FM2019 on Windows 11

New Here ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

Cannot install FM2019 on my new PC with Windows 11. Is there a fix, or I have to upgrade to FM2020?

Views

176

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Enthusiast , Mar 20, 2022 Mar 20, 2022
Regarding this error message you might want to check out this troubleshooting info:https://helpx.adobe.com/tech-comm-suite/kb/deprecated-internet-explorer-10-with-ims.html

Likes

Translate

Translate
Adobe Community Professional ,
Mar 11, 2022 Mar 11, 2022

Copy link to clipboard

Copied

FrameMaker 2020 (16.0.4) is Adobe certified for Windows 11. I don't know if people have figured out a way to get 2019 to work with Windows 11.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

Today I've installed FrameMaker 12 on my Win11-PC.

No Problems.

When updating to Win11, I already had installed FM2017, FM2019, FM2020.

 

No problems at all.

 

But how did you try to install?

I have noticed that when I install from a drive other than c:\, problems occur.
So I got into the habit of copying all FrameMaker installation files to a temporary directory (c:\temp) and only then running them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

Thank for the info. Based on your expereince, it seems that it is ok to update to Win 11 when FM2019 is already install. I am trying to install FM2019 on a new PC with Windows 11, and the installer gives this error message:

"Update required

Your browser or operating system is no longer supported. You may need to install the latest updates to your operating system.   Learn more"

 

But I already have the latest operation system. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 20, 2022 Mar 20, 2022

Copy link to clipboard

Copied

Regarding this error message you might want to check out this troubleshooting info:

https://helpx.adobe.com/tech-comm-suite/kb/deprecated-internet-explorer-10-with-ims.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2022 Mar 20, 2022

Copy link to clipboard

Copied

The fix worked. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

There are a few posts in the FrameMaker forum about FrameMaker and Windows 11.

When you search the forum with "windows 11" in double-quotes you find only these posts.

Possibly there is something which could help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

I had FM2019 (perpetual license)-Windows installed and working properly. I do not use FM very often but it is important to me. I updated from Win10 to Win11 and now FM does not work properly - it would crash. Ichecked the Updates and got the 'Update required' message. I have the latest OS updates installed. I read the answers below from Be.em and installed the updated AASIapp.exe. I've also updated the registry as suggested. 

I uninstalled FM2019 so as to be able to reinstall it. I re-downloaded the Framemaker_15_x64_LREFDJ file.

But now when I run the FM2019 Set-up.exe it immediately goes to the 'Update required' page with the only option to 'Quit'. So now I have nothing with no way forward.

Any ideas please?

 

PS I am also confused by the Adobe web pages which talk about 'Internet Explorer 11' being important - I thought this browser was out of date, superceded by Windows Edge/Bing. Also there is mention of Windows 10 but not Windows 11.

https://helpx.adobe.com/uk/x-productkb/global/update-operating-system-and-browser.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

As I've reported in this thread (the last three postings there, scroll down), the standard solution doesn't seem to work in all cases. I tried to install FM 2019 (also perpetual license) in a Win 7/64 environment, which was a supported platform when FM 2019 was released. I tried all the steps described in the standard solution, and failed miserably. It's simply not possible to get FM installed there, with the current solution set. I can imagine the same (or similar) problems are there with Windows 11.  I have been successful with installing FM 2019 in Windows 10, though, using the 3rd solution (replacing the set-up.exe).

 

I'm also wondering about the always repeated justification "it's only because Microsoft doesn't support IE10 any longer". No, this is not true. It's because Adobe Servers are set to no longer accept communication coming from IE10. You can easily confirm that when plugging off the internet connection for installing FM2019. Installation goes through smoothly, without any problem. But then you're stuck with having a demo installed. The problem is not installation, the problem is getting through to registration/activation on the Adobe servers. And this is nothing Microsoft has changed. By the way, IE11 (which is currently part of the solution) will be no longer supported by Microsoft in a few weeks, too. What will happen then?

 

Everything with FrameMaker registration/activation is tied to a certain 3rd party software tool. I don't know who ever might have thought that this is a great idea, making MY software depending on a 3rd party software application which has been outdated even when it was new… Internet Explorer, the GOAT browser.

 

Bernd

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

LATEST

Thanks Bernd, that was very helpful.

I tried installing FM2019 onto another PC, a Win10 laptop and hit the same update problem. I then went back to installing it (15.0.6.956) on my desktop and followed Bernd's advice and pulled the plug on the internet. This solved the 'not installing' problem but I still hit the 'Update required' problem and it crashed my working FM document with a 15084 error message. This apparently can arise for a large number of reasons (and so is pretty useless) but does produce a dump file. I then followed the 15084 discussions which recommended the latest version (Update 8, 15.0.8.979) which I installed (I thought I had the latest version earlier but did not). Update 8 is from

https://helpx.adobe.com/uk/framemaker/kb/framemaker-downloads.html

It installed Ok and the 'Update required' message disappeared. But I am still left with a 15084 error when I try to produce a pdf - it fails midway through producing the pdf.

So Bernd's suggestion that there is an Adobe server problem seems correct. It is not a Windows 11 problem as I originally thought. However, something must have changed with FM over the period I updated to Win11 to cause the new problem. So at the moment, I'm not sure whether my 15084 error is due to a server error or something else - though why a working fm document and a formerly working fm.exe should now cause a problem is a mystery.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

I believe that only the latest builds of FM2020 are Win11 certified/compatible. If you're running into that "Update your browser" misleading message, you'll need to follow the steps outlined in that helpx article @Be.eM linked to.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

No Jeff, as Bernd clearly explains - and have enough Web experience to judge that - the problem is at the registration servers. And Adobe does'nt seem to be willing to support even a current-1 version of FM...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Yes, I know that the issue is on the Adobe licensing end & the fix is by using the newer AASIAPP.EXE that the workaround provides. If it's still not working, then your only alternative is to contact the FM folks directly using the https://helpx.adobe.com/contact/enterprise-support.other.html#framemaker link. I'd recommend using the tcssup@adobe.com e-mail address.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines