how to get widow/orphan lines work in dita xml?

Contributor ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

I am using FM 2020 and would like to avoid having strange looking breaks in my text such as title (or title plus one line) at the bottom of a page and the rest of the content on the next page. In such cases what I would like to have is to see the title and the following content (i.e. body) on the next page. So I tried to increase the widow/orphan lines in the publishing template file (ChapterOutputTpl.fm) for the titles and body elements. It did not change anything. Am I missing something here?

TOPICS
PDF output , Publishing , Structured

Views

152

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

You might need to review the Keep properties for all the Paragraph Formats.

If, for example, ordinary Body has a Keep with Next, that might keep a following Heading1 on the same page.

When Keep/Widow/Orphan hints conflict, I'm not sure how FM prioritizes what to do.

I'm also not sure how Structured mode might alter the behavior.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Hi, thank you for the comments. I tried different options, no change occured. It is possible that this option is not active for structured FM. Unfortunately FM is not as complete when it comes to structured authoring (based on my experience in the past).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Are you able to see positive changes when you change Keep settings in your finished document? If so, you may be changing the wrong template because the changes should carry through to your published documents.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

Hi Rick, I also thought that I might be changing the wrong template. To check that under pagination in ChapterOutputTpl.fm I set the start of the title to top of the page. That happened immediately providing some level certainty that I am chaning the right template. Moreover, I applied the previously mentioned changes (keep, widow/orphan lines) to dita.template, dita1.3.template, section output and subsection output templates, I see no change.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2021 Apr 14, 2021

Copy link to clipboard

Copied

What happens when you make changes in the output document? Does it correct the pagination?

 

If it does, choose File > Import > Element Definitions and check Remove Overrides. This will "reset" the document to the default--and in some cases, undesired pagination. Now choose Structure > Show Element Context and start selecting some of the elements in the Structure View in the area where pagination has the undesired breaks. This will give you a window into the EDD and where the formatting is coming from. This will allow you to see which formats and/or EDD formatting that you may need to change.

 

If you want to do a web meeting, I will be glad to look at this with you. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 19, 2021 Apr 19, 2021

Copy link to clipboard

Copied

Hi Rick, thank you for your help. That would be great if we can do a web meeting. When is it possible for you?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 21, 2021 Apr 21, 2021

Copy link to clipboard

Copied

I think I know now a bit more about this topic. After modifying the ChapterOutputTpl.fm template, used for publishing, and increasing the number of widow/orphan lines from the default value which is 2 to 5 for instance, the "normal" paragraphs follow the new settings. By normal paragraphs, I mean the ones without line interruptions. But I have also paragraphs where I use the lines element in order to impose a line break inside the paragraph. In such cases it does not follow the widow/orphan lines settings. I guess the reason would be the fact that FM considers these as unconnected lines.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

LATEST

Did you import the updated template into the settings file for publish?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines