Order of entries in catalogues

Adobe Community Professional ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

In my post about Tagging and untagging objects Bob Niland states

«If one wants the null Style to float to the top of the Catalog menu, it appears that the name has to start with an ASCII numeral, perhaps "0". Perhaps: 0_{Empty}»

This puzzled me and therefore I tested these names of ¶ formats and got this order on my English FM:

!_Null

0Chapter-title

Äffchen

Body

bodytext

ztf-table-footnote

βgeuze
→ This is not the Unicode order (see the location of Äffchen before Body). It is ordered according to the index entries for English: <$symbols><$numerics><$alphabetics>

Views

32

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

Now that's odd, because on my machine, 0 is sorting before alphas, which sort before ! (as well as before . _ and =).

I have not extensively tried Unicode names. Where FM supports the codepoint, they at least work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

Bob, I may have found the reason for this. In my local maker.ini I have this setting in [Preferences]:

SymbolSortingBeforeAlphaNumeric=On

Obviously defaault is Off - your sequence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

LATEST

re: SymbolSortingBeforeAlphaNumeric=On
Yep. The
C:\Program Files\Adobe\Adobe FrameMaker 20■■\maker.ini
was at installed with what I presume is the factory default of:
SymbolSortingBeforeAlphaNumeric=Off
The
C:\Users\■■\AppData\Roaming\Adobe\FrameMaker\■■\maker.ini
has no entry at all for that, thus using parent file default of Off.
Adding the …=On expression makes it behave as yours does.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines