• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

question about Mini TOC

Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hello,

 

I have created two paragraph style :

- Test P1 (for Chapter 1, Chapter 2, etc ...)

- Test P2 (for 1.1 ,  1.2  , etc ...)

And I have created a Mini TOC with :

- Test P1

- Test P2

- Hypertext link is checked 

 

screenshot-14-46-13.jpg

But here is the result : 

- FM add a number "1" at the begining of the MTOC

-  FM add a number "1" at the end of each line

- I have no hyperlink inside the MTOC 

 

screenshot-14-47-27.jpg

And here is what I have in page reference :

 

screenshot-14-53-13.jpg

Why do I have this result ?

 

TOPICS
Getting started

Views

274

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Jun 05, 2024 Jun 05, 2024

Nice! I was typing while you were posting, so now it's down to the empty ¶ on the body page. 

 

Are the hyperlinks working after the update? Are you testing them by holding Ctrl + Alt as you click on one?

 

If not, please share that last screen shot again after you remove the ¶, but with text symbols showing.

 

~Barb

Votes

Translate

Translate
Community Expert , Jun 05, 2024 Jun 05, 2024

It looks like you have an empty paragraph above your Chapter 1 heading paragraph. It has one of the paragraph formats in the Include list applied to it, and that is why you get an empty TOC paragraph with just the page number.

Votes

Translate

Translate
Community Expert , Jun 05, 2024 Jun 05, 2024

Hi Pierre:

 

You can add the blue color to the paragraphs, or just to the page numbers.

  • If you add it to the paragraphs as a paragraph style, you can do it either on the body pages or the reference pages.
  • If you want to add the blue to just the numbers, you can select them on the reference page <$pagenum> and assign a character style. Something to be aware of though, is that if you add a character style to a paragraph, the only clickable area will be within the character style. That means reade
...

Votes

Translate

Translate
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

I gone in references page and added some points between paratext and pagnum, and I have updated the MTOC,  so here is the result :

 

screenshot-15-52-56.jpg

But always these two problems :

1) at the begining of the MTOC I have a number "1"

2) no hypertext links

Why ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

It looks like you have an empty paragraph above your Chapter 1 heading paragraph. It has one of the paragraph formats in the Include list applied to it, and that is why you get an empty TOC paragraph with just the page number.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Salut Pierre!

 

Thanks for starting out by showing us your reference page—that's the issue, of course. You results look confusing but Fm is doing what you are asking. The 1 at the end of the lines is the page number. Fm defaults to spaces between text and page numbers, you need to replace it with a tab and set the tab stop.

 

TestP1MTOC should look like this:

 

<$paratext>\t<$pagenum>

 

where \t is a tab character. You can type in the \t or just press the Tab key on the keyboard. In either case, you will need a right-align tab stop defined for the style.

 

TestP2MTOC should look like this:

 

<$paratext>\t<$pagenum>

 

again, you need to remove the space and add the tab. Then set the tab stop.

 

The 1 at the very top reflects that empty ¶ at the top of your first screen shot. No text, so Fm is just showing the page number. Head back to the body pages, View > Text Symbols to see it, and then remove it. 

 

After making these changes, right click the MTOC on the body pages and update. This should straighten out the presentation. Let's deal with the links after it looks the way you want.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Nice! I was typing while you were posting, so now it's down to the empty ¶ on the body page. 

 

Are the hyperlinks working after the update? Are you testing them by holding Ctrl + Alt as you click on one?

 

If not, please share that last screen shot again after you remove the ¶, but with text symbols showing.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

It's early here.—still drinking my coffeee. Just registered the words "added some points".

 

You probably fixed this by now, but that should be a tab and you want to add a leader dots on the tab stop and not press . . . . . . . . . . . on the keyboard. If you were to keep that, the page numbers would not align correctly, nor would the periods (points).

 

I can make a quick video if you need it. Just let me know. 

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hi Barb, Hi All,

Oh I see ... 9 AM at Evergreen . Here in France it is 5 PM. Personally, the morning I take a hot drink that is a mix between chicory and cereals.

About FM, in page references, I have removed the points (made by using the keyboard), so I have no space between paratext and pagenum, and I have added a tab stop by clicking in the top ruler for each line :

 

screenshot-17-03-08.jpg

And here is the result in the body page. You can see also the text symbols :

 

screenshot-17-03-56.jpg

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

And I have just seen that on the MTOC if I do Control+Alt and click on by example "chapter 1", it goes to "chapter 1" where "chapter 1" is in bold. I thought that all the MTOC content were in blue color (as it is hypertext links).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hi Pierre:

 

You can add the blue color to the paragraphs, or just to the page numbers.

  • If you add it to the paragraphs as a paragraph style, you can do it either on the body pages or the reference pages.
  • If you want to add the blue to just the numbers, you can select them on the reference page <$pagenum> and assign a character style. Something to be aware of though, is that if you add a character style to a paragraph, the only clickable area will be within the character style. That means readers wouldn't be able to click the text and follow the hyperlink. They have to click on the colored page numbers.

 

Now, let's look at your first screen shot in your last post. You are very close. Double click the tab arrow you are pointing at below the ruler, change the alignment to right (first column), add the leaders (second column) and adjust the tab position. This is adding an override so be sure to update the paragraph style once you like how it looks. (That's why the body page didn't update in your second screen shot.) 

 

Repeat for the other paragraph style, update the paragraph style and then update the MTOC. 

 

Let us know how that goes, and I'm curious what the name of your chicory/cereal drink is? I'm not a fan of chicory as a coffee replacement, but I suppose it is healthier?

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hi Barb,

In References pages, I have selected the two lines, and clicked on the top ruler to select a tab stop for the two lines.

Then I double clicked on the top ruler tab stop, and selected right (in left column) and the leaders (in right column) :

 

screenshot-19-17-09.jpg

 

Result in References pages :

screenshot-19-17-52.jpg

And I have updated the paragraph style in reference page for each line.

The result in body page :

 

screenshot-19-19-23.jpg

Now, about the blue color, in reference page I have set the font in paragraph style (for each line) on "blue" and "bold". But I see that only paratext and pagnum are in bold blue (the leaders are only blue but are not in bold. Why ?) :

 

screenshot-19-39-12.jpg

I updated paragraph style in page reference and here is the result in body page :

 

screenshot-19-39-40.jpg

Finally, I have removed the paragraph symbol at the blue arrow, so here is the final result (the begining of the MTOC does not display the page number "1") :

 

screenshot-19-44-19.jpg

And about the drink (mix of chicory and cereals), I give you the manufacturer page (it is made by Nestlé) : https://www.nestle.fr/media/pressreleases/caro-devient-ricore-cereales-chicoree

As I cannot drink coffee and tea, I have found this drink, and I think it is better for health. And I don't taste the chicory (chicory is at 14%).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Wow, Pierre. You have made great strides today! 

 

What you are showing for the blue/bold combination looks correct in the Paragraph Designer but it should impact the entire line. Remove any character styles that might have been applied first and then try one more time—you must be tired by now so added a video to make it easier for you. Or wait until morning. We'll be around if you need a hand.

 

~Barb

 

2024-06-05_12-50-48.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

How to remove any character style ? Is it (in reference page) by selecting the text and use the  "default" tag (in character catalog) ?

I have tried again (like in your video) to use blue/bold in reference page for paragraph style, but it did not succeeded.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Hi Pierre:

  • Triple click TestP1MTOC on the TOC reference page.
  • Click on Default ¶ Font in the Character catalog.
  • Then click on TestP1MTOC in the Paragraph catalog to reassign the style.

 

That should do it, but if it doesn't, don't waste your time. Just email me the file and I'll take a look. I think you have my email.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2024 Jun 06, 2024

Copy link to clipboard

Copied

Hi Pierre:

 

This is what I see when I open your file—without doing anything at all:

 

2024-06-06_07-14-30.png

 

I'm thinking it is a screen display issue on your end. Try zooming in, File > Print or File > Save as PDF. Do you see the blue/bold leaders after any of those steps? I didn't find any overrides so I think FrameMaker isn't sharing an accurate display.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 06, 2024 Jun 06, 2024

Copy link to clipboard

Copied

Hi Barb,

With FrameMaker I am working on a 15" laptop at a zoom of 110%, and here is what I have :

 

screenshot-18-51-16.jpg

You are right ! By changing the zoom by example to 190% , I have this in FrameMaker :

 

screenshot-18-50-41.jpg

And with the sam zoom (190%) in Acrobat Pro :

 

screenshot-18-50-17.jpg

Do you think the cause is that I have a too small screen, or are there some display issue ?

 

I am happy to know there are no overrides. About the overrides, if I understand well, to remove them, I have simply to update the paragraph style or character style ? Or are there some other solutions ?

To prevent overrides, have you some advises to give me ?  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 06, 2024 Jun 06, 2024

Copy link to clipboard

Copied

Hi Pierre:

 

A larger monitor is more comfortable to work on, as is access to additional resolution. The screen shot I shared this morning was also on a 15" laptop display, but the resolution was set to 2560 x 1600. It goes all the way up to 3840 x 2400 which works great for me when I'm working but too small for my students to see comfortably when I'm sharing my screen. Almost all of my students have two or three displays these days, which is another option.

 

As for the overrides, this gets tricky. Most of the time if I select a paragraph and click on Default ¶  Font and then reassign the paragraph style, that takes care of it. Sometimes I notice that the overrides linger, so like you, I work with the Text Formatting toolbar open. I know what the type face and size I should be using and if I see the wrong one, I fix it. 

 

There is another feature that's worth noting. In Find/Change you can search for overrides and remove them. FrameMaker lets us search/remove paragraph style overrides, character style overrides, table style overrides and object style overrides. I went ahead and ran the first two of those on your file and while it found a lot of overrides on the reference pages —these are built into new FrameMaker documents for some reason and a mistake on your part—It did not find any problems with your text.

 

~Barb.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 06, 2024 Jun 06, 2024

Copy link to clipboard

Copied

Hi Barb,

First thing : a big thank you for your help. You are always very clear in your explanations.

So you are working on a 15" laptop. When I see your videos on youtube, it is like if you had a more big screen. Is it because you have changed its resolution ? And what software do you use to do your videos : is it Captivate or other software ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 07, 2024 Jun 07, 2024

Copy link to clipboard

Copied

LATEST

Hi Pierre:

 

I use two different applications for recording, both from https://www.techsmith.com/: SnagIt and Camtasia. 

  • On the forums, I use SnagIt to pull screen shots and for my 30-second demos. It's quick and easy to use. 
  • For the webinars, I use Camtasia. It's a video editor that is geared towards creating online video content. 

 

I record all FrameMaker content on that 15" display. I increase the resolution when I'm working alone (to get more screen space), but decrease it for my classes and for all of the content I share online.

 

And thank you for the complement. I mean it when I say it made my day. 😊

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines