Highlighted

Odd published result of cross-reference format conversion

Explorer ,
Jan 12, 2018

Copy link to clipboard

Copied

Hello. Here is a strange problem ...

I am using FM 2015 in a Win 10 environment.

My document uses cross-reference formats that sometimes include a page number variable.

This cross-reference setup:

<Hyperlink>Figure\ <$paranumonly> on page\ <$pagenum><Default Para Font>

produces this cross-reference in the .fm file:

CrossRefInFMFile.jpg

For online help, I want only the figure number with no page number. In the Publish Settings/Style Mapping options, I select <$paranum> only:

FigNumPageConversionSetting.jpg

The result consistently appends empty spaces to the link. I can't figure out where they are coming from. (This problem does not occur when I convert my HeadingPage formats, which follow almost the exact same pattern.)

ConvertedCrossRefWithEmptySpaces.jpg

I would think the spaces come from the spaces in the cross-reference format (like the space between "on" and "page") but, as I say, the same result does not occur with my HeadingPage conversion.

All suggestions welcome. I'll simply create parallel xrefs and put conditions on them for the different outputs, if I must, but the conversion settings are so much easier when they work ...

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Can you show us your Auto-number properties of the figure numbers in Para Designer?

~Barb

Views

147

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Odd published result of cross-reference format conversion

Explorer ,
Jan 12, 2018

Copy link to clipboard

Copied

Hello. Here is a strange problem ...

I am using FM 2015 in a Win 10 environment.

My document uses cross-reference formats that sometimes include a page number variable.

This cross-reference setup:

<Hyperlink>Figure\ <$paranumonly> on page\ <$pagenum><Default Para Font>

produces this cross-reference in the .fm file:

CrossRefInFMFile.jpg

For online help, I want only the figure number with no page number. In the Publish Settings/Style Mapping options, I select <$paranum> only:

FigNumPageConversionSetting.jpg

The result consistently appends empty spaces to the link. I can't figure out where they are coming from. (This problem does not occur when I convert my HeadingPage formats, which follow almost the exact same pattern.)

ConvertedCrossRefWithEmptySpaces.jpg

I would think the spaces come from the spaces in the cross-reference format (like the space between "on" and "page") but, as I say, the same result does not occur with my HeadingPage conversion.

All suggestions welcome. I'll simply create parallel xrefs and put conditions on them for the different outputs, if I must, but the conversion settings are so much easier when they work ...

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Can you show us your Auto-number properties of the figure numbers in Para Designer?

~Barb

Views

148

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 12, 2018 0
Adobe Community Professional ,
Jan 14, 2018

Copy link to clipboard

Copied

Can you show us your Auto-number properties of the figure numbers in Para Designer?

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2018 0
Explorer ,
Jan 15, 2018

Copy link to clipboard

Copied

Hi, Barb.

The auto-numbering properties include spaces:

CaptionAutonumberProperties.jpg

Holy cow, that was it. The cross-reference pulls in everything in the autonumber format. Dang, this means I'll have to redo everything and insert the spaces in the text instead of having them inserted in the format itself. However, this solves my problem.

Thank you!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2018 1
Adobe Community Professional ,
Jan 15, 2018

Copy link to clipboard

Copied

Great news, Nancy. Glad you are back on track.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2018 0
Adobe Community Professional ,
Jan 14, 2018

Copy link to clipboard

Copied

Try mapping to <$paranumonly>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2018 0
Explorer ,
Jan 15, 2018

Copy link to clipboard

Copied

Hi, Matt.

I got the same result. However, Barb put her finger on the problem!

Thanks for all your help on this question and others.

--Nancy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2018 1