3D and materials Revolve (or Lighting) issue

New Here ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

I want to create a hollowed out tube section in illustrator. The first steps (Revolve with a Revolve Angle of 180° and a bit of offset) works find:

nuklearwanze_1-1663579245950.png

However, I am not able to get the lighting correct. I want to show the hollow side of the tube lit up. Unfortunately I can't figure out how to get the light source to the correct position. it seems i can only light the object from the "front", not the "back" and there doesn't seem a way to rotate the object facing away from the camera. (you cant set negative values in most boxes in the 3d-panel.

Here is the view i want to create - just with the light lighting the side that is curved inward (not the side that is curved outward.

nuklearwanze_2-1663579623884.png

Changing any of the sliders will not move the light source over to "my side" (behind the virtual camera). I think the main issue here is that under the Object tab in the 3D-panel you can only rotate the camera around, not the object. And the light source does not move with the camera. so you are stuck with a lightsource that is locked to the default view plane.

I just hope that I'm missing something here.

 

 

TOPICS
Draw and design , Tools

Views

39

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 20, 2022 Sep 20, 2022

Copy link to clipboard

Copied

Edit the shadow settings.

There are two: Shadow on the wall and shadow on the ground. Change it to the other option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

It's not about the shadows. Those are not even turned on on the example images (as you can see on the included settings panel). Its about the actual shading. There really seems to be no way to rotate the light source all the way around an object.

 

Seems like such a weird oversight.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

Yes, it is about the shadows. I had the exact same problem as you and it is caused by the shadow. Set it to the other position.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

so, I just tried it again - just in case I did something wrong:

Turning on shadows does indeed move the lightsource to the correct location. unfortunately, as soon as you turn off the shadow "below object" it reverts back. As I dont want a shadow (not even self shadowing) this is not an option.

This behaviour clearly is a bug - I'll write a bug report

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

LATEST

Does it work using the 3D Classic effect instead of the new 3D?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines