Can't disable snap to point

Explorer ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Hello,

I have disabled snap to point under View and also the Smart guides are off, however it still snaps to points

Can't find how to turn this off for days.

BTW align to pixel grid is also off!

Thanks in advance!

Views

7.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , May 31, 2017 May 31, 2017
In that case open Preferences > Pen tool and anchor point display and turn off snapping there.

Likes

Translate

Translate
May 31, 2017 May 31, 2017
Hi AgrisCaurs,Here's a screenshot for Monika's suggestion. Do share if that resolve your issue.Regards,Om

Likes

Translate

Translate
Adobe Community Professional ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Which version, which system?

What exactly is happening?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Illustrator CC2017 (2017.0.2)

When using pen tool and creating new points the cursor snaps to points of other shapes although "Snap to point" under view is disabled and Smart Guides are off.

If necessary I can do a screencapture to show it.

Thankyou

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

In that case open Preferences > Pen tool and anchor point display and turn off snapping there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

Hi AgrisCaurs,

Here's a screenshot for Monika's suggestion. Do share if that resolve your issue.

Capture.JPG

Regards,

Om

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

I had the same problem and the 'Answer' did not help.

...What did help was disabling "Highlight anchors on mouse over" in the same Preferences section.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2018 Dec 06, 2018

Copy link to clipboard

Copied

Unchecking that box had no effect for me either and I feel like it absolutely should have. Not to mention the other couple places where you can turn snap to points off. The snapping was driving me crazy. "...What did help was disabling "Highlight anchors on mouse over" in the same Preferences section."  Thanks a bunch

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

Didn't worked for me... Pen tool is jumping even after turning off snap and highlights. Any idea what should I do? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2020 May 12, 2020

Copy link to clipboard

Copied

Yes!  Thank you.  My biggest wish is for there to be ONE place to toggle snaps, please!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Thank you! This worked for me too!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

This worked. It's been an issue for a few years now, and I've been having to zoom in considerably just to avoid it from snapping to itself. 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

This solved it for me in the 2022 version! Thanks Tommy!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

Thank you! This has been driving me crazy. This should be under the view menu with the other snapping preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2022 May 22, 2022

Copy link to clipboard

Copied

LATEST

THANK YOU!!! Millions of thank you's! For the past few years, I have occasionally tried once again to find an answer to this very frustrating and unwanted default. Disabling "Highlight anchors over mouse" was the magic and mysterious change I needed to make. I wish I could tell you how awesome this is for me to finally discover. Thanks again!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2018 Nov 20, 2018

Copy link to clipboard

Copied

In the new version for CC 2018, this section in the preferences tabs no longer exists and I still can't remove the snapping problem even though I have removed the snapping from View> Grids and Guides and unticked Snap to Guides! If anyone has a solution for this please let me know.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

In the Creative Cloud you have to go to Preferences > Tools and disable Snap Vector Tools and Transforms to Pixel Grid.

 

Screen Shot 2021-10-20 at 8.38.27 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Are you sure that your post is about Illustrator?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

That is for Photoshop. This is the Illustrator forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

As someone who googled this question in regards to photoshop - it has led me to this post.. but it was this comment that answered my question at the very least - so thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines