clipping mask line showing

New Here ,
Jan 26, 2018 Jan 26, 2018

Copy link to clipboard

Copied

How do i get rid of my pesky circular clipping mask line, showing at the bottom of my wave. I've saved it as .pdf and .png and still shows. I've scaled it up and down multiple times and still wont go away. i don't recall this every happening before with clipping masks. so weird and frustrating. AI file download if you want to try playing around with it.

Artboard 9-100.jpg

Thanks!

Views

3.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 26, 2018 Jan 26, 2018
That is an anomaly with clipping masks.You can use the transparency palette instead if that really bothers you, but the thin line will not print or export to bitmapped format. release clipping mask fill path with black groups colored items underneath if needed select both your graphics, and your mask. In transparency palette >> make mask then check both checkmarks in transparency palette

Likes

Translate

Translate
Adobe Community Professional ,
Jan 26, 2018 Jan 26, 2018

Copy link to clipboard

Copied

This has alway happened.

You can try and flatten it using the pathfinder "Crop" and then delete everything you don't need.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2019 Oct 16, 2019

Copy link to clipboard

Copied

Flatten, crop and delete is not a good suggestion. It's simply too convoluted and destructive to the image for it to be a good solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2018 Jan 26, 2018

Copy link to clipboard

Copied

Although it is just a display issue, it may be a bit irritating.

There are a couple of ways to hide it, for example:

  • Apply a white stroke to the clipping path (1 pt should be sufficient). Of course, that may not be desired if the clipping group is on top of other filled objects.
  • Or: Apply Pathfinder Crop to the entire clipping group, but not in the Pathfinder palette. Use the Pathfinder Crop effect in the Effect menu. That way no (probably undesired) flattening will happen.
  • Or: Use the Rasterize effect temporarily (see Effect menu).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2018 Jan 26, 2018

Copy link to clipboard

Copied

That is an anomaly with clipping masks.

You can use the transparency palette instead if that really bothers you, but the thin line will not print or export to bitmapped format.

  1. release clipping mask
  2. fill path with black
  3. groups colored items underneath if needed
  4. select both your graphics, and your mask. In transparency palette >> make mask
  5. then check both checkmarks in transparency palette

Screen Shot 2018-01-26 at 1.54.30 PM.png

Screen Shot 2018-01-26 at 1.53.12 PM.png

Screen Shot 2018-01-26 at 1.53.21 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2019 Oct 16, 2019

Copy link to clipboard

Copied

First, thanks Mike for providing a workaround to the problem. It really shouldn't be necessary to go through these steps, but it's better than anything else I've heard or seen and that includes 4 hours through Adobe tech support chat (those guys don't have a clue).

 

Why on earth do people keep calling this a display issue? If I can see it, it's a problem.

 

And please people, try not to give advice that goes against everything designers are trying to do. What I mean by that is we're trying not to be destructive and we want the image to be flexible so we can move elements around freely. Flatten, crop, delete goes against that strategy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2019 Oct 16, 2019

Copy link to clipboard

Copied

When I export from Illustrator using this technique and open it in Photoshop, it's semi transparent. Any ideas?

 

It's also not exporting to the size of the area that should be masked. It's a small detail, but it adds another step in Photoshop to get the crop just right.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

LATEST

I had the same issue with a round flag for the website. I used Trim on the pathfinder and all super good.Screenshot 2022-05-19 at 17.40.42.pngScreenshot 2022-05-19 at 17.41.01.pngScreenshot 2022-05-19 at 17.41.28.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines