• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Compound path not working when used as clipping mask

New Here ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

Hey guys,

 

I'm still learning how to use illustrator but I created a compound path from a hexagon with a hole at the top (to be a keyring). The issue is that when I try to use this as a clipping mask, the hole at the top doesn't seem to be registering as the clipping mask if that makes sense. The screenshot with the red outline is the compound path which I placed over a green square, but when I use it as a clipping mask, as you can see in the other screenshot the hole remains filled in. Does anybody know how I can fix this or what I might be doing wrong? I need the hole to remain a hole/transparent. Any help would be appreciated!Clipping mask.pngCompound path.png

TOPICS
Draw and design , Tools

Views

4.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Aug 05, 2021 Aug 05, 2021

Select your compound path (red stroked shapes) and use a fill instead of a stroke (Shift+X) to check if the hole is filled or not.

If it is filled, perhaps look in the Attributes panel and change the fill rule to Even-Odd.

 

I'm not 100% sure why you need it to be a clipping path if you're just filling it green, but perhaps there's something you're not telling us.

Votes

Translate

Translate
Community Expert , Aug 05, 2021 Aug 05, 2021

You may try to select your compound path/clipping mask and change the attributes in the Attributes panel.

Screenshot 2021-08-05 at 14.13.56.png

Votes

Translate

Translate
Adobe
Community Expert ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

Select your compound path (red stroked shapes) and use a fill instead of a stroke (Shift+X) to check if the hole is filled or not.

If it is filled, perhaps look in the Attributes panel and change the fill rule to Even-Odd.

 

I'm not 100% sure why you need it to be a clipping path if you're just filling it green, but perhaps there's something you're not telling us.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Haha was just filling it green as an example to show what I meant, but thank you the fill rule to even-odd fixed the issue!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

You may try to select your compound path/clipping mask and change the attributes in the Attributes panel.

Screenshot 2021-08-05 at 14.13.56.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

This fixed the issue- thank you!!! Can't tell you how long I've been stuck on trying to figure it out

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

Good to hear that helped.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2023 Feb 01, 2023

Copy link to clipboard

Copied

LATEST

You saved my day, thank you very much!

 

I cannot find the button at 1st, and found out need to click Show All for the options.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

Looks like your compound path is fouled up from the start. 

  1. Draw your 2 shapes from scratch (as I don't know what rough life your paths have been through, and they might have items assigned that you would see in appearance palete)
  2. Fill the circle with a different color so you can 100% confimr it is on top
  3. select both
  4. option command 8 to make compound

MikeGondek_0-1628166023804.png

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

I think the compound path was buggered as the other shapes I created didn't have the same issue- but using the even-odd rule fixed it 😃 thank you for your suggestion though!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

aiturtle,

 

You can always use Pathfinder>Minus front if you have trouble making a Compound Path with a hole.

 

Still trying to spot a hexagon.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Hahaha I'm a tard sometimes *rhombus

But thank you yeah I've played around with minus front 😃 will remember that for next time

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

For my part you are welcome, aiturtle.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines