GPU glitch in Illustrator 25.3.1 weird corners/ jagged lines/ weird artifacts

New Here ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Since the latest update I get weird effects when using pathfinder (trim/divide) for instance. Is there any know issues? Se attachements. The object when using divide gets weird corners, what am I doing wrong? Never seen this before. Any suggestions? Thanks.

 

Skärmavbild 2021-03-24 kl. 14.34.44.pngSkärmavbild 2021-03-24 kl. 14.35.43.png

 

{Renamed by MOD}

TOPICS
Performance

Views

1.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Mar 24, 2021 Mar 24, 2021
Without seeing Layers Panel, Stroke Panel Appearance Panel and object selected it is very hard to say. Are there strokes involved? Are these real paths? Check it with [Strg/Ctrl]+[Y]  (Outline View) Is this a problem with GPU? Try to toggle with [Strg/Ctrl]+[E]  (Preview on CPU/GPU)

Likes

Translate

Translate
Adobe Employee , Jul 08, 2021 Jul 08, 2021
Hi all,     Sorry about the inconvenience this issue has caused. We are currently investigating this issue. Till the time it is fixed, please try the workaround shared by @pixxxelschubser  Turn off GPU performance from Illustrator Preferences (CMD+K > Preferences > Uncheck GPU Performance). I would also request you to upvote this issue here ( https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/43599609-sharp-corner-edge-displaying-wrong ) and stay tuned for up...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Does settting the Precision to something small like 0,001 in the Pathfinder Options help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Without seeing Layers Panel, Stroke Panel Appearance Panel and object selected it is very hard to say.

  • Are there strokes involved?
  • Are these real paths? Check it with [Strg/Ctrl]+[Y]  (Outline View)
  • Is this a problem with GPU? Try to toggle with [Strg/Ctrl]+[E]  (Preview on CPU/GPU)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Thanks a lot. It was in GPU Preview, had no idea that would mess with the geometry like that. Anyways, thanks a lot for the quick reply!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Hi.

I think something changed in the code of the boolean functions. There is an example that I have used in my classes for more than ten years, and last Thursday, the result was disastrous. I had to stop the class and record a video after I discovered how to solve the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

I get this exact same issue since an update around this time... I'm using a iMac Pro with 32GB RAM so it really should handle this kind of stuff...

 

I found that switching off GPU Preview fixed this as well but now Illustrator is unuseably laggy since the update.

 

Is there a better solution?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

Had the same problem here.
Happy to found the solution here but quite annoyed with team Illustrator as I don't understand why the option of GPU Preview is still in (for many versions) as it's causing these issues. If it doesn't work; trash it. Sorry had to vent.



Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

LATEST

It is a tradeoff between speed and accuracy and a work in progress.

I like the speed and switch temporarely between CPU and GPU when I don't trust the preview (Cmd or Ctrl E).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Hi there i found a very annoying BUG. When you try to split a circle with the pathfinder tool, he adds a little extra on the tips of the stroke. Please help me to solve it. 

 

Schermafbeelding 2021-07-05 om 16.30.50.pngSchermafbeelding 2021-07-05 om 16.32.00.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Try if it is still visible when you switch to CPU Preview (Cmd or Ctrl E)

And/or set the pathfinder precision from the panel menu PathfinderOptions  to a small value like 0,001 pt.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Heej Tom setting the precison to 0,0001 did not made any difference. However it is indeed not visible when i switch to CPU preview. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Then it is just a preview glitch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Hee Tom,.. it is strange i have really never noticed this?! Is it gone when i am going to send this to a printer?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

It will be OK to send it to a printer, it is a GPU preview problem.

Using the power of your graphics card, Illustrator can speed up the display.

Unfortunately speed does not always mean accuracy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

Any one can solve this white patches in Illustrator (100pt stroke used)

AbdulRehaman_0-1625213770407.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

Have you tried switching from GPU to CPU in your viewing options?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

I have the same problem and tried it but it's still the same

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

All vector lines are highlighted in red.  No stroke.  Moved accender on "N" and illustrator keeps glitching out.  Can't get rid of it.  Any suggestions?

 

I need to send the client a proof but I can't because of this glitch.

 

Illustrator Sucks 1.jpgIllustrator Sucks 2.jpgIllustrator Sucks 3.jpgIllustrator Sucks 4.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Please try View > Preview on CPU

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Recently updated iMac (27-inch, Late 2012) to latest software along with illustrator, measurements now do not have live displays and are replaced with grey boxes whenever using pen tool, line tool and box draw tool.

 

I have seen that it may be due to my graphics card but havent had this problem before?

 

Is my mac now out of date??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Hi. Make sure that the Graphic Card has the latest driver available installed. Also, disable "GPU Performance" in Preferences > Performance and check if the issue persists.

 

 

Marlon Ceballos.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Hello,

When I use pathfinder (minus front), the forms makes an undesirable corner.
How can I fix it?

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

@defaultnej2ibujqdg2 Could be several things but I'm assuming you already checked your layers panel to make sure there isn't another shape you didn't delete underneath the forms. Is that little corner showing up when you export the file? Next will be checking your GPU settings and possibly a preferences reset. Let us know what version and OS you are using and if you need more troubleshooting help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Hi, 

The little corner disappear in CPU mode and is not there on an hi-res pdf.
I'm using MasOS Mojave and Illustrator 2021 (25.3.1).

Thanks for you time and answer!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

Do I see right? 3 objects: 2 triangles and one rectangle? Can you share screen shot before using pathfinder?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines