Hebrew punctuation

Community Beginner ,
Nov 25, 2019 Nov 25, 2019

Copy link to clipboard

Copied

Hi, I have a problem writing in hebrew, which is written right to left (same as Arabic). Illustrator is installed as "English-with Hebrew support", I've added Indic options and changed it to "Middle eastern & South Asian single line composer" in the paragrph menu (fugure 1), but a period or a comma at the end of the sentence appears on the wrong side. There are some buttons missing (fugure 2). I'm using Illustrator 23.1. Indesign works fine with hebrew. 

Anyone had this problem?

TOPICS
Bug , Tools , Type

Views

1.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 03, 2019 Dec 03, 2019

Ok, so I contacted Adobe, They were very helpful. Apparently I had to uninstall, log out of CC, log back in and reinstall for the CC language settings to take affect. 

Likes

Translate

Translate
Community Expert ,
Nov 25, 2019 Nov 25, 2019

Copy link to clipboard

Copied

From the Paragraph Panel menu ( at the the top right of the menu ) you can change between the 4 composers options till you get your text good directions and working well with digits and prackets.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 29, 2019 Nov 29, 2019

Copy link to clipboard

Copied

Hey Omar,

Thanks for your reply. I'm not sure what composers options you mean, but I've tried different alignment options and none worked.

 

זאת. דוגמה...

 

So the dot at the middle of the line is where it should be, but the three dots on the right should be at the other end of a sentence. 

On a different pc at my department the buttons marked on the image I added fixed that, but I can't seem to fo find them here. 

 

Any Ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

Ok, so I contacted Adobe, They were very helpful. Apparently I had to uninstall, log out of CC, log back in and reinstall for the CC language settings to take affect. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

LATEST

Having this same problem. Have installed/reinstalled a few times over the last few years, on multiple machines. I've also used every available composer and tried to install others. None of these routes have had any meaningful effect on punctuation correctly matching the language in InDesign.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines