How to save an Ai-file with transparent background WITHOUT exporting?

New Here ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

At my work we use ai-files for links in a lot of different projects – both for prints and digitally –, and we constantly update our files with new info, so having to export all the time is NOT an option.

 

Till now I have been able to just save it as an ai-file with no background, but now suddenly it keeps saving it with a white background – even though there isn't one in my layers or on the artboard. 

I can't find any articles explaining how or why – so hopefully some of you can help me figure it out?
Thanks. 

TOPICS
How to

Views

140

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 15, 2022 Jul 15, 2022

@Ton Frederiks post is referring to the Show Import Options when placing a file into InDesign. AI files are controlled by the PDF settings. Check to see if the Transparent Background is on.

image.png

 

Likes

Translate

Translate
Adobe Community Professional ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

What are you using the AI file in that you see a white background?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

InDesign and also when I just preview the file.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Check the options in InDesign when placing the file. They are sticky, so when changed they stay that way.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

@Ton Frederiks post is referring to the Show Import Options when placing a file into InDesign. AI files are controlled by the PDF settings. Check to see if the Transparent Background is on.

image.png

 

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2022 Jul 16, 2022

Copy link to clipboard

Copied

Sorry, I just need to follow; When I place an ai-file in InDesign the "Place PDF" option should pop up – or where do you find this? 'Cause, when placing I am not given this option. 🤔

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2022 Jul 16, 2022

Copy link to clipboard

Copied

LATEST

When Place is selected you need to click Options to get the Show Import Options checkbox.

Check that box, select an .ai file and click Place to get the dialog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

schuuulz,

 

What happens if you View>Grid or View>Transparency Grid?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Same. I tried after seeing an article about it. But didn't do the trick.. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Hello @schuuulz,

 

Sorry to hear about this experience. Are you experiencing this behavior with all of your files? If yes, kindly try resetting Illustrator's preferences by following the steps shared in this article (https://helpx.adobe.com/illustrator/kb/troubleshoot-preference-issues.html) and sharing your observations.
Disclaimer: Please note that resetting preferences will remove all custom settings, and Illustrator will launch with the defaults. You may take a backup of these settings from the location mentioned in the article.

Looking forward to hearing from you.

 

Thanks,
Anubhav

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines