• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

illustrator 2018 - eyedropper tool doesn't pick-up properties

Community Beginner ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

Hi,

I've updated to the latest version of illustrator 2018 and found a bug relating to the eyedropper tool.

It doesn't pick up the properties especially with text styles. I have one style of text, use the eyedropper to copy the style to the other and doesn't work.

It picks up colour but very oddly picks up shades as well and not the solid colour of the object.

How do I fix it or must i wait for an update?

thanks

TOPICS
Tools

Views

19.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Engaged ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

If you double-click on the eyedropper tool, and view the options, is everything selected?

Image 1276.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

Yes, everything is selected, I've checked and unchecked it, I've closed the programme, I've shut down as well.

While writing this, it seemed to have worked now thanks, but its so buggie though. Will i have to redo this every time I open a document?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

I copied some new text over to the document and copied properties, again it doesnt work, double-checked the panel, all is ticked, this is so frustrating doing this manually.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

Did you collapse  all the options panel before clicking ok?

Strangely, not doing so can cause problems, like illustrator is left hanging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2017 Oct 30, 2017

Copy link to clipboard

Copied

Thanks Ray, I have yes, and still doesn't work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2017 Nov 08, 2017

Copy link to clipboard

Copied

I'm having this same issue too and have tried all the suggested fixes. I hate CC updates

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2017 Nov 08, 2017

Copy link to clipboard

Copied

Hmmm...can't reproduce here...seems to be working correctly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Me, too. I would pay double for a "no updates ever" subscription to CC. They keep breaking the interaction patterns and the product is nowhere near as stable and solid as it used to be.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2017 Nov 09, 2017

Copy link to clipboard

Copied

Here's an example of where I'm experiencing eyedropper failure again today. I used the eyedropper tool to change the color of the wrench from orange-fill-white-stroke, to white-fill-orange-stroke, and the object doesn't change, but the properties panel insists that it has.

Before using eyedropper

Screen Shot 2017-11-09 at 10.46.48 AM.png

After using eyedropper

Screen Shot 2017-11-09 at 10.49.31 AM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

me too!!!

it doesn't work on type layouts or drawn up illustrations......

does anyone have a fix?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2018 Jun 23, 2018

Copy link to clipboard

Copied

A Group can have a different appearance from the objects in the Group. This is the only screen shot I see in the thread, so I will address this one. It's from a half a year ago.

Double-click to go into isolation mode and check the appearance of the individual objects.

Decide if you want the appearance to be on the Group or the individual objects, and try to remove conflicts to get the Appearance you want.

I'm not sure if this is the issue with the others who are posting. If it's different, please include screen shots. Thanks!

IMG_5377.PNG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2018 Jun 24, 2018

Copy link to clipboard

Copied

Hi Jane-e,

Thanks for responding. I don't think that this is the issue. Up until I switched versions, I was able to select a group contained of parts with identical properties, click on either the eyedropper to select a colour or change the group colour/opacity etc by using the swatch pallet or the like.

This is no longer the case. It now requires me to ungroup everything and click on each item and change them individually. If I do the above and ask that it apply to the group (all pieces identical, just grouped!), there will be no change of appearance with the art on the artboard, however, the right-hand appearance menu will say that the colour or appearance of the object has changed.

I have tried turning off my computer. Shutting down the program. Starting with a new file. It all still does the same thing.

I hope that helps explain it a bit better.

Cheers,

-A

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2018 Jul 04, 2018

Copy link to clipboard

Copied

I've got exactly the same problem.  Picker doesn't seem to pick or apply anything.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 04, 2018 Jul 04, 2018

Copy link to clipboard

Copied

Wingmanmatt  schrieb

I've got exactly the same problem.  Picker doesn't seem to pick or apply anything.

Please tell us what exactly you're doing with which kind of object.

Show us screenshots of color picker options, your object(s) and the appearance panel (object selected)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

I have this same issue:

I use the eyedropper to sample properties from another object,

The currently selected objects' appearance doesn't change, but it's properties in the swatch panel and the appearance panel update to what the eyedropper should have applied,

BUT, if I cut, and paste the object it then displays correctly.

Lots of bugs in this latest update to AI.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

I have the same problem. I copy something from one doc to another with a drop shadow and feather. I click on a new object which is empty, go to the object with colour and feather etc, click the eye dropper tool and it does nothing. At best, it copies the colour but doesnt add the feather or shadow.  Cmon Adobe.... what the hell is going on. You are casuing me hours of uncosted work having to manually change everything rather than simply pick up a style !!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 30, 2018 Jan 30, 2018

Copy link to clipboard

Copied

Chiming in with the exact same problem. This is an incredible waste of my time to not be able to use my eyedropper. Where is the engineering QA queue??

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

I have the exact same problem ... ADOBE ARE YOU LISTENTING ... Fix THIS!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

Me too! Get your code-Monkeys on this! @adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

Same issues here, I have to manually go to the Appearance panel and change color from there. This has rendered the eyedropper useless, and it was the tool that I used the most.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 09, 2018 Apr 09, 2018

Copy link to clipboard

Copied

Same issue here. The workaround I have to use is to _deselect_ Character Style and Paragraph Style in Eyedropper Options. Then the eyedropper picks up the actual present color, font and size of the source text.

When I leave Character/Paragraph Style checked in Options, the eyedropper applies a style that I long ago removed from the document -- no text in the current document has either paragraph or character styles applied, the only used color in the document is 100% black (I have made sure by using Add Used Colors; there are no others used in the document) -- but when I use the eyedropper the values from that long-ago deleted style override the source style I am clicking on and the _always_ becomes 93% horizontal scale, Semibold weight, a custom build color fill. I have tried copying the contents of the file to a new file to check, and that does not help. Definitely a bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2018 Jun 22, 2018

Copy link to clipboard

Copied

I just converted over to CC from my trusty CS6. I started to encounter this issue almost right off the bat. It's so incredibly annoying! If anyone has discovered a fix, please do let me know!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2018 Jul 04, 2018

Copy link to clipboard

Copied

I've got a rectangle that's white and a text layer that's blue both separate layers in a group. If I select the blue text and then pick the white rectangle, nothing happens.

All boxes are checked in the eyedropper options window.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 04, 2018 Jul 04, 2018

Copy link to clipboard

Copied

Please show.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines