• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Illustrator CC Changing Document Color Mode from RGB to CMYK

Participant ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

I work in publishing. I have a set of graphics for which the print versions need to be grayscale (ie shades of K) and the ebook versions need to be in color. Naturally, the ebook graphics need to be in RGB color mode. However, when I change the document color mode to RGB, save and close, then reopen, the color mode is back to CMYK. Yes, I know I can open them all in Photoshop then export them as RGB raster files, but that's a bit of a Rube Goldberg solution to something that should be very simple. Is there something I'm missing here? Thanks in advance for any help.

TOPICS
Bug , Draw and design , How to , Performance , Print and publish

Views

208

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 17, 2022 Dec 17, 2022

And you save as AI? Or perhaps EPS (with include CMYK data turned on?)

Likes

Translate

Translate
Community Expert ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

Exactly what are you doing step by step and what are you saving using which options?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

  1. File/Document Color Mode/RGB (originally in CMYK mode). I actually see the colors change subtly, so I know it's changing.
  2. Save.
  3. Close.
  4. Reopen.
  5. Check document color mode, and it's CMYK.

 

In case it helps, I'm running Windows 10 x64 latest build, just updated Illustrator an hour or so ago, but the issue existed in the previous as well as this version. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

And you save as AI? Or perhaps EPS (with include CMYK data turned on?)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

Ah, you see, I knew there was probably something obvious I was missing, I just needed someone to point out my stupidity with the right question, lol. I was indeed saving the ebook versions using our prepress settings for print graphics, ie I was thinking on auto-pilot. I just verified by working with a few of them, and all is well when saved with other settings. Thanks so much for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

LATEST

Thank you for the feedback. Glad you could solve it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

Can you share an example file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 17, 2022 Dec 17, 2022

Copy link to clipboard

Copied

Already figured it out with Monika Gause's help, above. As usual, there was something glaringly obvious my brain wasn't perceiving. Thanks, though!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines