Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator CS6 Spacebar stops working seemingly randomly

Explorer ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

This is an infrequent issue I've had, but it has happened more than once in the last few weeks that I've been using CS6 on a regular basis:

On occasion, my spacebar will just stop working in Illustrator CS6, so I can't use the hand tool or zoom or… you know, type, basically making Illustrator unuseable. Now, I'm PRETTY sure it has nothing to do with my actual keyboard, because the spacebar will continue to work just fine in every other application even after it does this.

The only fix is restarting the computer. Just restarting the application doesn't do it. Deleting the preferences file and restarting doesn't fix it. It's really perplexing.

Now, I'm NOT certain about this, but I think it might occur after waking from sleep (but not immediately, so perhaps it's unrelated). If/when it happens next, I will attempt to see if I can reproduce the issue, but so far I have no idea why it happens; it just seems random.

I'm using a late 2008 MacBook Pro with 8GB of RAM, running Mac OSX 10.7.4 and Illustrator CS6 (16.0.0, in case people see this after an update has been released).

Views

128.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 104 Replies 104
Explorer ,
Oct 30, 2015 Oct 30, 2015

Copy link to clipboard

Copied

Really? This question was asked 3 years ago and Adobe still doesn't have a fix for it?

Well anyway, I closed Chrome and reopened it, on a Mac here at work. That did the trick.

I'm a 50 year old woodworker living in the forest hills. I have a grey beard and scruffy old work clothes, and I like to carve walking sticks on the weekends. My home is comfortable but disorganized. I have a slightly standoffish demeanour, as if you just insulted me merely by being in my presence. I seem as if I will be happier when you're gone, but if you look me in the eye and talk to me like an equal I'll tolerate you and allow you to listen to my extremely valuable and candid, if uninformed, opinions on whatever we're talking about. Even though you may be friendly I'll still act as though you wronged me somehow, and I won't look back after we say goodbye, even if we ended up having a nice interaction and I seemed like I was relaxed. Afterward, you will somehow feel like a jerk for even talking to me, and wonder what you did wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2016 Jan 27, 2016

Copy link to clipboard

Copied

Why is this still a problem?  Where are you Adobe and why haven't you put out a fix for it.  I've tried all the suggestions on this thread and the only thing that will work is to shut down everything and re-boot my macbook pro.  Very unhelpful and extremely annoying.  The Spacebar Handtool short is no doubt THE most used tool in Illustrator!

For the record, I'm using Adobe CC 2016, on a Macbook Pro (Mid 2012), 2.7GHz, 16GB DDR3, OS X El Capitan 10.11.2.

It is so counter productive to have to shut down everything, everytime this happens.  Probably happens twice a month for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2016 Feb 08, 2016

Copy link to clipboard

Copied

Illustrator has been super buggy since I upgraded to CC. This is just one of them. Force quitting Safari immediately solved it for me. Thanks again Adobe!

  Model Name: MacBook Pro

  Model Identifier: MacBookPro11,2

  Processor Name: Intel Core i7

  Processor Speed: 2.2 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 6 MB

  Memory: 16 GB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 10, 2016 Feb 10, 2016

Copy link to clipboard

Copied

So far I have identified three things that cause this behavior for me:

1. Webroot security has Secure Keyboard Entry (much like Terminal app as mentioned in another thread) enabled by default. When I turned this off I had my modifiers back.

2. 1Password. As long as I was logged in, my modifiers wouldn't work.

3. LastPass. Same as 1Password. I found that even after LastPass had logged me out after inactivity my modifiers still didn't work. I had to login, then out and I had my spacebar and other modifiers back.

I would bet those that assume Chrome is the problem would find that it's an extension added to Chrome, not the browser itself. My LastPass is a browser extension.

Hope this helps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2016 Apr 01, 2016

Copy link to clipboard

Copied

I have a similar problem on both my laptop and imac at work. Best I can tell is a paused video (maybe just youtube?) in any browser(application?) seems to create the issue. I have't tested it fully but that seems to be the most consistent correlation in my experience. This also seems to affect illustrator photoshop and indesign for me. Basically there is an override on the spacebar.

If you have a video paused in a browser or application you must fully quit the application (this goes beyond just closing all the windows). I am actually experiencing the issue right now. I closed a window that had a paused video, and the problem didn't resolve. When I quit chrome altogether, 95% chance it'll be fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

Had the same issue -  found a quick fix - I copied and pasted all contents into a new document/artboard and my space key began working fine.  And I deleted the problem art file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2016 Apr 07, 2016

Copy link to clipboard

Copied

This is still happening in Illustrator CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2016 May 05, 2016

Copy link to clipboard

Copied

I have this same problem too, no matter I tried cs6/cc ,my AI spacebar-hans tool are still not working.

It was happened after I update my Imac to the last verson and then I found there are some new option appeared on my Wacom drawing pad. there are spacebar shortcut on my drawing pad when I using AI/photoshop.

After this my keyboard spacebar shortcut no longer working. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2016 Jun 09, 2016

Copy link to clipboard

Copied

Solved! (LOL)

In my case, I'm using Illustrator CS6.

I quitted everything I was using, including Illustrator, and the H (spacebar) tool didn't work.

But, as everyone said, the spacebar worked perfectly as I typed text. It just didn't work with the "H" tool.

The last thing I quitted, was Safari.

Came back to Illustrator, and the spacebar DID WORK!! (no need to quit it again nor restart the whole mac)

I launched Safari again, see if it works... and it did. Yaay!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 16, 2016 Jun 16, 2016

Copy link to clipboard

Copied

So, this issue has been going on for FOUR years and still no bug fix from Adobe? The best people can hope to do is quit various applications and hope for the best?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2016 Jul 24, 2016

Copy link to clipboard

Copied

I agree... Not a single word from Adobe in all this time! It's a bloody disgrace!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2016 Jul 18, 2016

Copy link to clipboard

Copied

I tried quitting every app that was running and checked which app was causing the problem.

For me it was webroot secureanywhere app that caused the spacebar hand shortcut malfunction.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2016 Aug 14, 2016

Copy link to clipboard

Copied

I quit chrome and it is working fine.

Adobe illustrator CC 2015.3.0

OS X 10.11.2

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 08, 2016 Sep 08, 2016

Copy link to clipboard

Copied

After narrowing it down to Chrome, I decided to start closing my extensions and then my tabs one by one. For me the culprit was—get this—Adobe's website. True story.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2016 Sep 29, 2016

Copy link to clipboard

Copied

I've been dealing with this for a while and none of the solutions above have worked. I'm on a Win10 - Lenovo X1 laptop, with Illustrator CC 2015.3. I was about to give up since there hasn't been any response from Adobe (shockingly </sarcasm>) when I accidentally discovered something, the shortcut has changed. Instead of space bar and mouse its:

Alt + Space bar more specifically: Space bar + Alt I got the hand tool, clicked the mouse to get the hand to grab the document and move it around.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2016 Sep 30, 2016

Copy link to clipboard

Copied

Also In Photoshop CC 2015.5 it is Shift + Space bar

I discovered this today.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2016 Sep 30, 2016

Copy link to clipboard

Copied

For me, running El Capitan, the app blocking the A.I. keyboard shortcuts for Hand and Zoom tools was Safari. I needed to go into preferences for Safari and uncheck the "CMD" key shortcuts that deal with activating certain tabs under the "tabs" tab, if that makes sense. Then I had to quit Safari and restart it, in order for Illustrator to work properly in terms of Hand and Zoom tool shortcuts.

Prior to figuring out it was Safari I went through every app that was active, turning off any app preference that had anything to do with the CMD key and shortcuts. Nothing affected AI until I got to Safari. This includes the system prefs for shortcuts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2016 Nov 21, 2016

Copy link to clipboard

Copied

Thanks, I turned these Safari tab options off then on again, and Illustrator started working again. In a fresh install of Illustrator on OSX Sierra. So shouldn't need to leave them off. Weird.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 30, 2016 Oct 30, 2016

Copy link to clipboard

Copied

I found a solution that works for me, I quit Safari, and it started to work immediately even after I relaunched Safari. I use to restart the computer, which drove me nuts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2016 Nov 24, 2016

Copy link to clipboard

Copied

Hey Guys,

I had the same issue here so I contacted Adobe support and the solution they gave me worked.

Problem:

Hand Tool keyboard shortcut (Spacebar) doesn't work on Illustrator, Indesign, and Photoshop CC for Mac.

Answer:

1- Reboot your computer on Safe Mode

2- Open up the applications and test the Hand tool - (it worked)

3- Restart your computer normally and it should work fine after doing that.

I hope you find this helpful.

Cheers,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2017 Feb 16, 2017

Copy link to clipboard

Copied

i found this and it worked for me
i haven't tried copying all the contents from the old one to the new one, but for now i just typed what i need and copied it to the so called corrupted file ^^ it worked ok.
https://content.pivotal.io/blog/fixing-broken-keyboard-shortcuts-in-adobe-illustrator

PS: i am using windows 8 adobe illustrator CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2017 Mar 30, 2017

Copy link to clipboard

Copied

Completely close your internet browser(s)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

It was 1Password for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Quit Safari and reopen. Go back to Illustrator and try the (spacebar) shortcut.

Should work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

I discovered this problem today - I have an IMac 10.11.6 and use CC 2017 - the issue arose when I installed Webroot SecureAnywhere to protect my Mac. This was causing the conflict, as soon as I stopped it running in the background (turn-off from the top right-hand side of your desktop toolbar) the problem was solved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines