Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Illustrator CS6 Spacebar stops working seemingly randomly

Explorer ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

This is an infrequent issue I've had, but it has happened more than once in the last few weeks that I've been using CS6 on a regular basis:

On occasion, my spacebar will just stop working in Illustrator CS6, so I can't use the hand tool or zoom or… you know, type, basically making Illustrator unuseable. Now, I'm PRETTY sure it has nothing to do with my actual keyboard, because the spacebar will continue to work just fine in every other application even after it does this.

The only fix is restarting the computer. Just restarting the application doesn't do it. Deleting the preferences file and restarting doesn't fix it. It's really perplexing.

Now, I'm NOT certain about this, but I think it might occur after waking from sleep (but not immediately, so perhaps it's unrelated). If/when it happens next, I will attempt to see if I can reproduce the issue, but so far I have no idea why it happens; it just seems random.

I'm using a late 2008 MacBook Pro with 8GB of RAM, running Mac OSX 10.7.4 and Illustrator CS6 (16.0.0, in case people see this after an update has been released).

Views

128.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 104 Replies 104
Community Beginner ,
Jan 26, 2016 Jan 26, 2016

Copy link to clipboard

Copied

This did the Trick for me – when i quit 1Password and relaunch Ai CC 2015 the Spacbar-Handtool worked again as expected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2013 Mar 12, 2013

Copy link to clipboard

Copied

For what it's worth, I had this problem -- not with the spacebar turning the cursor into a hand, but with the spacebar not producing a word space. I tried everything suggested here, and even uninstalled and reinstalled the app (CS 5.5, on a Mac Pro running 10.6.8). Finally determined it was ... the document, of all things. Copied the art/elements onto a new page, and suddenly could type again. Bloody hell, as the Brits would say....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 23, 2013 Apr 23, 2013

Copy link to clipboard

Copied

was having exactly the same problem until today. i found it where is the conflict on my computer. was using fluid with the browserapp "teuxdeux", in teuxdeux you can write, grab and move text around. all was working fine until i move a word there. in this moment the spacebar stopped working on illu and indesign. closed the app, anything is working fine again.

i'm not shure, but i guess it is a conflict with ajax features what is causing the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 24, 2013 Jun 24, 2013

Copy link to clipboard

Copied

I just had teh same issue but with InDesign CS6 and it was a conflict with 1Password as well. Once I closed it the hand/spacebar started working again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2013 Aug 13, 2013

Copy link to clipboard

Copied

I've finally figured out the cause of this infuriating bug! It happens if you use COMMAND-H to hide any other windows or software you have open. If you avoid doing this, you will not trigger the bug. So to minimize windows simply click the yellow window icon. Let me repeat this- if you use COMMAND-H to hide anything, it makes the space-bar hand tool trigger stop working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 03, 2013 Sep 03, 2013

Copy link to clipboard

Copied

For what it's worth, I had the same problem today with AI CS6 on OSX 10.8.4. For me the space bar started working again when I quite Terminal (of all things!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 24, 2013 Sep 24, 2013

Copy link to clipboard

Copied

In my case it was a conflict with the Spotify App. The space bar controls play/pause ...not sure how to disable it in Spotify or why when Illustrator has focus it matters.

Glad I found this thread---thanks!

...but I hope Adobe fixes this, it's really frustrating as the hand tool and the magnifying glass are *integral* to my illustration workflow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2013 Nov 03, 2013

Copy link to clipboard

Copied

I had the same Probleme on PS and after reading all your answers i still had the problem also because i don't use chrome and 1 password so i closed alle applications also deactivated the spotlght shortcut on my mac and i still had the problem alfter closing everything that could be closed i just tried to close the
ADOBE CREATIVE CLOUD APP in the system bar and it started immediatly to work so i relaunched the app activated again the shortcut for spotlight and everything is working fine now...

I think the creative cloud app needs maybe a restart then you can still use it withoud any problems

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2013 Dec 03, 2013

Copy link to clipboard

Copied

Same problem. Spacebar grabber hand and zoom tool was not working in CC apps. Like

Francesco83MI, this worked for me as well. Quit CC app and it immediately starts working again. I then restarted CC app and it still works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 04, 2016 Jun 04, 2016

Copy link to clipboard

Copied

I can corroborate that quitting the Creative Cloud app immediately solved it for me (mac) today. The test will be if the problem happens again and that sol'n solves it again, but for now my brain is back to being able to zoom in/out with the spacebar combo shortcut.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2013 Dec 08, 2013

Copy link to clipboard

Copied

Adobe CC needs something more than restart...I suppose an update...I was tried everything but spacebar shortcut is still blocked on my windows 8.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2014 Mar 03, 2014

Copy link to clipboard

Copied

NONE of this worked for me. I have had this problem starting in CS6 and still in CC. The ONLY thing that works is restarting the whole machine. Which is overkill in this day and age. Reminds me of 1997 working with Crash 4… errr… I mean Flash 4.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2014 Nov 11, 2014

Copy link to clipboard

Copied

Using Safari, no chrome installed on machine, have also been using 1pass and spotify intermittently so I can't pinpoint it either as the culprit. Tried many of the suggestions from here with no success and finally had give in and restart machine to get the spacebar / hand tool to work properly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2014 Mar 19, 2014

Copy link to clipboard

Copied

I have the same problem, but if I close my browser such as Chrome/Firefox/Safari out, it seem to work again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2014 Mar 23, 2014

Copy link to clipboard

Copied

This issue drove me nuts and none of the suggestions in multiple threads helped (including shutting down all other applications, restarting and resetting preferences). I haven't managed to find a full solution to the problem but I did find a bit of a workaround which may help someone. I'm on Windows 8.1 BTW.  If I hold down the Alt key together with the spacebar the hand icon "grabs" and allows me to drag the canvas around.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 27, 2014 Apr 27, 2014

Copy link to clipboard

Copied

Windows 8

Go to  Metro UI> Settings > PC and Devices > Trackpad > Touchpad - 

  • Deactivate the Touchpad Delay.

Also:

I used a different wireless mouse which worked fine. The issue is possibly related to Mouse/Touch problems.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2014 Nov 21, 2014

Copy link to clipboard

Copied

That really solved it for me ^_^

Thank you so much (Y)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2016 May 25, 2016

Copy link to clipboard

Copied

Thanks for this, I had this issue upgrading from Windows 7 to 10 - found the solution at last! Changing the touchpad 'delay' was the solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2014 May 12, 2014

Copy link to clipboard

Copied

Good thread For me the answer was quitting Google Chrome (Version 34.0.1847.131). After that Illustrator CS6 (version 16.0.0) started working normal again. Annoying problem, I have to admit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2014 Jul 25, 2014

Copy link to clipboard

Copied

Can confirm.  This solved my problem immediately.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2014 Jul 25, 2014

Copy link to clipboard

Copied

Ugh. PC… what about this issue on MAC?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2014 Sep 01, 2014

Copy link to clipboard

Copied

Found the problem. Looks like it might be different app for each case that's triggering the spacebar issue. I forced to quit all open apps one-by-one until found the app that was causing it. In my case it was Slack.

However, I re-started Slack and seems that my spacebar feels just fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 02, 2018 Apr 02, 2018

Copy link to clipboard

Copied

Ahh thanks for this I shut down some apps and spacebar is working again, these little things can be so annoying!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

This thing is like Cancer. There seems to be no one remedy and nothing ever completely gets rid of it forever. None of these solutions has ever worked BUT now at least the last two times I was able to fix it by restarting.

Which didn’t used to work.

MAC OSX 10.9.4

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2014 Sep 15, 2014

Copy link to clipboard

Copied

My case, was chrome also, close it and open it again and start work without problems, could be a plugin or something else, was using MAC OSX

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines