• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Illustrator flickering when moving cursor

New Here ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

Hello - I updated Illustrator yesterday to version 26.0.1 and a strange flickering is now occurring. When I move my cursor the grey background behind the artboard flickers between light and darker grey. Also, filled shapes onscreen do the same thing -- jumping between a slightly lighter and darker shade of the same color. This appears to be related to onscreen guides for alignment trying to appear -- when the flickering is happening, alignment lines are visible, but no text (Anchor, Center, 45 degree angle, etc.). I'm attaching a quick screen recording in which you can see the flickering happening, then it stops, then starts back again. Never seen anything like this until the update yesterday. Please help, this is incredibly annoying and headache-inducing!

 

More about my system:

2017 Macbook Pro, 15"

2.9 GHz Quad-Core Intel i7

16 GB Memory

Graphics: Radeon Pro 560, 4 GB

OS: macOS Monterey 12.0.1

Dual screen setup via USB-C to an LG 27" 4K monitor (Model # BK67U), 60 Hz refresh rate

 

Thank you in advance for all suggestions and input :^)

 

PS -- Saw similar posts to the community but they were either older, occurring on M1 Macs, and/or not the same as my experience (with background and shape colors flickering).

TOPICS
Bug , Performance

Views

5.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 14, 2022 Feb 14, 2022

Good morning, Anshul

 

I've been having this exact probelm for a while and it finally annoyed me enough to seek a solution here on the forums. Since I'm using two external displays (Dell S2421H & Cintiq 13HD) with my MacBook Pro, I tried the 1080p display scaling suggestion first. That didn't solve the problem, so I went back and made the suggested changes with GPU Performance, Animated Zoom & Real Time Drawing. Turning all three off solved the flickering problem. I wanted to see if any one by its

...

Likes

Translate

Translate
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

I'm having an issue as well.  I just got my new Macbook with an M1 chip.  I'm running Illustrator 26.0.1 and when I open an image the whole artboard turns white.  While I'm zooming in and out I'll catch glimpses of the image but then it turns completely white again and I can't see anything.  It's basically unusable at the moment. 

 

With this being a new computer and my first time running Adobe on an M1 computer, I'm not sure if I'm doing something wrong or if there's a bug of some kind

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

I thought I'd add a screen capture too.  This time I was able to see the image as it opened but as soon as I choose the move tool and click on the image the screen turns white and I can only see the image outline when I mouse over it.  If I click, the screen turns blue and I can't see anything. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 28, 2021 Nov 28, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble you are facing. I would request you to try the following steps and let me know how it goes:

  • Does turning off "Animated Zoom," "GPU Performance," & "Real-Time Drawing and Editing" from Illustrator Preferences > Performance > uncheck Animated Zoom, GPU Performance & Real-Time Drawing, and Editing helps to resolve the issue?
  •  Close all Adobe applications and go to the following locations:
    ~/Library/Caches
    ~/Library/Application Support/Adobe
    ~/Library/Preferences
    Rename Adobe Illustrator, com.adobe.illustrator and Adobe Illustrator 24 Settings folders to Adobe Illustrator.old, com.adobe.illustrator.old and Adobe Illustrator 24 Settings.old
  • Rename the CEP folder to CEP.old from the following location:
    /Library/Application Support/Adobe
  • If that doesn't help, rename the UXP folder to UXP.old from the following locations:
    /Library/Application Support/Adobe
    ~/Library/Application Support/Adobe
  • If that doesn't help either, uninstall the whole Creative Cloud & its applications using the CC Cleaner tool and delete all the Adobe files from searching in Mac.
  • Restart the Mac and reinstall apps from the Creative Cloud Desktop app. I hope it helps!

 

I'll be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 15, 2021 Dec 15, 2021

Copy link to clipboard

Copied

Hi Anshul_Saini,

I'm having an issue as well, I using Macbook Pro M1 Pro chip with this Adobe AI version 26.0.1.  And i have some question from your awnsers above.

 

Why do we have to turn off  "Animated Zoom", "GPU Performance" & "Real-Time Drawing and Editing"?

It should be turn on to working with GPU or not?  Because "GPU Preview" it's smooth to working this mode. So, I think should have another solution to fix this.

 

I have added the video screen capture for your preview  same as this issue.

 

Please advice and explain for this issue and thank you in advance.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 27, 2021 Dec 27, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble you are facing. I just want you to check if turning off "Animated Zoom," "GPU Performance," & "Real-Time Drawing and Editing" helps or not. Would you please check that and let me know?

Also, I would request you to check the following:

Go to Apple System Preferences > Display > Make External Monitor as "Main Display" if any > Select Scaled > 1080p (1920x1080) resolution or below for Macbook to External Display
Anshul_Saini_2-1640631704653.png
or
Disconnect External Monitor and check if it is happening then.

 

We'll be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2022 Feb 14, 2022

Copy link to clipboard

Copied

Good morning, Anshul

 

I've been having this exact probelm for a while and it finally annoyed me enough to seek a solution here on the forums. Since I'm using two external displays (Dell S2421H & Cintiq 13HD) with my MacBook Pro, I tried the 1080p display scaling suggestion first. That didn't solve the problem, so I went back and made the suggested changes with GPU Performance, Animated Zoom & Real Time Drawing. Turning all three off solved the flickering problem. I wanted to see if any one by itslef was causing the issue, so I turned them back on, one by one, and then in the different available combinations. Just simply turning all three off and then back on seems to have solved the problem for now. I figured it would be helpful to post my experience here, especially for the user above ( @Vanlop22265005y5oy ) who asked why we should have to turn those off. Thanks for the solution. Have a great day!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

thank you so much! this was driving me crazy for weeks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

This worked for me! Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

My "Animated Zoom" was already unchecked. Checked off "GPU Performance", it stopped! Checked it back on, still gone. Thank you!

BF, Florida

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

LATEST

Good golly. One has to try ALL those steps to shut off that annoying flicker? 😐

Here's my solution. Quit out of Illustrator. Re-open file. No more flicker.

Here's to the AI dev team to get rid of the flicker in the next update. 👍

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

I fixed this problem by unchecking GPU performance, and animated zoom but has adobe fixed this issue with an update to Illsutrator? I'm running Illustrator 27.0 with Mac Os 12.5.1 and Macbook Pro 2021 with APple M1 Max and 32 GB RAM. THis needs to be fixed properly. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2022 Nov 21, 2022

Copy link to clipboard

Copied

I have had this issue for YEARS (8 or so)! I have had a few different computers in that time, all high spec Macs. It does it all the time when I'm working in Illustrator BUT only if I have Photoshop open as well, portions of the artboards and everything on them also disappear and goes white, and then reappears if I zoom in and out. It has been a constant problem for me, even to this very day! The only way I can stop the flickering cursor is to close Photoshop, and to only work with Illustrator open. I have spoken to adobe techincal help on many occasions regardring this, as I literally cannot bear it when I'm working - it drives me CRAZY! The promises of a solution have never been upheld...it has been a persistant issue for me over the last 8 years, and so I don't have much hope that there will ever be solution coming. I even replaced my older Macbook for an iMac at one point, hoping that would be the end of it...but no, the problem continues. Adobe, seriously...when will this be fixed?! 

 

I have just purchased a brand new Macbook Pro 2022 last month - I am yet to use both Photoshop and Illustrator  simultaneously on it, to know if this problem is also present on my new device. I will keep you updated though! 

 

I'm running iMac 2017 Retina 5K
3.8GHZ Quad-Core intel Core i5 -
Radeon Pro 580 8GB

Memory 40GB 2400 Mhz DDR4

 

I have all the latest Mac and Adobe software installed and up to date at all times (in the vain hope the problem will suddenly be fixed!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines