Illustrator macOS 12.3.1 Preferences folder Read-Only

Community Beginner ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

I've tried to change the permissions on preferences (i've succeeded in changing them on Application Support/Adobe)

 

However when i go to /Library/Preferences it says it can't change the permissions because I don't have the permissions necessary to do so

 

Anyone kno whow to remedy this?

 

[Renamed by Mod]

TOPICS
How to , Performance

Views

118

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , May 23, 2022 May 23, 2022
Apple has limited access to the System/Library in the new Monterey OS to the System Admin only. To change the Adobe preferences for Illustrator, you need to go to the Library folder in your user folder.

Likes

Translate

Translate
Adobe Employee , May 24, 2022 May 24, 2022
Hello @Andrew24572087m0si, Sorry to hear about this experience. As pointed out by Larry, you need to change the permissions for these folders after closing out all Adobe applications: • ~/Library/Caches • ~/Library/Application Support/Adobe • ~/Library/Preferences Note: Location starting with this "~" sign indicates the User Library, which is hidden. So, you need to copy & paste the exact path in spotlight search or from Finder Menu > Go > Go to Folder > Paste the location in the dialog box li...

Likes

Translate

Translate
Adobe Community Professional ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Yo ushould go to Apple System Preferences/Security and Privacy and add Adobe Illustrator to the Full Disk Access list. No need to go around in the individual folders.

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Thanks! Unfortunately when given full access the application still doesn't open and still gives the same error.

 

When I follow the instructions on the website under more info: https://helpx.adobe.com/illustrator/kb/preferences-folder-read-only-error.html, I'm met with the error message within finder saying I cannot update the preferences folder's permissions.

 

Have you ever seen anything like this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Apple has limited access to the System/Library in the new Monterey OS to the System Admin only. To change the Adobe preferences for Illustrator, you need to go to the Library folder in your user folder.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Are you an Admin account on this Mac?

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Thank you for your help!! This fixed it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Hello @Andrew24572087m0si,

 

Sorry to hear about this experience. As pointed out by Larry, you need to change the permissions for these folders after closing out all Adobe applications:
• ~/Library/Caches
• ~/Library/Application Support/Adobe
• ~/Library/Preferences

Note: Location starting with this "~" sign indicates the User Library, which is hidden. So, you need to copy & paste the exact path in spotlight search or from Finder Menu > Go > Go to Folder > Paste the location in the dialog box like this:

Anshul_Saini_0-1643743865628.png

 

Kindly update this thread if the issue persists or if you need further assistance.

 

Thanks,

Anubhav

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

Thank you! This fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 24, 2022 May 24, 2022

Copy link to clipboard

Copied

LATEST

Hello @Andrew24572087m0si,

 

Glad to hear it helped. Feel free to reach out if you need further assistance in the future.

 

Regards.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines