• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
10

Illustrator Resizes on File Open

Participant ,
Jun 19, 2012 Jun 19, 2012

Copy link to clipboard

Copied

This is a silly little issue, but it really bugs me! Whenever I open a file in Illustrator via double-clicking the file in Windows Explorer, Illustrator resizes its main window, as if I've hit the "Restore Down" button in the upper right corner. I then have to click "Restore Up" to expand it to fill the screen again. I'm using Illustrator CS3 and Windows XP. Any ideas?

Views

37.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 06, 2022 Aug 06, 2022

Hi, no there isn't a solution yet, just resize the window manually as suggested 10 years ago.

Votes

Translate

Translate
replies 105 Replies 105
New Here ,
Aug 20, 2014 Aug 20, 2014

Copy link to clipboard

Copied

I just chatted with Adobe today - it's a known problem and they're working on it. As a workaround, they suggested opening files through the interface "File open" rather than double-clicking a document. Hope this helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 20, 2014 Aug 20, 2014

Copy link to clipboard

Copied

Well, that's something I guess. I've updated to the latest version, CC 2014, and it does the same thing. You'd think this many versions later it would be fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2014 Sep 19, 2014

Copy link to clipboard

Copied

Good tip from in this thread: forums.adobe.com/message/5640644#5640644 . Modify your AI shortcut properties to set window to maximized on start. That worked for me (Win7/CS6).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2014 Sep 19, 2014

Copy link to clipboard

Copied

Well, as has already been concluded 3, maybe 4 times in this thread; that is not the solution. I have never NOT had Illustrator set to start maximized. With it already running...already maximized...double click an associated file. No more maximized. That's the long-running bug; not the window state on start-up.

Actually, the problem doesn't affect me much because I never really developed a habit of opening files by any other method than File > Open (Ctrl+O). There are, however, workflow scenarios in which it becomes a convenience, but I've even consciously avoided it specifically because of this Illustrator bug. I do know of people who never open a file any way other than double-clicking. Just to note, the bug rears its head in any Windows OS-level file association action, except somehow, when "Edit Original" is invoked from within InDesign. I wonder why.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 02, 2014 Oct 02, 2014

Copy link to clipboard

Copied

John, but have you tried that solution? In my case I had the same poroblem: while Illustrator was already running, and it was maximized, I dragged an artwork on its shortcut, and its window got small, even to a degree that the file couldn't be open. After I modified my shortcut (actually embedded in Total Commander that I love to use, although it shouldn't make a difference) to open the target app in maximized mode, the window stayed maximized.

The difference is that the method described by @emil emil and used by me uses shortcuts to open the file, and you are opening the files by double clicking. So the only advice I'm able to give is to create an AI shortcut in 'maximised' mode and use it to drag&drop your designs.

PS

Personally I never save artwork in AI, only in PDF, so my double-click action is to open the file in PDF viewer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 01, 2014 Oct 01, 2014

Copy link to clipboard

Copied

i just tried a window sizing/opening/location utility that i have been using for a while called Winsplit Revolution.

it fixes this problem.  At least so far....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 06, 2014 Oct 06, 2014

Copy link to clipboard

Copied

With the latest AI CC 2014 update this issue has been fixed. Please update the AI CC 2014 application using the Creative Cloud application (to update quit & re-launch CC app).

Please update the thread with your findings.

-Rama

Illustrator Team

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Oct 14, 2014 Oct 14, 2014

Copy link to clipboard

Copied

I run the latest issue and I still had this problem today.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Actually, it isn't fixed at all.

Just checked that latest updates applied (through Creative Cloud).

Win 7

Open AI.

Maximise.

Double click on AI file.

AI restores down.

Colin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2015 Jan 20, 2015

Copy link to clipboard

Copied

Do you have iCloud installed? Uninstall iCloud and the bug is gone ...

I don't call this a solution, but at least it works for now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2015 Jan 21, 2015

Copy link to clipboard

Copied

Unfortunately, no iCloud.

While annoying, the "manual maximise" workaround will do me.

It would be nice if the oligarch's at Adobe would see the need to fix stuff that annoys those who pay for their lifestyles...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Oct 14, 2014 Oct 14, 2014

Copy link to clipboard

Copied

Drag the bottom left corner(s) of the Illustrator window to the size you desire (in my case, full screen). It should solve the issue. Good luck!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 01, 2016 Apr 01, 2016

Copy link to clipboard

Copied

Still an issue in CC2014 on a Windows 7 ThinkPad. Will check CC2015 when I get home. This is ridiculous. I can't believe this is still an issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2017 Feb 02, 2017

Copy link to clipboard

Copied

I cant believe the amount of time this question has been sitting on the forum unanswered.

Simple fix:

Resize the window to desired size as stated before. The step that was missing is this.... are you ready for it? Immediately quit the program by clicking close (the little X). Illustrator being the amazing program it is, remembers the last setting upon exit to include all preferences, rulers, guides, and measurement units etc This is very handy if used properly.

This problem presents itself when the Illustrator art board is accidently minimized and instead of clicking maximize the user on error clicks the close button and it now becomes the default size upon reopen.

That's all I got. Hope this helps...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

For me, the issue only happens when I double-click a file. If I highlight it with the arrow keys and hit 'enter' Illustrator stays maximized. Has anyone else noticed this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2017 May 07, 2017

Copy link to clipboard

Copied

I've got a fix for this that works perfectly, at least for me (Illustrator CS6, Windows 10). You create a shortcut to launch Illustrator maximized, and then associate .ai files to open through that shortcut. Only problem is, you can't associate a file type with a shortcut, but you can get around it by using an intermediate script or batch file.

Step 1: Shortcut

Create a shortcut to the Illustrator.exe somewhere, say C:\foo\Illustrator.lnk. Right-click on the shortcut, select Properties, go to the Shortcut tab and change Run to Maximized. (You could even just do this to the shortcut in the start menu or the one Illustrator has in its Program Files directory if you want.)

Step 2: Script

Create a VBScript file somewhere, say C:\foo\Illustrator.vbs, with the following contents (change C:\foo\Illustrator.lnk to the path to the shortcut you prepared in step 1):

CreateObject("Wscript.Shell").Run """C:\foo\Illustrator.lnk"" """ & WScript.Arguments(0) & """"

(Alternatively you can create a batch file, say C:\foo\Illustrator.bat, with the following contents:

start "" "C:\foo\Illustrator.lnk" "%1"

But that flashes an ugly command window on the screen for a split second so I prefer the VBScript approach.)

Step 3: File association

Open Registry Editor (Start > Run, type regedit, OK), navigate to HKEY_CLASSES_ROOT\Adobe.Illustrator.16\shell\open\command (note: this might be different if you're running a different version of Illustrator), double-click "(Default)" in the right pane and set the value to this (change C:\foo\Illustrator.vbs to the path to the script you prepared in step 2):

C:\Windows\System32\wscript.exe "C:\foo\Illustrator.vbs" "%1"

Done! Now double-clicking .ai files should not un-maximize the Illustrator window. On the contrary, it forces it to be maximized even if it wasn't before. This may or may not be a problem for you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 05, 2018 Jul 05, 2018

Copy link to clipboard

Copied

I caused this to start happening, and luckily I remember what I did so I reversed it.

Open illustrator, not a file. Resize the frame, exit.

Boom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

6 years (!!) later and this is still a problem. What the heck, Adobe. Your moderators are on point after 10 minutes, yet 6+ years and this issue still remains. Pathetic.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

I have the same problem and its extremely annoying. Every time I open a file Illustrator completely resizes to 3/4 of the screen.

Yes it's not a big deal but when you have to open over 100 files a  day it's extremely frustrating to have to make it full screen every time you open a file.  It just started doing it again out of the blue without any updates or changes to my settings.

It would be great if adobe could actually fix their bugs...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 24, 2019 Mar 24, 2019

Copy link to clipboard

Copied

Was looking for this, just in case there was an easy solution, I noticed the post is from 2012, it is shameful this is the industry standard and a company so big can be so not innovative.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2019 May 30, 2019

Copy link to clipboard

Copied

So its 2019 and this is still an issue on Illustrator CC 23.0.3.

Any time i open a file the whole program resizes to full screen, it even covers my windows tool bar.

I know this is a silly issue but its so frustrating to have to resize the window every time i open a file with can be hundreds of

file a day.

So far Adobe has been 0 help like always and say they cant make this happen on their end so its not an issue.

Does any one have any solution to fix this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2019 Jul 16, 2019

Copy link to clipboard

Copied

Still happening as of July 2019 😕 Can't believe how pathetic Adobe is to respond, it's only been 7 years since your original post!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

Wow. Just got a new laptop with a fresh install and this annoyance is still happening. Almost 8 years since the first post...pathetic.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

User paul-UPI posted a solution in a separate thread (thanks, paul):

Edit > Preferences > User Interface. Deselect "Open documents As Tabs."

 

That did it for me. Even though Illustrator 24.0.2 was working just fine, I hadn't changed any settings, and the problem just started up out of the blue...

 

Original thread found here:

https://community.adobe.com/t5/illustrator/illustrator-cs6-opens-in-window-too-small/td-p/4634736?pa...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

The scratch disk solution as pointed out on page 1 has fixed my problem perfectly. It's probably there to optimise file importing (albeit cumbersome as we have to manually readjust our windows every single time). It definitely needs to be fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines