Illustrator slow when closing documents

Community Beginner ,
Sep 15, 2021 Sep 15, 2021

Copy link to clipboard

Copied

When I close a document (that is already saved), it takes up to 5 seconds until it's closed.
Same when I open a new document and close it right away. Illustrator takes 5 seconds to do this. IT's pretty annoying and disturbs my workflow.

What could be the problem here? 

 

Thanks!

 

(Windwos 10, Illustrator 25.4.1 (64-bit))

 

TOPICS
Performance

Views

454

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Nov 11, 2021 Nov 11, 2021
Hi there, Sorry about the trouble and delayed response. I would like to know if you have tried the steps shared above. If they don't help, you may try the following steps based on your specific Nvidia case and let us know how it goes: 1. Open the "Nvidia Control Panel." 2. Select "Manage 3D Settings" under 3D Settings. 3. Click on the "Program Settings" tab > "select a program to customize" > Illustrator > Select the preferred graphics processor for this program > Integrated/ High Permonce/Glo...

Likes

Translate

Translate
Community Beginner , Nov 30, 2021 Nov 30, 2021
Hey, great news: using the CC Cleaner Tool and reinstall did the trick! Now the files are closing immediatelly!! Thanks for the help! Just one thing: after I installed the Nvidia Studio Driver, I can't switch back to RTX 2070 on Illustrator. The performance tab only shows Intel Integrated Graphics.

Likes

Translate

Translate
Adobe Community Professional ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

Where is the document saved?

What's in the document?

Are there any third party plugins installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about your experience. Could you please share a few more details along with the ones asked by @Monika Gause:

  • OS and version of Illustrator
  • Does disconnecting from the Internet help resolve the issue?
  • You machine specification?
  • Does your system has SSD or HDD?
  • Are you saving files on a Network Drive, shared folder, or USB/ Hard drive? If yes, try saving files on Desktop and see if it takes less time to save documents.
  • When did this start happening? Are there any recent changes made to your system? For example, any antivirus, system updates, or web extensions installed recently.
  • Does resetting Illustrator Preferences (https://helpx.adobe.com/illustrator/using/setting-preferences.html) help to resolve the issue?
    Disclaimer: Please note that resetting preferences will remove all the custom settings, and Illustrator will launch with default settings. You can also take a backup of the folders in case you want to. Location is mentioned in the article.

 

If resetting Illustrator Preferences doesn't help, then you may try following the steps shared in this post (https://community.adobe.com/t5/illustrator/resolve-slow-performance-and-unexpected-behaviors-in-illu...) step by step and let us know how it goes.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Hi there,

 

- as I mentioned in my OP, this also happens when I open a new (blank) document and close it right away (without saving), so it doesn't matter what's a) in the documents (because it'S empty) and b) where it's saved (because it isn't).

- No plugins are installed.

- The version numbers (were also mentioned in my OP): Windwos 10 (19043.1237), Illustrator 25.4.1 (64-bit).

- Disconnecting from the internet does not change the behavior.

- I run Illustrator form a SSD on a Intel i7-9700k 3.60Ghz with 32 GB of RAM.

- Again, saving is not the issue here, this also happens with a new, unsaved, blank file. (I create a new document and close it right after that. It will take about 5-7 seconds for the file to gets closed).

- Resetting the preferences did not change the behavior.

 

I tried every other step in the link you provided, it did not solve the issue.

 

BR

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

I have exactly the same problem. When I close a blank file, it takes up to 5 sec to close it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Thank you for sharing the details and trying the steps. I would suggest you and @alexm43536329 to try a few more steps as follows and let us know how it goes:

  1. You may try resetting preferences manually:
    - Close all Adobe applications.
    - Go to Location C:\Users\user\AppData\Roaming\Adobe
    - Rename Adobe Illustrator and Adobe Illustrator 25 Settings folders to Adobe Illustrator.old and Adobe Illustrator
    - 24 Settings.old
    Disclaimer: Please note that renaming preferences folders will remove all the custom settings, and Illustrator will
    launch with default settings. You can also take a backup of the folders in case you want to. The location is
    mentioned above.
  2. Try disabling any security apps (Norton360 Antivirus) and test if this helps resolve the issue.
  3. Close any application running in the background and see if that helps resolve the issue.
  4. Rename the CEP folder to CEP.old from the following location:
    C:\Program Files (x86)\Common Files\Adobe
  5. If that doesn't help, rename the extensions folder to extensions.old in the following location:
    C:\Program Files\Common Files\Adobe\UXP
  6. If that doesn't help either, uninstall the application using the CC Cleaner tool and reinstall from the Creative Cloud Desktop app.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 07, 2021 Oct 07, 2021

Copy link to clipboard

Copied

I have the same problem here, same PC setup. So, to test,  I installed Illustrator on a virtual machine, on the same pc and it worked normally, closing files immediatelly!
So, the problem is for sure some proceess that is interfering with Illustrator, but I can't find it. I reinstalled al the Adobe apps but for nothing, the same thing happened. Maybe some Nvidia stuff? Becaue it was the only thing that it's not installed on the virtual machine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry about the trouble and delayed response. I would like to know if you have tried the steps shared above. If they don't help, you may try the following steps based on your specific Nvidia case and let us know how it goes:

1. Open the "Nvidia Control Panel."
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab > "select a program to customize" > Illustrator > Select the preferred graphics processor for this program > Integrated/ High Permonce/Global settings. Check one by one in which Illustrator runs fine.

 

I hope it helps!

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

OMG, it worked. Thank you so much. After I selected illustrator, I only clicked restore and that's it. It worked!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

Nothing worked for me, I don't know what to do anymore... 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

The most strange thing, is that on a Windows 10 virtual machine, running in the same laptop, everything works perfectly! This is a mistery! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

@leonardovago, thank you for sharing the keen observation & testing. You may try installing Nvidia Studio Driver and do the following settings as mentioned above in the Nvidia control panel and see if that helps.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

Sorry, I totally forgot to mention my GPU: RTX 2070

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 27, 2021 Nov 27, 2021

Copy link to clipboard

Copied

Thanks for letting us know that. You may try installing the Nvidia Studio Driver as suggested above.

 

Also, please check if you select your integrated GPU as "Select the preferred graphics processor" instead of Nvidia RTX 2060 under Nvidia Control Panel > Manage 3D Settings > Program Settings and let us know how it goes.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Well, I installed Nvidia Studio Driver, tried both modes (integrated and Nvidia GPU) and the results are the same, no changes. I disabled the nvidia gpu on the Setup (only iGPU), same thing. I changed my monitor from 240 to 60 Hz, nothing. Disconnect from Internet, put on airplane mode, nothing. Maybe something related to FontBase (a font manager)? I don't know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Hey, great news: using the CC Cleaner Tool and reinstall did the trick! Now the files are closing immediatelly!! Thanks for the help! Just one thing: after I installed the Nvidia Studio Driver, I can't switch back to RTX 2070 on Illustrator. The performance tab only shows Intel Integrated Graphics.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

Glad to hear that, and thanks for sharing your insights with us. Please feel free to reach out if you run into any other questions or issues in the future. We'd be happy to help.

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 06, 2022 May 06, 2022

Copy link to clipboard

Copied

Hi @Anshul_Saini how's going? i hope you are doing fine! Do you know how to fix this problem on desktops that uses Radeon Gpu instead of nvidia? Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

Hi @Felipe5D1F,

 

Sorry to hear that you are experiencing a similar issue. You may try the steps suggested in the following AMD help articles:
(https://www.amd.com/en/support/kb/faq/dh2-024)
(https://www.amd.com/en/support/kb/faq/dh-017)

(https://www.amd.com/en/support/kb/faq/gpu-110#faq-Customizing-Graphics-Performance-Preference-for-a-...).

 

Let me know how it goes. I will be looking forward to your response.

 

Regards.

Anshul Saini 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

Hi @Anshul_Saini thanks for the answer, I figure out the problem: It was two plugin folders of Fontbase that was inside older folder versions of both adobe photoshop and illustrator. After I deleted those folders (the fontbase plugin folders) the problem was solved and now its working like a charm ♥

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 11, 2022 May 11, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear that, @Felipe5D1F. Please feel free to reach out if you run into any other questions or issues in the future. We'd be happy to help.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines