Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


IllustratorGc.jsx script error while launching Illustrator 25.3

Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Updated this morning to Illustrator 25.3 - as soon as the update was done this scripting error began appearing (every 30 seconds). .. Personally went back to 25.2.3 which has solved this issue. 

 

Screen Shot 2021-06-08 at 10.01.26 AM.png

 

 

{Renamed by MOD}

TOPICS
Bug, Performance

Views

42.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Aug 25, 2021 Aug 25, 2021
We are investigating this issue and reached out to Logitech for permanent solution. Meanwhile users can try the below workaround. Create a JSX file with the following content: app.preferences.setBooleanPreference("ShowExternalJSXWarning", false); Save the above JSX file. Now, go to File > Scripts > Other Script, and choose the newly saved jsx file. This will suppress the warning dialog and run the script.

Likes

Translate

Translate
Adobe Employee , Oct 11, 2021 Oct 11, 2021
Hi all, We hope the issue is resolved by now. If not, please update the logitech driver to latest version (9.40.86) and share your observations with us. Regards, Srishti

Likes

Translate

Translate
replies 176 Replies 176
New Here ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

This is extremely annoying...


Turning OFF the application specific settings is NOT a solution. That was one of the reasons why I and most likely everyone who bought this specific mouses or keyboards, had them in first place!

 

It's August 18th and this problem is still requiring solution.

Absolutely disgraceful, there's no way you can work with that notification popping every 10 seconds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Has anyone found a solution for this? It is driving me absolutely crazy! I can't get anything done!Screen Shot 2021-08-20 at 12.31.02 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Use a versao Beta do logitech, para mim resolveu o problema.

https://www.logitech.com/en-gb/software/logi-options-plus.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

Yes. Download and install an earlier version of Illustrator until Adobe fixes the problem. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2021 Aug 22, 2021

Copy link to clipboard

Copied

I also have the issue despite having updated everything. Waiting from a prompt solution from adobe

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Use a versao Beta do logitech, para mim resolveu o problema.

https://www.logitech.com/en-gb/software/logi-options-plus.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2021 Aug 22, 2021

Copy link to clipboard

Copied

Screenshot 2021-08-23 at 2.04.18 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Use a versao Beta do logitech, para mim resolveu o problema.

https://www.logitech.com/en-gb/software/logi-options-plus.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

A menos que você tenha o teclado Kraft ... que atualmente não é compatível com a versão beta, o que para mim parece insano

-------------------------

Unless you have the Kraft keyboard ... which is not currently supported in beta, which to me seems insane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

We are investigating this issue and reached out to Logitech for permanent solution. Meanwhile users can try the below workaround.

Create a JSX file with the following content:

 

app.preferences.setBooleanPreference("ShowExternalJSXWarning", false);

 

Save the above JSX file. Now, go to File > Scripts > Other Script, and choose the newly saved jsx file.

This will suppress the warning dialog and run the script.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

Hi Rama,

 

I just tried this and it did not work. I copy and pasted the content into a txt document and renamed the file to .jsx — am I doing something wrong? Below is the error message I receive after selecitng the .jsx file. I also have the latest version of LogiOptions, but still receive the script warning.Screen Shot 2021-08-25 at 12.52.21 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

@EndeavorGlobal Looks like quotes got replaced with typographer's quotes causing this error please use the below that contains correct quotes.

 

app.preferences.setBooleanPreference("ShowExternalJSXWarning", false);

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

@rama_ai perfect, that worked. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

@rama_ai I seem to get this error when trying this method.

Screen Shot 2021-08-25 at 1.10.33 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

@sirfrancisbacon  That happened to me when I used rich text. Try Format > Make Plain Text before saving.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

@EndeavorGlobal thank you. Illustator is actually usuable again. I couldn't even change font in illustator without that stupid pop up destroying everything. It brought me back to the Clippy days of Microsoft Office...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Works for me.... finally

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I received an invite to join Logitech's Beta program (Logi Options+ Beta). I am able to modify my mouse for Illustrator and other programs without an error. Logi Options will take over the LOGI app. This might be the fix everyone needs.

https://www.logitech.com/en-us/software/logi-options-plus.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

This is VERY annoying. I tried making my own JSX file to diable the popup as mentioned by rama_ai but it doesn't work.... I copy pasted exactly what was in the message: app.preferences.setBooleanPreference("ShowExternalJSXWarning", false);

But when I import the .jsx file Illustrator says there is a syntax error?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

@MattD-KOJO you may have ran into the same issue as I did with the typographer quotes. Try this instead:

 

app.preferences.setBooleanPreference("ShowExternalJSXWarning", false);

 

Also make sure to convert the text plain text before saving.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

Still having this issue on Illustrator 25.4.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

This is so damn annoying, literally shouting at my computer here.

I'm glad the workaround helped with the javascript. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

Hi there,

 

One easy fix is to simply drag the dialogue box out of your visual workspace. This way you can still use the crown without the warning screen popping up every time you try to use it. However, you will have to close the warning box if you are trying to save or exit the program, as the program prioritizes the warning box over the main menu functions. 

 

P.S. the .jsx file did not eradicate the problem for me, so i have been using this method

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

For those that are not familiar with code, I have done that an Works (MACBOOK PRO):
1) Install a code editor like Visual studio Code (Free).
2) Type this:
app.preferences.setBooleanPreference("ShowExternalJSXWarning", false)

3) Save it on desktop as .jsx (write this at the end).
4) Go to illustrator and do that: File > Scripts > Other Scripts


Hopefully that helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

There is no need for a code editor. Just any software that can save plain text files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines