Intersect tool in pathfinder not working properly

Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

This is strange, but when I go to intersect open paths in Illustrator that don;t have any fill it acts as if the shapes are filled. It gives me a line connecting the two end points of the paths and then I have to go back, delete the unnecessary shapes created by this anomaly, and merge the fragmented shapes that i needed. I've tried restarting Illustrator, Restarting my computer and even rolled back to a previous version hoping that this would fix the error, but it still persists. Any help would be much appreciated, it's getting on my last nerve.

-Justin T

Views

4.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 25, 2017 May 25, 2017

OK, I can reproduce it.

I selected all, deleted all apearances with the appearance panel and then reapplied strokes. Then it worked.

Don't know what exactly caused this.

Likes

Translate

Translate
Adobe Employee ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Hi jtaylor,

If I get your query correctly, intersect option is not working correctly?

In order to assist you further, we would need some details like:

Operating system (Windows or MAC with exact versions)

Exact version of Illustrator.

Screenshots of artwork (before and after using intersect option) For details, see: How to add a screenshot to a forum message from iPad/iPhone

Regards

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

ere's all the information. I compiled it into one image for you to make it easier for you. You can see that there are no fills in the paths yet it is treated as if there is when I use the intersect option from the pathfinder. Additionally, The lines that run vertically completely disappear rather than dissecting the lower shape, as it should be doing if it were functioning properly. I did this on two other versions of Illustrator, which I never had an issue with prior to now, and the problem still persists in those versions as well.

img.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Hi jtaylor,

Would you mind sharing this file?

Regards

Srishti

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Its not the file, its the program.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Sorry, it does seem to be an issue with my settings because when an associate opened it, he had the same issue. Here's a link to the file:
Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

OK, I can reproduce it.

I selected all, deleted all apearances with the appearance panel and then reapplied strokes. Then it worked.

Don't know what exactly caused this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Thank you, I wish I could figure out what was causing it so that I can avoid it in the future. At least I can correct it now when it happens. Thank you for your help with this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

LATEST

Thank you. That helped!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

I'm pretty sure you used a different pathfinder then.

It looks like what you want to have, will be achieved with Divide (second row, the leftmost button)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

You're right, I meant to say I was using Divide, not intersect. I shared it with an associate though and it must be settings in my program because it didn't work for him either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

Pathfinders will always act unexpected when you work with strokes only.

So this sounds like expected behaviour.

Please show your artwork and tell us what you want.

Expanding/Outlining the strokes before applying pathfinder functions might already get you there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

I work with this program daily. This isn't normal. If I expand the paths then they're no longer editable if a client wants a revision so that's not an option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2017 May 25, 2017

Copy link to clipboard

Copied

jtaylor7535  schrieb

I work with this program daily. This isn't normal. If I expand the paths then they're no longer editable if a client wants a revision so that's not an option.

And if editability is such an important goal: Have you ever tried Live paint?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines