Rastering problem with new 3D tools.

New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

I've been testing out the new 3D tools and materials and for one day I didn't have an issue. (I've been using it mostly for creating 3D text). Now, out of nowhere, my 3D models lost their quality and the shadow casted is in an even lower quality — as if they're not vectors like before. 
I tried adjusting the raster settings — I am working on a RGB file with 300dpi quality. I changed the quality to 300dpi in Document Raster Effects Settings as well, and in the general preferences.

I'm so desperate I even reinstalled Illustrator and restarted my device. 

 

How can I get my 3D models back to vector? 

 

Here how it looks now:

Zrzut ekranu 2022-01-6 o 00.51.21.png

TOPICS
How to , Performance , Tools

Views

112

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Did you check the Render Settings at the top right of the 3D and Materials panel as well as the softness in the Lighting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Yes, and unfortunately, changing them doesn't do it, either 😕
Before this happened, I was able to get clear vector models in preview, without having to wait ages for the render — and it still works for me when I use the old 3D tools. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

And switching between GPU and CPU Preview (Cmd or Ctrl E)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Yes, I don't think the preview is causing the problem...

Here are two shapes made in the same document:

The one on the left made with the old 3D tool, the righ one made with the new one. 
Zrzut ekranu 2022-01-6 o 13.23.03.png

It's as if the new model is automatically rastered, converted to a print file or something. Even the colors seem to be in two different modes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

You cannot compare the 2 3D versions, they are very different.

Can you share an example .ai file with the problem?

Dropbox, CC Filesharing, WeTransfer, Google...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Sure! 
Here you go:
https://we.tl/t-02hLURFdsX

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Thanks, I was expecting the shadow problem. 

This is what it is, the difference between the old an the new effect algorithms.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I added a shadow to your file and increased the softness.

It was very slow and this is what I get. (I would use the old effect for this and fake the shadow).

Screenshot 2022-01-06 at 15.12.56.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Hmm... I wonder why this wasn't an issue for me previously? Like I said, I used it for a while, with a large quantity of shapes and letters—had no issues with the quality, everything worked smooth and didn't weigh on the file. I didn't render it, the preview appeared to be a vector, same for the shadow. 
It's frustrating, almost as if I unintentionally broke something in my preferences (I had restored it to default, but nothing changed)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

How large are those objects?

Did you enable Raytracing?

After you enable it, you have to click on "Render"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I'm using a 600x600px file, but before this issue appeared, the 3D models worked fine no matter the size, so I don't think that's causing the problem. The issue is that it's no longer a vector-model (idk if that's the right way to name it), As I said, before this was a problem I didn't have to render the model to get it vector-sharp.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Then please open the Raytracing options and check the vector option in there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Well, it appears that it fixed the problem of just one of my shapes, but the shadow casted is still pixelated... and when I check that option for any other shape, it still does nothing.
I posted a link to my file in the message above—if you have the time, maybe it would be easier for you to look at the settings there and somehow figure out why it's not working for me? Much appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

LATEST

The shadow will never be a vector shape.

As for the other shape you are talking about: is it in that file? I haven't seen it.

 

It will also always depend on the surface if Illustrator is able to draw sharp edges. Most of those surfaces will need to be rendered as pixels.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines