• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
1

Recolor artwork not working, please help.

Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Hi, I'm trying to recolor some artwork in illustrator. I'm using the same method I used yesterday and haven't changed any settings. It looks like it is doing it but the colors don't change. I'm using the direct selection tool, then select-same-fill and stroke. Then re-colour artwork, double click on the rectangle to bring the colors up, I pick a color, click OK, then OK on the recolor artwork box, it all looks normal but the colors don't change. Please help.

TOPICS
Tools

Views

56.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Is the "Recolor" option in the bottom left checked?

If that doesn't help: please show.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Where exactly do you mean? I'm new to illustrator. Do you want a screen shot?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

In the bottom left of the recolor art work dialog box there is this option. It needs to be checked.

And if it doesn't help, please show a screenshot of your artwork with the dialog box and your options in it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Yes it is checked, it is showing that it is the new color in the box, but as you can see on the screen behind it is still black. wondering if its a problem with my selection tool or something, I don't get the blue lines everywhere when I click select-same-stroke and fill.

1 recolor.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

ou haven't selected any black objects. Otherwise there would be black in the "Current colors" section.

When recoloring black you also need to check the recoloring options, which is the small button right to "Preset: Custom".

Have you read the manual thoroughly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Hi Monika, Thank you for your help, in the box above the reason its pale blue is because it thinks I already changed it, but it isn't showing that color on my screen, it was still showing black. I've closed the file and re-opened it etc. I've just done it again using the selection tool instead of the direct selection tool and it seems to be working now. So simple, lol. Im sure I was using the direct selection tool yesterday and in my other documents. Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

In that case you might want to check your object hierarchy. Maybe you've grouped your paths and applied a fill to the group.

Use the layer panel and the appearance panel.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Arrgghh, now its doing it again and I cant figure out why.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Can you post the artwork somewhere?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Do you mean here? I could grab a screen shot. I suspect its something to do with the selection but I cant figure outs what is different between the ones it's doing it on and the ones it isn't. I'm currently working on 4 designs that have been wee transferred to me and each time I open them from the download it seems to affect different ones. I suspect like you say its something to do with the grouping or something but I didn't draw them and they mostly appear to be un-grouped. I'm currently using the free trial of cs6 as I have a new pc, up till then I was using cs2 so she has transferred them as cs2. could this be the issue?

What screen shot would be helpful? When I open the files that are affected they have corner widgets turned on which I haven't seen before and I've turned them off thinking that might be it. Hasn't made a difference though.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Opening the file in a higher version has no impact on this.

You need to post a screenshot of the fully opened layer panel after you have selected stuff (objects visible).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2015 Feb 15, 2015

Copy link to clipboard

Copied

Also its working n my other files, just not this one.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

  1. Select None.
  2. Go on Default Swatches.
  3. Select Art & Illustration.

Done.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

also, this can help too.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

LATEST

Isn't there a way to stop anyone replying to a post that's more than a year old?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 10, 2015 Aug 10, 2015

Copy link to clipboard

Copied

hi check this post if you haven't already done so Re: Recolor Wheel keeps changing colors and color selections to color groups rather than artwork col...

its a glitch in the new update and Adobe is aware of it.. work around is to use the eyedropper at the top right to get the artwork colors

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2016 Oct 27, 2016

Copy link to clipboard

Copied

Maybe this will help somebody though the thread opener might not be interested anymore...

When recoloring black you have to check which color range is active for the chosen element. Before recoloring, select the element and open the "Color" Panel. In most cases when the element is colored black it will show the GRAYSCALE range. Open the dropdown on the upper right of the color panel and set it to RGB or CMYK, whatever you are working in. Then you can continue with recoloring.

If the greyscale range is active for the element, it will actually be recolored but the new setting still shows only greys and so it seems as nothing has changed. This is especially important if you selected a group because it is possible that the recoloring won't work if there is just one element wit the grayscale setting included.

I do not really understand what's the purpose of this behaviour but I guess there might be any... This was at least my personal experience with this recoloring issue. Hope it helps. Have fun!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2018 Apr 26, 2018

Copy link to clipboard

Copied

I'm having this same issue. Tried re-assigning to a spot color in my swatches panel but no go when I view Separation Preview it confirms it has not applied. For whatever reason I was able to get it to work by re-assigning to a random CMYK color and then changing again to the correct spot color but this is a bit of a convoluted process. That works anyways.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2018 Aug 27, 2018

Copy link to clipboard

Copied

I had same problem. That was fixed very easy by refresh all illustrator settings. Hold Cmd + Option + Shift (Mac) or Ctrl + Shift + Alt (Win) when app starts. Good luck!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines