• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Select text by clicking on text, not path

Explorer ,
Oct 29, 2019 Oct 29, 2019

Copy link to clipboard

Copied

Is it possible to select a text object created with the plain Type Tool (not Area Type or any other text tool) by clicking anywhere on the glyph itself as opposed to clicking EXACTLY on the anchor path? I am specifically trying to option-click-drag to duplicate and move a copy of a text object and it is difficult to click exactly on the path. I am using the plain selection tool (V). Regardless of my preference settings, I am unable to click anywhere but EXACTLY on the anchor path to perform this action.

 

I am running version 23.1.1 on a mac with High Sierra 10.13.6.

 

Things I have already tried:

1. I have turned OFF the "Object selection by Path Only" option in the Selection & Anchor Display preferences. This setting does not appear to have ANY effect on the selection behavior for text. Illustrator help documentation says this setting "Specifies whether you can select a filled object by clicking anywhere in the object or whether you have to click a path." which sounds like exactly what I need. My text IS filled with black so it seems like it should apply to text objects just like it applies to other objects but it does not. Should this setting apply to text objects?

 

2. I have changed the selection tolerance to it's maximum value of 8 pixels. This also has absolutely no effect on how close my cursor needs to be to select any object. Maybe I am misunderstanding this preference setting. If I have rulers showing and set to pixels, should this preference indicate how close in ruler pixels my mouse needs to be to an object to be able to click to select it? If not, what does this setting do?

 

Is there another preference somewhere that would allow easier selection of text objects?

Views

1.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 30, 2019 Oct 30, 2019

There's similar setting in Preferences > Type. That's the one you need to use.

Votes

Translate

Translate
Enthusiast ,
Oct 29, 2019 Oct 29, 2019

Copy link to clipboard

Copied

Hello! THX_1137
It is weird.
In my environment, the behavior changes with "Object selection by Path Only".

OFF.gifON.gif


How about initializing the environment settings?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 29, 2019 Oct 29, 2019

Copy link to clipboard

Copied

Weird, my machine is allowing me to select a text object no matter how I change my settings. The only thing I can think of is doing an uninstall/reinstall while removing the current preferences and making sure not to bring them back during the reinstall. I do that whenever Ai is acting up and it works most of the time. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 29, 2019 Oct 29, 2019

Copy link to clipboard

Copied

Have you tried restarting Illustrator? Restarting your computer? That's been known to fix things.

 

Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 30, 2019 Oct 30, 2019

Copy link to clipboard

Copied

There's similar setting in Preferences > Type. That's the one you need to use.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 30, 2019 Oct 30, 2019

Copy link to clipboard

Copied

That did the trick Monika, thank you! I was focused too much on the Object Selection by Path Only preference, thinking it would apply to all objects.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

Simply go to Prefrences/Type -> Uncheck!

Screenshot 2023-01-27 160330.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

LATEST

There's already a correct answer from 2019 (the OP hasn't even visited the forum for ten months...)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines