• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Serious Mouse Lag. I cant do my job

Community Beginner ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

Hi,

I have a some serious mouse lag problems lately while working in Illustrator. I havent changed anything, I've been using the same MacBook Pro and 4k secondary display for the past 3 years and never had a problem. When the mouse is over the toolbars it is fine, but when the cursor is in the working area the mouse lags so bad that the program is unusable...

I've seen this issue brought up on other forms, but so far the only work around is to work on my laptop screen and toss my secondary monitor in the trash This issue needs to be resolved soon... I dont really want to learn Corel Draw...

Ai version 23.0

MacBook Pro

macOS Mojave 10.14

Views

11.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Oct 30, 2018 Oct 30, 2018

I had this problem when I first installed Illustrator 2019. If you've only had the problem since then (Illustrator version 23.0) then try:

Illustrator CC Menu > Preferences > User Interface and at the bottom, turn off "Scale Cursor Proportionately" if it's on.

I hope that helps.

Votes

Translate

Translate
Adobe
Community Expert ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

Are Dictation services turned off?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

In the computer system preferences? Yeah it is turned off.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

does turning off GPU Performance help?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

Sadly it did not... thanks for the comment though!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

I had this problem when I first installed Illustrator 2019. If you've only had the problem since then (Illustrator version 23.0) then try:

Illustrator CC Menu > Preferences > User Interface and at the bottom, turn off "Scale Cursor Proportionately" if it's on.

I hope that helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

This worked for me! Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2020 Nov 23, 2020

Copy link to clipboard

Copied

Turning off "scale user interface" worked for me, thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Worked for me as well. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2024 May 07, 2024

Copy link to clipboard

Copied

LATEST

You're a savior. Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2019 Jan 07, 2019

Copy link to clipboard

Copied

I've been having the same issue. I also have the same issue in InDesign. I found that it mostly happens to me whenever I have Photoshop open. However, I work between InDesign, Illustrator, and Photoshop constantly, so having to close each one out is a pain. I've also contacted Adobe multiple times about it and have yet to hear of a fix. So my solution currently is to close out Photoshop, I don't know if that helps or not.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 31, 2019 Jul 31, 2019

Copy link to clipboard

Copied

That's a very interesting observation. I will test it out and keep PS closed while working in Illustrator whenever possible. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

This 'cursor lag' in Illustrator has happened to me from time to time and it's so frustrating.

 

I usually have Illustrator and Photoshop open at the same time, so I didn't think that quitting Photoshop would work, but it did! Thanks!

 

This is an old problem, have you seen any other fixes for it recently?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

This worked for me as well! Whoop whoop!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2020 May 27, 2020

Copy link to clipboard

Copied

Same here. Just had a serious lag in illustrator, turned off photoshop and the problem was fixed. This is frustrating though because I constantly need to work on photoshop....

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 13, 2020 Oct 13, 2020

Copy link to clipboard

Copied

Well spotted. Closing Photoshop stops the issue!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Quitting out of Photoshop solved my cursor lag in InDesign. This is a crazy but that should've been fixed a long time ago. Come on Adobe! You're better than this!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2019 Jun 04, 2019

Copy link to clipboard

Copied

Having the exact same issue (new 2019 macmini, mojave 10.14.5, latest version adobe apps as of this post). Makes Illustrator largely unusable with a very slow, draggy and heavily flickering cursor while on the artboard.

It happens sometimes, and I can't pinpoint what exactly triggers the problem (probably when I copy paste from Ill to PS and some shared library screws up), but when it happens, just quitting and restarting Illustrator does not solve it.

But as TheChancellor says above here, quitting Photoshop immediately fixes the problem (thanks for that), and then restarting Photoshop again also does not bring the problem back, luckily, so I can work again with the 2 apps open side by side. (Until the problem appears again, but this usually takes a while, so this workaround is workable for me.)

Update: Indesign has the same problem, here also, quitting and relaunching Photoshop resolves the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 30, 2019 Jul 30, 2019

Copy link to clipboard

Copied

Having the same problem, no idea what's causing it, but it's making it very difficult to work. The lack of response from Adobe is worrying on this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jul 31, 2019 Jul 31, 2019

Copy link to clipboard

Copied

This has been an ongoing problem for me for a few years now. Completely unacceptable.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 31, 2019 Jul 31, 2019

Copy link to clipboard

Copied

It never has happened to me. It could be hardware related. For people reporting, list Illustrator version, operating system, and mouse model. Have you updated your mouse driver?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2019 Nov 17, 2019

Copy link to clipboard

Copied

Has anyone found a solution for this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2023 Dec 14, 2023

Copy link to clipboard

Copied

I have the same problem. I think Adobe should impliment AI in their Q&A process - instead of just adding AI to their software features. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Hi @mark34268377s39x,

 

I understand that you're experiencing serious mouse lag, and I apologize for the inconvenience. To assist you further, could you please provide more details about your system? Specifically, the make and model of your computer, as well as the operating system version.

 

Additionally, if you could share a screen recording demonstrating the mouse lag, it would be beneficial for our investigation. We'll do our best to address this issue and forward your feedback to the product team for further review. Thank you for your patience and cooperation.

 

Best,

Anshul Saini

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2019 Nov 17, 2019

Copy link to clipboard

Copied

Hey! 

What mouse are you using?

I know there is an issue, that i currently experience as well with Logitech, that might somehow be related to Chromium based browsers. If you have a logitech mouse, try closing the software like chrome, opera or other browser and see if that helps.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines