SVG file missing layer names when using Export

New Here ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

This used to work still a week or two ago, but now I'm having issues when exporting .ai file to .svg. The expoerted file is missing layer names. Test files can be loaded here:
https://drive.google.com/drive/folders/1GnaLeXTFHmWnLYCcHrrXHDZ1YJQ6Zrag?usp=sharing

This is my very simple test file. You can see the object names here.

Siiri23850569p8b9_1-1648795862307.png

 

 

I choose File -> Export -> Export as... and export that as .svg with these settings:

Siiri23850569p8b9_0-1648795520898.png


When I check the svg file code, it doesn't have those names "name.test1" etc. Previously they have been showing when I have exported files same way.

<?xml version="1.0" encoding="UTF-8"?><svg id="a" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 411 482"><defs><style>.e{fill:#fff;stroke:#231f20;stroke-miterlimit:10;}</style></defs><rect id="b" class="e" x="21.5" y=".5" width="239" height="92"/><rect id="c" class="e" x="13.5" y="123.5" width="268" height="148"/><rect id="d" class="e" x=".5" y="361.5" width="410" height="120"/></svg>

I first noticed this maybe a week or two ago. I reinstalled Illustrator and then I was able to export one file correctly, but the next time I needed it, the same issue occurred. Today I tried to reset preferences, but it did nothing. I asked my collague export the exact same file I have issues with and for him it worked. We compared our settings, but couldn't find any difference. Do you have any solution?

TOPICS
Bug

Views

115

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 22, 2022 Apr 22, 2022
Thanks for confirming. I would request you to upvote the UserVoice page listing this issue if not done already. Also, we have logged a bug with the Product Team already. I would request you to be patient and stay tuned for future updates. Thanks, Anubhav

Likes

Translate

Translate
Adobe Employee ,
Apr 19, 2022 Apr 19, 2022

Copy link to clipboard

Copied

Hello @Siiri23850569p8b9,

 

Sorry for the delayed response and the trouble. Multiple users have reported this on our UserVoice. I would request you to please check and confirm if it is the same issue mentioned on this UserVoice page. If yes, I would request you to upvote the UserVoice and add your comments there. By doing this, you will keep getting all the updates related to this issue.

 

Also, please confirm the version of Illustrator installed on your computer.

Additionally, I would suggest you try these steps in order and let us know if it helps:

  1. Uninstall Illustrator using the CC Cleaner tool
  2. Manually remove the preferences for Illustrator

    - Go to Location C:\Users\[YOUR USERNAME]\AppData\Roaming\Adobe
    - Rename Adobe Illustrator and Adobe Illustrator 26 Settings folders to Adobe Illustrator.old and Adobe Illustrator - 26 Settings.old

    Disclaimer: Please note that renaming preferences folders will remove all the custom settings, and Illustrator will
    launch with default settings. You can also take a backup of the folders in case you want to. The location is mentioned above.

  3.  Re-install Illustrator from the Creative Cloud Desktop app.

 

We will be looking forward to your response.

 

Thanks,

Anubhav

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

Hi,

 

Thank you for your answer. Unfortunately that didn't solve the issue: the srv export worked for a while, but after few files the same issue started again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

I of course meant svg*

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 22, 2022 Apr 22, 2022

Copy link to clipboard

Copied

LATEST

Thanks for confirming. I would request you to upvote the UserVoice page listing this issue if not done already.

 

Also, we have logged a bug with the Product Team already.

I would request you to be patient and stay tuned for future updates.

 

Thanks,

Anubhav

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines