SVG is exporting with "white" lines/transparent space between shapes

New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

 

I can't seem to figure out why my SVGs are exporting with what looks like to be the width of a path as transparent space between shapes:

 

Screen Shot 2022-07-14 at 1.13.16 PM.png

In Illustrator, I do not see these "white" lines/transparent space.  It is only when I export the SVG and open it in say PowerPoint or a browser.  It's like upon saving as an SVG, Adobe subtracts the width of the paths from shapes.  All 4 shapes/objects here should be touching each other. 

 

P.S. I am on a mac so hopefully you can see the lines I am talking about in the above image.

 

Any help is appreciated.  Thank you!

TOPICS
Bug , Import and export

Views

52

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 14, 2022 Jul 14, 2022

OK.

The might be gaps because precision can't be set high enough. But you could try a higher "Decimals" value.

If that still does not work, create them in a way that they overlap slightly.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Can you please show the Outline view in Illustrator?

 

If there  are multiple paths that made this shape (using e.g. Live paint), then maybe expanding and uniting is an option?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

Hi Monika,

 

Please see the below.  I am needing the SVG to be four separate shapes like it is now so each can be a separate color and editable in PowerPoint.

 

Screen Shot 2022-07-14 at 2.12.23 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

OK.

The might be gaps because precision can't be set high enough. But you could try a higher "Decimals" value.

If that still does not work, create them in a way that they overlap slightly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

LATEST

Thanks, Monika. 

 

I've tried the highest SVG decimal accuracy of 5 and the issue still persists.  Sounds like I will need to work around this bug by overlapping like you mentioned.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines