• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Ugly white lines around freshly drawn objects

New Here ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

Hi Everybody,

A question from an Illustrator newbie here.

whitelines.png

I have drawn a few simple objects, circles and line segments, but they have a jagged white line around them. So I googled this ugly fenomenon and unchecked the anti-alias checkbox in Preferences and also set the offset to 0.001px. But I still have these lines.
Can anybody please help me to get rid of these lines?
Thanks in advance!

TOPICS
How-to

Views

138

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 14, 2024 Mar 14, 2024

This is an anti-aliasing issue. I'll get to that in a moment.

Sooo, if this is showing just on the screen (i.e. not in an image-based export like PNG or JPG), my guess is you are working in CMYK and the black objects are defined as 0C 0M 0Y 100K, and are NOT set to overprint (Attributes). In the vector world, objects are rendered from the ground up, so your blue is rendered first, then the Black objects are rendered. In these objects, since there is nothing on the C M and Y layers, they are knoc

...

Votes

Translate

Translate
Adobe
Community Expert ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

Can you select one of the objects and show the appearance panel?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2024 Mar 16, 2024

Copy link to clipboard

Copied

HI Doug A Roberts, here it is.  I have set the stroke/fill to Overprint  (Dutch: afdekgroep). Thanks to Brad @ Roaring Mouse  my problem is already solved. Thanks anyway for you reply!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2024 Mar 16, 2024

Copy link to clipboard

Copied

LATEST

screenprint.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

This is an anti-aliasing issue. I'll get to that in a moment.

Sooo, if this is showing just on the screen (i.e. not in an image-based export like PNG or JPG), my guess is you are working in CMYK and the black objects are defined as 0C 0M 0Y 100K, and are NOT set to overprint (Attributes). In the vector world, objects are rendered from the ground up, so your blue is rendered first, then the Black objects are rendered. In these objects, since there is nothing on the C M and Y layers, they are knocked out White, then the Black layer is rendered in that "hole". Unfortunately, Anti-aliasing is allowing a hint of the white knockout to show along the edges.

Now, there is an option in Preferences > General > to turn off Anti-Aliased Artwork for display on the screen, but it seems to only affect things when NOT using the GPU, which seems to ignore that setting depending on what GPU is in your machine.

You can see this if you uncheck Anti-Aliased Artwork in Preferences > General, then toggle between CPU and GPU (Under View > View by GPU<>CPU)

In the print world, we tend to want pure Black like this to overprint anyway to avoid this same problem on the printed page, as even the slightest mis-registration would show as a white gap. So select your Strokes/Fills and set them to Overprint accordingly (View > Attributes)

This will change how it displays on screen no matter the anti-aliasing settings/GPU.

Regardless, this anti-alaising for the screen does not affect proper high-res vector output, so it's just a screen preview anomaly.

 

If, on the other hand, you are seeing this on Exporting an image-based format, make sure (if you DO use anti-alaising) that you select the Art-Optimized option for best results. Type-Optimized, although good for improving the look of smaller type in these exports, also tends to affect other objects as well, and could allow the white gaps to show.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2024 Mar 16, 2024

Copy link to clipboard

Copied

Thank you Brad@RoaringMouse for your detailed answer.

The problem occurred as well on my screen as well in my PNG. I have tried all of the combinations with GPU on/off, Anti-aliased on/off,. The best solution for the screen problem  for me was to have GPU off and Anti-aliased on. For the PNG problem the Art-Optimizes option worked wonders.

Yes, I'm working in CMYK and hhe black objects were indeed not set  to overprint, but that didn't seem to be the problem. I set all objects fill/strokes to overprint to be sure.
Again many thanks, you helped me a lot!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines