Can't select under locked objects when in preview mode

Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

Just to preface this, it may have always been the case but I'm fairly sure it wasn't.

In 2020 when a selection is locked and you're in preview mode you can still select it, this means that if you want to select something underneath (usually the reason I lock things) you can't without moving the thing you're trying to select up or hiding instead of locking. Illustrator tends to add these things and create a checkbox somewhere allowing me to turn it back to how it was before, anybody have an idea how to revert this?


TOPICS
Draw and design, Tools

Views

76

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Nov 09, 2020
Kurt Gold Adobe Community Professional , Nov 09, 2020
You may check if you can disable an option called "Select Objects on Artboard and Unlock" (or some similar term) in the Illustrator Preferences > Selection & Anchor Display section.   It's a pretty new option that allows you to select locked objects on the scratch area and unlock them immediately. That new way may probably have to be improved.  

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

I am working in Illustrator 2020 and cannot reproduce the behavior that you're describing. When I lock an object, either with the keyboard command, or by clicking on it's lock icon in its sublayer in the layers panel it stays locked and unselectable.

Please describe what method that you are using to lock objects.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dative AUTHOR
Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

Hi Bill,

Thanks for the response, I'm using cmd + 2, I believe it's "lock selection" although I haven't clicked it in a menu bar for a long time. Here's a video to explain in more detail. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dative AUTHOR
Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

It's solved now but thanks for trying to reproduce it!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 09, 2020

Copy link to clipboard

Copied

You may check if you can disable an option called "Select Objects on Artboard and Unlock" (or some similar term) in the Illustrator Preferences > Selection & Anchor Display section.

 

It's a pretty new option that allows you to select locked objects on the scratch area and unlock them immediately. That new way may probably have to be improved.

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dative AUTHOR
Participant ,
Nov 09, 2020

Copy link to clipboard

Copied

Aha, this is it! Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Lunnson LATEST
Community Beginner ,
Nov 17, 2020

Copy link to clipboard

Copied

Oh, thank you...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more