Highlighted

Illustrator 2018 importing .dxf files at extremely tiny size

Explorer ,
Oct 20, 2017

Copy link to clipboard

Copied

I regularly get .dxf files from our mechanical engineers and import them into illustrator to save as eps files. Suddenly, with Illustrator 2018 they are importing so small they can barely been when I import at original size. For example, the  drawing below is magnified at 3200%. Since the stroke is coming in at .75pt, it is just a bunch of thick black lines and blobs, but you can see the objects when you highlight the drawing, as shown below.

I was able to open it to normal size by scaling it to about 6400% , but I have been doing this for many years with multiple previous versions of Illustrator and never encountered this. In fact, I opened this specific drawing in Illustrator 2017 just a couple of days ago and it opened normally.

So is there some setting I am not aware of that got changed in the new version of Illustrator, or did Adobe just screw this up? Note that I have tried this with multiple files and all had the same problem.

Views

7.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Illustrator 2018 importing .dxf files at extremely tiny size

Explorer ,
Oct 20, 2017

Copy link to clipboard

Copied

I regularly get .dxf files from our mechanical engineers and import them into illustrator to save as eps files. Suddenly, with Illustrator 2018 they are importing so small they can barely been when I import at original size. For example, the  drawing below is magnified at 3200%. Since the stroke is coming in at .75pt, it is just a bunch of thick black lines and blobs, but you can see the objects when you highlight the drawing, as shown below.

I was able to open it to normal size by scaling it to about 6400% , but I have been doing this for many years with multiple previous versions of Illustrator and never encountered this. In fact, I opened this specific drawing in Illustrator 2017 just a couple of days ago and it opened normally.

So is there some setting I am not aware of that got changed in the new version of Illustrator, or did Adobe just screw this up? Note that I have tried this with multiple files and all had the same problem.

Views

7.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 20, 2017 0
Guide ,
Oct 21, 2017

Copy link to clipboard

Copied

maybe in the import options for DFX DWG

you have scale 1, units 1,  pixels

when it should be, for example,   1 ,1, inches

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 21, 2017 0
Explorer ,
Oct 23, 2017

Copy link to clipboard

Copied

That did not solve the problem. First of all, if you have selected Original Size, I don't think the Scales setting would matter. But either way, no matter what unit value I pick - points, pixels, inches - it still always comes in super tiny.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
Adobe Community Professional ,
Oct 23, 2017

Copy link to clipboard

Copied

This is a long outstanding problem well before 2018 with auto cad not tagging the file with what units this is saved in. Have a feeling who sent you the file changed the units they work in.

The secret is in this popup window which you should be getting.

Screen Shot 2017-10-23 at 3.48.24 PM.png

First change to a smaller until such as millimeters or points. Then change the Unit(s) to 1, then open.

Also remember first thing to do is  check your file >> document >> color mode >> is CMYK if print job or RGB if for digital.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
Explorer ,
Oct 23, 2017

Copy link to clipboard

Copied

Mike,

That is not the answer. First off, as I originally stated, this specific file opened up without problems 2 days before I updated to Illustrator 2018. Second, when the dialog opens it is set with a value of 1 for units and set to Points. I have then selected Scale by and set it to 100%. I have tried selecting Millimeters, pixels, and inches, and they all open the same way.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
Adobe Community Professional ,
Oct 23, 2017

Copy link to clipboard

Copied

Can you  post a copy of one of these .dxf with dropbox or similar ftp sharing link. .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
New Here ,
Feb 16, 2018

Copy link to clipboard

Copied

I am extremely new to Illustrator, but I am experiencing the issue described.  Example dxf file here:

https://raw.githubusercontent.com/dotdash32/Cases/master/Minidox/Minidox%20Plate.dxf

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 16, 2018 0
Guide ,
Feb 17, 2018

Copy link to clipboard

Copied

I cannot  see a download link to a file from there, but maybe it's  my setup .

Are you in communication with the  dxf file creator, they should be sending you files more suitable  for illustrator .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 17, 2018 0
Adobe Community Professional ,
Feb 17, 2018

Copy link to clipboard

Copied

I was able to open it with Scale to Fit Artboard options

dxfOpenOptions.PNG

dxfOpenOptions2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 17, 2018 0
New Here ,
Mar 01, 2018

Copy link to clipboard

Copied

But opening it to artboard will just use the default artboard size so it won't be accurate. 

Someone please take a look at this problem.  As it constantly happens with Fusion 360 and Illustrator.  Posting in Autodesk's forum, they just point the finger at Adobe. 

I've read elsewhere and the suggestion is to scale by some factor, but I can't find that thread. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0
New Here ,
Mar 01, 2018

Copy link to clipboard

Copied

mjulson1 is right.  Choosing "scale to fit" does make it visible, but the scale is likely important and lost (or at least not obvious to the user).  I don't think Illustrator is handling the situation wrong, but it could be handled better.

I suspect the dxf simply has unit-less measurements that can be used differently by whatever tool generated the dxf.  Therefore, illustrator doesn't know how to interpret.  Illustrator gives you the prompt to choose, but I think it could possibly be a little more helpful.  In my example above, I eventually found that I could select "Scale by" then set "Unit(s) = 35.28 mm" to produce a view that appeared reasonable.  I think the Illustrator import prompt could likely guide me to this value in a more intuitive fashion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0
New Here ,
Mar 24, 2018

Copy link to clipboard

Copied

Hi all. This took me a long time to figure out. Here's the answer/trick:

DXF files are referred to as unitless. If I'm working on an architectural document set to feet and I export a 100' object as a DXF file, the Illustrator import/place dialog box just sees that the object is 100 "things" long. In order to size an object accurately upon import, there needs to be a clear relationship between the object-to-be-imported units and the document units. If Illustrator had the option to view documents in feet, there wouldn't be an issue. But Illustrator was born of Graphic Design, and its measurement options are limited: points, picas, inches, millimeters, centimeters, pixels.

The trick is to temporarily change the units of your source document to one of the native Illustrator measurement options before generating the DXF files. I'll pick inches. So now, in Revit or Rhino or whatever I am working in, my 100-foot object is registering as 1200 inches. Export the object as a DXF file.

Since I'm preparing architectural surfaces for laser cutting and eventual assembly into scale models, I'll use that scenario as my example. In Illustrator, I choose File > Place, select my file and the DXF/DWG Options dialog box appears. I'm making a 1/48 model, so for every 48 units in my DXF file, I want 1 unit in my Illustrator file. You can see the options I selected here. If I set everything up correctly, my 100' (1200") wall should import as a 24.96" object. And it does​. Hope this helps some people out. Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2018 2
New Here ,
Feb 05, 2020

Copy link to clipboard

Copied

@dfkurz. I too have this same issue, but just found the solution. Open the DXF or DWG and select the "Original Size" or "1:1", doesn't really matter the units as you've mentioned. Once the file is open, select all of the imported artwork. On the Properties Manager on the top that indicates the height (H) and width (W), just change the units shown to the units that are intended for the DXF or DWG. I was also able to do "Original Size" and then change the units on the import upon a second try, but I needed to change the scaling to 1:1 to update to the new units. I hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2020 0
New Here ,
Aug 19, 2020

Copy link to clipboard

Copied

Hi all,

I faced a problem with Adobe_Illustrator_CC_2018_v22.1.0.312x64. Autocad (.dwg) file not open with original size in illustrator. Example, a single line size is 480.5mm in original autocad file, but when I opened that file in illustrator then that size is 146.3mm. Please solve this issue. Thanks is advance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2020 0