Highlighted

Items from CC Libraries not placing correctly

Community Beginner ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi Adobe Community,

I recently updated Illustrator to Version 22.0.1 on my work Mac OS High Sierra system. Our company relies heavily on the Adobe CC Library's ability to Alt+Drag an item to a document for printing templates. I noticed with the recent update that when pulling an asset with multiple elements from the Library onto a document, all items are automatically grouped together and some elements are misplaced. I've included some screenshots below to illustrate what I mean.

Artboard 1.png

Untitled-1.png

Thanks for your time.

Adobe Community Professional
Correct answer by MikeGondek | Adobe Community Professional

This is because you have a pattern.

Object >> Expand Appearance , then add to the library.

This has to do with your pattern its based of 0,0 on your rulers. You have have to either

1) place this directly at 0,0

2) place this, then move to 0,0 with this setting off.

Screen Shot 2017-11-15 at 4.55.37 PM.png

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Items from CC Libraries not placing correctly

Community Beginner ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi Adobe Community,

I recently updated Illustrator to Version 22.0.1 on my work Mac OS High Sierra system. Our company relies heavily on the Adobe CC Library's ability to Alt+Drag an item to a document for printing templates. I noticed with the recent update that when pulling an asset with multiple elements from the Library onto a document, all items are automatically grouped together and some elements are misplaced. I've included some screenshots below to illustrate what I mean.

Artboard 1.png

Untitled-1.png

Thanks for your time.

Adobe Community Professional
Correct answer by MikeGondek | Adobe Community Professional

This is because you have a pattern.

Object >> Expand Appearance , then add to the library.

This has to do with your pattern its based of 0,0 on your rulers. You have have to either

1) place this directly at 0,0

2) place this, then move to 0,0 with this setting off.

Screen Shot 2017-11-15 at 4.55.37 PM.png

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Nov 10, 2017

Copy link to clipboard

Copied

Hi almeniac,

Please try resetting preference for  Illustrator.

Close all Adobe applications.

~/Library/Caches

~/Library/Application Support/Adobe

~/Library/Preferences

Delete or rename Adobe Illustrator, com.adobe.illustrator and Adobe Illustrator 22 Settings folders.

Launch Illustrator from the creative cloud.

Kindly update the discussion if you need further assistance with it.

Thanks,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 10, 2017

Copy link to clipboard

Copied

Since you are on mac, assume you meant option.

Seems once you pull from library and extra group command is added to your original art You should be able to do one ungroup command after placing to fix that..

I could not reproduce the position moving using Sierra. What happens if you drag without option to place as cloud item. I realize that you want to edit the objects but curious.

Top item is original prior to adding to library, bottom is option dragged from library.

Screen Shot 2017-11-10 at 6.49.11 PM.pngScreen Shot 2017-11-10 at 6.51.06 PM.png

Try Command Y to see if this is a preview bug retailed to GPU preview.

Note in CC2018 they lost the ability to remember what layer your art should be on. I did 6 key lines yesterday and did not notice until later that all the elements I pulled were on wrong layers.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 11, 2017

Copy link to clipboard

Copied

Maybe you can comment on this bug and add your problem with the displaced items:

Option dragging a graphic from CC library does not remember layers in update 2018 – Adobe Illustrato...

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 15, 2017

Copy link to clipboard

Copied

Hi almeniac,

I would like to know if the steps suggested by above worked for you, or the issue still persists.

Kindly update the discussion if you need further assistance with it.

Thanks,

Srishti

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 15, 2017

Copy link to clipboard

Copied

Hello,

Sorry for the delayed response.

I tried the steps mentioned November 10th of renaming my settings folders and files and launching Illustrator CC 2018 from the Creative Cloud, I still had the same issue.

In response to MikeGondek,the objects still shifted off from it's original position when viewing in outline mode (Command Y).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 15, 2017

Copy link to clipboard

Copied

Would like to know is if you

  • recreate this asset, does the offsetting happen everytime?
  • double click on the asset preview to edit the original asset in illustrator, does the position look off?

Can you please post a copy of your graphic in .ai format using dropbox or similar ftp sharing link. Would like to see if this happens on someone else computer, which would mean there is something in the construction of the asset

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 15, 2017

Copy link to clipboard

Copied

Certainly!

Here's a link from Google Drive. Let me know if you have any trouble viewing or downloading this file.

Print_Template_Adobe.ai - Google Drive https://drive.google.com/file/d/17N6XE6-YbBPXcO77tvn9wbjprwyym_pc/view?usp=sharing

When I double click to preview the asset in the library, everything is in it's right place and properly grouped.

I've also confirmed that this also happens on my co-workers computers with different assets as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 15, 2017

Copy link to clipboard

Copied

This is because you have a pattern.

Object >> Expand Appearance , then add to the library.

This has to do with your pattern its based of 0,0 on your rulers. You have have to either

1) place this directly at 0,0

2) place this, then move to 0,0 with this setting off.

Screen Shot 2017-11-15 at 4.55.37 PM.png

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 15, 2017

Copy link to clipboard

Copied

Hi MikeGondek,

I updated my preferences with the Transform Pattern Tiles option unchecked.

When I attempted to Expand the appearance, the option was unavailable (grayed out). I tried to do so by direct selecting the rectangle (containing the pattern only), the group containing the patterned rectangle and circle with arrow, and ungrouping to select the patterned rectangle.

Screen Shot 2017-11-15 at 4.58.34 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 15, 2017

Copy link to clipboard

Copied

My mistake use object >> expand. This will give you vector shapes for each.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 16, 2017

Copy link to clipboard

Copied

Hi MikeGondek

As a result, I got this when Alt+dragging out from the CC Library after expanding the pattern's appearance..

Screen Shot 2017-11-16 at 5.01.48 PM.png

This has resulted with the expanded pattern and elements still not placing correctly.

Our team will probably need to continue to use CC 2017 as expanding the patterns will over complicate our shared print template files. I greatly appreciate your assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 17, 2017

Copy link to clipboard

Copied

There must be some miscommunication here, will try to rephrase.

You need to expand appearance on a good copy of the artwork with everything in correct position. You can do that by double clicking on the item in your library which will allow you to edit the artwork. you can then expand and save. Your items will drag out of the library now as you see without shifting.

What we are doing is eliminating the pattern, as patterns will shift position depending on where they land on the page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 17, 2017

Copy link to clipboard

Copied

Yeah there must have been a mixup. Apologies I wasn't clear on things.

My original issue was the objects shifting, not the pattern, when dragging from the CC Libraries. In the first photograph that was posted, I was pointing out that the circle and arrow were not in the same position as how it was originally created as an Library Asset.

I would still need to keep a pattern in the rectangle shape with the circle and arrow over it. When my team was using CC 2017, placing objects from the library (whether it had a pattern or not) always kept the same position, grouping, and arrangement. With the 2018 update, there now seems to be an issue of objects being grouped altogether, patterns shifting, and objects not in their original positions.

I'm wondering if this is just an issue with my OS as you pointed out earlier you are working with Sierra and I am on High Sierra?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 17, 2017

Copy link to clipboard

Copied

In my tests on a Mac Sierra, only the pattern was shifting and not the objects, so sorry I cannot offer any better advice  on that part.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 17, 2017

Copy link to clipboard

Copied

No worries.

Thank you again for your assistance. I went ahead and pasted this post to the bug report link from earlier. Our team will be using CC 2017 until this gets resolved (soon I hope).

Best.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 17, 2017

Copy link to clipboard

Copied

Placing objects that contain a pattern as a copy from a CC Library will almost always shift the pattern.

It does not matter if it's version 2017 or 2018 or Sierra or High Sierra.

If the object with the pattern is not placed at the exact same position when it was created in relation to the 0/0 ruler origin, the pattern will shift, just like it has always done when pasting between different documents.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 17, 2017

Copy link to clipboard

Copied

And, yes Mike's suggestion to expand the Pattern before you create the Library object will solve the problem, because then it is not a pattern anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Resources
Add a group