Highlighted

Mixing Arabic and English Text

New Here ,
Mar 07, 2018

Copy link to clipboard

Copied

Hi,

I'm having trouble with orientation for Arabic and English text. The Arabic text is displaying alright, but the English text is displaying right-to-left. How do I make the English text left to right, in Illustrator CC 2018?

Adobe Community Professional
Correct answer by Zaid Al Hilali | Adobe Community Professional

Yes, it is possible to remove existing InDesign, however it would be better to download an older version from the desktop menu that supports Arabic.

Previous3_2017.jpg

Whats even better is to use existing InDesign to work with Arabic by following steps mentioned at this post​ by Federico_Platón

  1. I have open InDesign CC 2015 (it also works in any later version too) US version.
  2. Changed the typeface to ArialMT (Windows OS OT font)
    (to control text Hyphenation it would require selecting Arabic as Language, too).
  3. Selected World Ready Composer for that paragraph.

          (Blue dot shows right to left word direction)

Views

4.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mixing Arabic and English Text

New Here ,
Mar 07, 2018

Copy link to clipboard

Copied

Hi,

I'm having trouble with orientation for Arabic and English text. The Arabic text is displaying alright, but the English text is displaying right-to-left. How do I make the English text left to right, in Illustrator CC 2018?

Adobe Community Professional
Correct answer by Zaid Al Hilali | Adobe Community Professional

Yes, it is possible to remove existing InDesign, however it would be better to download an older version from the desktop menu that supports Arabic.

Previous3_2017.jpg

Whats even better is to use existing InDesign to work with Arabic by following steps mentioned at this post​ by Federico_Platón

  1. I have open InDesign CC 2015 (it also works in any later version too) US version.
  2. Changed the typeface to ArialMT (Windows OS OT font)
    (to control text Hyphenation it would require selecting Arabic as Language, too).
  3. Selected World Ready Composer for that paragraph.

          (Blue dot shows right to left word direction)

Views

4.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 07, 2018 0
Adobe Community Professional ,
Mar 07, 2018

Copy link to clipboard

Copied

It would have been nice if you showed us the issue from a screenshot. Any how, if this below what you're facing? Then change Character Direction to the "Default Direction" and let InDesign handle mixed Latin/Arabic.

Character-Direction.jpg

The best way is to handle mixed Arabic/Latin scripts via Paragraph panel.

Paragraph-panel.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2018 1
New Here ,
Mar 07, 2018

Copy link to clipboard

Copied

I don't see those options. Instead, this is what I'm seeing:

Screen Shot 2018-03-07 at 11.37.58 PM.pngScreen Shot 2018-03-07 at 11.39.38 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2018 0
Explorer ,
Mar 07, 2018

Copy link to clipboard

Copied

Have you got ME version installed?  If not, you need to uninstall and install the ME version , then you'll get the RTL markings that you need.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 07, 2018 1
Adobe Community Professional ,
Mar 08, 2018

Copy link to clipboard

Copied

Yes, it is possible to remove existing InDesign, however it would be better to download an older version from the desktop menu that supports Arabic.

Previous3_2017.jpg

Whats even better is to use existing InDesign to work with Arabic by following steps mentioned at this post​ by Federico_Platón

  1. I have open InDesign CC 2015 (it also works in any later version too) US version.
  2. Changed the typeface to ArialMT (Windows OS OT font)
    (to control text Hyphenation it would require selecting Arabic as Language, too).
  3. Selected World Ready Composer for that paragraph.

          (Blue dot shows right to left word direction)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 08, 2018 1
Engaged ,
Oct 09, 2019

Copy link to clipboard

Copied

I had huge issues with copying arabic and english mixed text from word over to Illustrator (unitl I finally found a super easy solution - see below). I initially did everything that was suggested and mentioned in forums: but still, when tried to cut & paste mixed arabic text with roman numerals, the numerals got transformed into arabic numerals in Ilustrator. When performing cut n' paste from Word to Window's text editor software (which is probably by far the simplest app I have), the mixed paragraph got copied over 100% perfect. Only when I copied into Illustrator, I had the issue. It was really becoming  frustrating, as all Adobe's solutions didnt work either. Here is what I was told to do: 

 

1.) Check to "indic options"

2.) Selected "Middle Easter Single Line composer"

3.) Finally, I was told to clean / deleted and remove my copy of illustrator with a special removal-tool from Adobe and told to re-install the English-Arabic version of Illustrator.

 

But that didn't resolve the issue either.  I was also not able to see the LTR (Left to Right) and RTL options. 

 

I finally found a work-around (totally unrelated to any support suggestions). When I copied the text with cut & paste into an existing text frame, the issues remained (roman numerals got transformed into arabic text, which I did not want). When I copied the text into a new blank text frame, for some reason, the issue was resolved and I was able to cut & paste mixed english and arabic just fine.

 

It seems that if Illustrator once recognises text as purely arabic, the text frame then gets defined as a purely "arabic" text frame. When new but mixed text gets copied into such a text frame, the incoming text (which in my case included roman numerals) then gets converted to arabic numerals. If, on the other hand, a text frame is newly created and text copied into it, it will recognise incoming "mixed" text and define the text frame as a "mixed" text frame, so that any future mixed text copied into it will remain mixed.     

 

I realize this is a very specific and unfortunate problem to have had and have run into. But it would have saved me a lot of time & hassle, if Adobe Support understood the problem from the outset, which they obvioulsy did not. Instead they did what so many support people do, they simple offer standard answers without trying to understand the depth of an issue first. In my case, I was put on many detours, which all turned out to be completly un-related and unnecessary.

 

Anyway, I am happy I soved this issue and hope this will be of help to anyone encountering this very specific Illustrator behavior. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
New Here ,
May 28, 2020

Copy link to clipboard

Copied

Hi, 

I have the same issue, and need to do a work with 4 different languages involved.

I read your post carefully, so I must clear my illustratore US version and install a ME one?

Do you work with Win or Mac?

I work with both and I need to solve on both OS. I'm frustrated, all that I read and tried doesn't work.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 28, 2020 0
Adobe Community Professional ,
Oct 09, 2019

Copy link to clipboard

Copied

You need to turn on Preference>Type>Show Indic Options before the Paragraph options will be available.

clipboard_image_0.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Engaged ,
Oct 09, 2019

Copy link to clipboard

Copied

Please re-read my post. You will see that I mentioned that I checked the Indic Option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 09, 2019 0
Resources