Highlighted

smart guides are not working

New Here ,
Jun 11, 2018

Copy link to clipboard

Copied

For some reason, the smart guides have stopped working. Haven't done any changes and have updated the Illustrator too. Please help as its supper annoying.

Correct answer by abberdab | Community Beginner

I was having this problem, too. EXTREMELY annoying. Turned out “Smart Guides” was checked in my “View” menu even though it wasn’t actually enabled. I selected the “Smart Guide” menu item to turn it “off” and it remained checked. I toggled it again, this time it became unchecked. I toggled it again — checked. And now it works. WHA. I can’t recall what all menu items were behaving similarly, but Smart Guides wasn’t the only item that was checked but not actually enabled. Seems to be a weird buggy thing.

Views

9.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

smart guides are not working

New Here ,
Jun 11, 2018

Copy link to clipboard

Copied

For some reason, the smart guides have stopped working. Haven't done any changes and have updated the Illustrator too. Please help as its supper annoying.

Correct answer by abberdab | Community Beginner

I was having this problem, too. EXTREMELY annoying. Turned out “Smart Guides” was checked in my “View” menu even though it wasn’t actually enabled. I selected the “Smart Guide” menu item to turn it “off” and it remained checked. I toggled it again, this time it became unchecked. I toggled it again — checked. And now it works. WHA. I can’t recall what all menu items were behaving similarly, but Smart Guides wasn’t the only item that was checked but not actually enabled. Seems to be a weird buggy thing.

Views

9.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 11, 2018 2
Most Valuable Participant ,
Jun 11, 2018

Copy link to clipboard

Copied

Claudio,

If no brighter suggestions appear, you may try the list and hope for one of the easy ones.

If things that should work simply refuse to (all possibilities exhausted including the A) - C) below (and carefully making sure you are performing (all) the needed things)), you may try (the relevant part(s) of) the list 1) - 6) below.

Sometimes, (certain) things may fail or stop working for no apparent reason. When the (other) possible reasons/cures fail to work, it may be some kind of (temporay or permanent) corruption, or even some inconvenient preference setting(s), which may be cured with something on the following list set up in an attempt to provide a catchall solution for otherwise unsolvable cases. It starts with a few easy and harmless suggestions 1) and 2) for milder cases, and goes on with two alternative ways 3) and 4) of resetting preferences to the defaults (easily but irreversibly and more laboriously but more thoroughly and also reversibly), then follows a list 5) of various other possibilities, and it ends with a full reinstallation 6). If no other suggestions work, or if no other suggestions appear, you may start on the list and decide how far to go and/or which may be relevant.

The following is a general list of things you may try when

A) The issue is not in a specific file,

B) You have a printer correctly installed, connected, and turned on if it is physical printer (you may use Adobe PDF/Acrobat Distiller as the default printer with no need to have a printer turned on, obviously you will need to specify when you actually need to print on paper), and

C) It is not caused by issues with opening a file from external media.

You may have tried/done some of them already; 1) and 2) are the easy ones for temporary strangenesses, and 3) and 4) are specifically aimed at possibly corrupt/inconvenient preferences); 5) is a list in itself, and 6) is the last resort.

If possible/applicable, you should save current artwork first, of course.

1) Close down Illy and open again;

2) Restart the computer (you may do that up to at least 5 times);

3) Close down Illy and press Ctrl+Alt+Shift/Cmd+Option+Shift during startup (easy but irreversible);

4) Move the folder (follow the link with that name) with Illy closed (more tedious but also more thorough and reversible), for CS3 - CC you may find the folder here:

https://helpx.adobe.com/illustrator/kb/preference-file-location-illustrator.html

5) Look through and try out the relevant among the Other options (follow the link with that name, Item 7) is a list of usual suspects among other applications that may disturb and confuse Illy, Item 15) applies to CC, CS6, and maybe CS5);

Even more seriously (this may be serious because you may need to restore plugins and whatnot afterwards if you have customized things), you may:

6) A) Uninstall (ticking the box to delete the preferences if applicable), B) run the Cleaner Tool (if you have CS3/CS4/CS5/CS6/CC), and C) reinstall. You may try without step B), but sometimes it is needed, because otherwise things may linger.

As it appears from this thread, it may be worth repeating this if it fails to help the first time:

https://forums.adobe.com/thread/2283530

To uninstall:

https://www.adobe.com/cfusion/search/index.cfm?loc=en_us&term=uninstall&cat=support&product=illustra...

Cleaner Tool:

http://www.adobe.com/support/contact/cscleanertool.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2018 1
Community Beginner ,
Jul 25, 2018

Copy link to clipboard

Copied

This was very frustrating when it happened to me just today.

Disable "Snap to Point" and "Snap to Grid" in your view menu. This should fix it.

Be sure of course "View>Smart Guides" is enabled, obviously you've done that.

Go to Preferences>Smart Guides and be sure you have them set as you like, obviously you've done that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 25, 2018 6
New Here ,
Oct 29, 2018

Copy link to clipboard

Copied

I was having the exact same problem - after searching I ended up on this page.

I went through the menu items and discovered that 'Snap to Pixel' must be turned on, it didn't matter whether or not the other 'snap to...' choices were selected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2018 0
New Here ,
Nov 28, 2018

Copy link to clipboard

Copied

After over  an hour of frustration this quick fix worked. Thank you..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2018 0
New Here ,
Jul 12, 2019

Copy link to clipboard

Copied

I was having this problem too and with help of this answer and experimentation I found that 'snap to grid' is the one option that causes smart guides to disappear.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 12, 2019 0
Community Beginner ,
Jul 25, 2018

Copy link to clipboard

Copied

I was having this problem, too. EXTREMELY annoying. Turned out “Smart Guides” was checked in my “View” menu even though it wasn’t actually enabled. I selected the “Smart Guide” menu item to turn it “off” and it remained checked. I toggled it again, this time it became unchecked. I toggled it again — checked. And now it works. WHA. I can’t recall what all menu items were behaving similarly, but Smart Guides wasn’t the only item that was checked but not actually enabled. Seems to be a weird buggy thing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 25, 2018 1
Most Valuable Participant ,
Jul 26, 2018

Copy link to clipboard

Copied

Thank you for sharing, abberdab, that is a significant finding that may spare others the possible inconvenience of (the more serious parts of) the list.

You may report it here:

Adobe Illustrator Feedback

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 26, 2018 0
New Here ,
Dec 05, 2019

Copy link to clipboard

Copied

This happened to me too; Smart Guides is checked. Then selecting it keeps it checked. Then selecting it again turns it off. Then selecting it again turns it on and it actually works. Ridiculous bug!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 05, 2019 0
Community Beginner ,
Mar 27, 2019

Copy link to clipboard

Copied

Here is the real answer for those of you with illustrator cc 2019. I found this out by playing around. TURN OFF show bounding box. Also make sure you have smart guides TURNED ON and "Alignment Guides" Checked in preferences. This works for both text and objects! Once you do that it all snaps no problem!! So glad adobe tech could not figure that one out....geezz

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2019 0
New Here ,
Oct 17, 2020

Copy link to clipboard

Copied

For me this was life saver. Click on Gray Area of the artboard (outside the artboard).


Click the following button. And then press Command + U or Ctrl + U

CleanShot 2020-10-18 at 11.13.52.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 17, 2020 0