Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Converting Endnotes to Footnotes return blank reference

New Here ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

Hi! 

TL;DR: In some documents, when I try to convert Endnotes to Footnotes with the menu option, my Endnotes return mostly blank. I have the reference number at the correct place, but the reference stays behind, numberless. The same thing happens if I try manualy, reference by reference. What can I do?

 

Long story: I need to convert my InDesign document into Wordpress after all the editing is done. They all are research paper, so many many references. I want to keep the references linked to save me the hassle to relink them one by one (as they are so many), and it seems to work if I convert my endnotes to footnotes, extract the document to RTF, open as Word and copy/paste the result into Wordpress. However, some documents, and I do not understand why, do not let me easily transfer my endnotes to footnotes. They "convert" the right numer of references, but the result is just numbers being transferred at the end of the correct page but the data stays behind, unlinked to everything. I just updated the software to see if it was corrected with other bugs, but my problem remains.  

 

Maybe a script? Maybe an easier way to achieve my goal? Maybe something else I can do? Thanks!

TOPICS
Bug

Views

29

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 22, 2021 Jul 22, 2021
Thanks for posting! I already see something odd in your endnote text frame. Look at the second endnote text. The closing blue "bracket" of the second endnote text comes immediately after the tab that follows "2." . So the text that follows with "BIRD, Richard M., …" is not part of that endnote text. Therefore it will not be converted to a footnote! The same issue is with the following endnote texts. To resolve this, move the text after the closing bracket right after the tab. You should d...

Likes

Translate

Translate
Adobe Community Professional ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

Hi Eve-Lyne,

hard to tell what's going wrong.

What is the version of InDesign you see this?

What's your operating system?

 

Could you post a screenshot with hidden characters and frame edges visible?

Before and after you did the conversion.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

I'm using CC2021, my InDesign says it's version16.3.2. I'm on a mac, Big Sur 11.2.3.

 

This is an example of a document not working. The first image is the Endnotes before I transfer them to Footnotes, the second image is the blank Footnotes and the last one is the remaining Endnotes. Hope it helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

Thanks for posting!

I already see something odd in your endnote text frame.

 

Look at the second endnote text.

The closing blue "bracket" of the second endnote text comes immediately after the tab that follows "2." .

So the text that follows with "BIRD, Richard M., …" is not part of that endnote text. Therefore it will not be converted to a footnote!

 

The same issue is with the following endnote texts.

EndnotesTextFrame-1.png

 

To resolve this, move the text after the closing bracket right after the tab. You should do that in the Story Editor Window. Enable the Story Editor with the keyboard shortcut Cmd + Y ( Mac OS ) or Ctrl + Y ( Windows 10 ). If your version of InDesign is in French the keyboard shortcut could be different.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

Thanks so much! It is a project that was made outside our organisation, so I have no clue how that happened. But the good news is I now do know how to repair it. Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

LATEST

"I have no clue how that happened"

Well, someone typed the text when InDesign showing the page in Preview mode perhaps.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines