Cross reference forcing line break?

Community Beginner ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

I'm using cross references in my productions since way back and it has always worked out with no problems. Now I seem to encountered a problem that I can't solve. Picture no 1. Here I've entered the page reference by hand (the blue figure 60). Picture no 2. Here I'm using cross reference tool and just applying it for the creating the page ref figure (the black figure 60). When using cross reference tool the figure jumps over to the next line. I have to decrease spacing to like -40 for the whole sentence to make it come back on the same line again. And that is not an option... Problem occours in both in 16.4 version (2021) and 17.2 (2022). Apple M1. Mac OS 12.3.1.
Anyone got a clue?

TOPICS
Bug , Type

Views

175

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Apr 17, 2022 Apr 17, 2022
Hi @Stefan Wulff: I did a little research and it appears that changing the composer from the Paragraph Composer to the World-Ready Paragraph Composer addresses this very odd issue. ~Barb

Likes

Translate

Translate
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Go to the cross reference set up, you can go to the standard text set up and replace the normal space before the number with a nonbreaking space of different widths. You will find it in th @-menu on the side,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Making that will only force the word infront of cross ref to change line as well.  And I don't want a spacing to be part of the cross ref.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

It will only keep page number with the previous word IN the cross reference together, NOT with the word before the cross reference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Hi @Stefan Wulff:

 

Can you share a screen shot of the x-ref setup and the same figure 2 but with Hidden Characters visible?

 

~Bar

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Thanks for your time. Hope this is what you're looking for. The Cross ref is set to numbers only, no spacing or other text involved. This because at times I need to set intervalls; for example. See p. 45 – 64.

 

Skärmavbild 2022-04-15 kl. 15.43.55.pngSkärmavbild 2022-04-15 kl. 15.46.24.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Yes, thank you. If you type in the number 60 does it fit as expected? And what happens if you uncheck Character Style for Cross-Reference? 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Still trying to recreate it. The red 60 is a x-ref, the black 60 is typed in. They have the exact same width, which makes me think your character style is increasing the width.

 

macOS 12.1

InDesign 17.2

 

~Barb

 

xref.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

I've tried both with and without charcter style. Same problem. The style used doesn't do anything. It is applied just in case we would like to change it later. I had the same problem a couple of weeks ago in another production (and I was forced to manualy enter page numbers and make a hyperlink. (Thanking higher powers that we didn't make any late layou changes). That production was using Avenir Next. This one uses Mr Eaves XL San OT. So font may not be the issue either. I can't recall running in to this problem on my former cpu (a Mac Book Pro using IOS 11.xx and Indesign 16.x). I'm puzzled. Is there a general setting making Indesign reserve space for like four digits in cross ref? It is like there is a hidden boundary surrounding the ref number.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Not that I can determine. As you can see in my last screen shot, the x-ref and the digits are the exact same width.

 

Hopefully someone else will come along with some insight. I'm very curious. In the meantime, can you package and share just that one page? You can put it on dropbox and add a link here (public) or message me privately.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 17, 2022 Apr 17, 2022

Copy link to clipboard

Copied

Hi @Stefan Wulff:

 

I did a little research and it appears that changing the composer from the Paragraph Composer to the World-Ready Paragraph Composer addresses this very odd issue.

 

~Barb

wrc.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 17, 2022 Apr 17, 2022

Copy link to clipboard

Copied

Barb,

 

Thank you so much for your time and for solving this problem. That was an odd one. I did test to change from Adobe Paragraph composer to single-line … but not to world ready. 

I'll make this default from now on, hoping nothing else goes wild.
Are you in a position to report this issue to Adobe or should I report it?

 

Yet again. You saved me lots of time and stress.
Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

LATEST

Hi @Stefan Wulff:

 

I'm glad we have a solution. 😊 I'm just a user like you, so I'd say go ahead and report it.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines