Data Merge Image Paths

Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I'm using CS5 on Mac OS 10.5 and 10.6 at work (I'm at home now, so I can't be more specific at the moment), and experimenting with Data Merge. I place an image, and use the "copy full path" feature in the links manager and paste it into my spreadsheet. When I do the actual merge, it works (the image is imported with the merge) if the path leads to a folder on my hard drive, but not if the path leads to an external drive.

Does anyone know if the path that the links manager creates is the wrong syntax for using data merge? If so, is there some place where I can read the "rules" of how the text string should look?

Views

49.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I don't know that I've ever seen the syntax defined. However, as a workaround, why don't you put the images on your hard drive, and use Data Merge to create the InDesign file. Then use the Links panel in InDesign to relink the images to those on your hard drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

In short, that wouldn't be practical. There will be hundreds or thousands of images.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

Here is the syntax as defined in InDesign Help:

http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-6c3ca.html

Click on the Add image fields to the data source file link.

If it's not working for an external drive, it could unfortunately be a bug.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I've already been there. The examples show images on the HD, which I have no trouble with. It's just not working from the external drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I found this old thread pertaining to CS3, but the limitation may still hold today:

http://forums.adobe.com/thread/331247

It suggests the InDesign file, the Excel file and the images all need to be on the same drive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I'll try saving the ID and text files to the external when I get back to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I think this is probably a drive mapping issue, and ID is fussy about paths. Select a file onthe external drive and see what the path is on the second machine, then do a find/change on the text file to fix the path statements and save a second copy so you can use one for each machine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

I'm not sure I follow you, but I've only tried this on one machine so far. That would probably work if the path began with "Bills Mac" and you were trying from "Steves Mac," but it doesn't work from Bill's Mac either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

What does the path in a single line look like in the text file now?

If you manually place that image on the second machine, and copy the path to the clipbaord, what do you see? Are they identical?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

Sorry, but as of yet, there has been no second machine. Just one machine with an external USB drive.

To get the path, I'm placing an image from the HD into a new ID document, clicking on the image in the links manager, and selecting "copy full path" from the links manager's fly-out. It works if I place images from a folder on my internal HD, but when I try from the USB drive, I get an error message that ID couldn't locate the images.

I'm not at work now, but I'll post the exact path to the forum when I can (I work nights, so it will be a while).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

You've confused me. What's on the USB drive, the images, or the text file? Is the path in the text file referring to the hard drive of the machine into which it's been plugged?

I think Macs do some strange addressing stuff with USB, but I'm a PC guy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

Sorry to have confused you. The office has several workstations—all Macs with some form of 10.5, but one (the one I use) that has some form of 10.6 (sorry that I can't be more specific now, but I'm at home). All machines are supposed to go up to 10.6 at some point, but I'm not the administrator, so I can only ask for any software updating—I can't do it myself.

There is a PC server, but for some reason, they use an external USB drive for archiving. It would probably make sense to always have the USB drive hooked up to the same machine, but it would be more flexible if it could be carried to any machine, should the main one be tied up by something else.

It is from the archives that the images for this job (a 12-24 page ad sheet that publishes every two weeks) will be taken. Images are located in 11 folders, depending on the SKU of the product in the ad. I'm looking to introduce Data Merge into the mix so that we can get a whole page's worth of ads from a data sheet, rather than looking up each ad by SKU and copy/pasting from the archive. The hope is to pick SKUs from a database, assemble them by page into tab-delimited text files, and use Data Merge to bring each ad into a text frame, with any associated product image or logos.

So, at this point, the only problem is that the path that I copy from the links manager returns an error when the images are on the USB drive, while the same method works if the image is on the HD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

A little more info:

I'm using an iMac with 10.6.6, and I haven't tried on the other iMacs that run 10.5.8. InDesign is CS5 (7.0.3). Here is what the paths look like when copied from the links manager:

HD, root level:
/204983 SS Pkt Tees.tif

In a folder on the root  level of the HD:
/Links/204983 SS Pkt Tees.tif

On the desktop in a folder:
/Users/carol/Desktop/Links/204983 SS Pkt Tees.tif

On a removable USB drive, a few folders in:
/Volumes/USB_External/Archives/2s/204983/Links/204983 SS Pkt Tees.tif

On a PC server:
/Volumes/Shared Folder/ClientFolder/AdDate/Page7/Links/204983 SS Pkt Tees.tif

I also noticed that in the help files, the PC example used the backslashes as separators, and the Mac example used colons. I tried swapping out the colons, but no joy. I tried saving the text file and the ID file in the same folder as the links folder, but the only thing that worked was to have the links all out in the same level as the ID and text, rather than being in a links folder. This obviously won't be good for me if I can't get Data Merge to work by pulling images from various folders. Any thoughts?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

Can you give the external drive a name? I don't know if that would help. It may also matter which USB port it plugs into.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

The name of the drive is actually the name of the company I work for, but I changed it for the forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

I'm about out of ideas. As I mentioned earlier, I'm a PC guy. I do know that 10.5 was flaky about recognizing usb drives. My daughter has an old G4 MacBook Pro that got upgraded to Leopard by Apple when they replaced a bad hard drive. It never read a flash drive again, and searching Google revealed this to be a pretty common problem. Not sure about the external hard drive she uses for backup.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

Wow, I'm a little bit late to the party, but it looks to me like we're missing some information here.

What's the exact path you are using in the spreadsheet?

On a Mac, there are (at least) 2 kinds of paths: the colon path and the unix (slashes) path. They are not the same. InDesign wants the colon path in the Spreadsheet according to the documentation, but appears to be giving you the unix path, and maybe that sometimes works.

Generally speaking they are quite similar. The colon path starts with the name of the drive and then directory names with sepeators. The unix path does not.

So, for your USB drive, the colon path should be: "USB_External:Archives:2s:204983:Links:204983 SS Pkt Tees.tif".

Please note that for the desktop folder, etc, the colon path is different -- it needs your hard drive name in it. Stuff like: "Macintosh HD:Users:carol:Desktop:Links:204983 SS Pkt Tees.tif"

At this point, I speculate that unix paths work fine when they can be converted to colon paths by prefixing "Macintosh HD:" and changing the slashes to colons. But that's not how it works for external volumes.

I sincerely doubt that spaces in the filename are the problem, but that's easy enough to test.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2011 Mar 30, 2011

Copy link to clipboard

Copied

Hi, Michael. Did my suggestion work?    


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 30, 2011 Mar 30, 2011

Copy link to clipboard

Copied

John Hawkinson wrote:

What's the exact path you are using in the spreadsheet?

Sorry, but I didn't see your reply until just now. I haven't checked the forum for a while. The paths that I copied from the ID links manager were pasted directly into the spreadsheet. I tried with the slashes and by using find/change to convert the slashes to colons, but neither worked. I work the night shift, so I'll try your suggestion tonight, and maybe be able to post back tomorrow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2011 Mar 30, 2011

Copy link to clipboard

Copied

Oh right, two addenda:

1) I guess the preferred term is POSIX Path, not "unix path." Sorry about that.

2) You should be able to work around this problem with a symbolic link. But try my solution first...symlinks are kind of confusing and you'll need to create them by hand in the Terminal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

Two things to possibly consider:

– spaces in filename. Can be problematic with csv files

– file system of the hard drive. Possible issue if accessing NTFS drive? NTFS3G may help

Does it work with USB drive connected to your computer? (beware potential for data loss with cross-platform drives)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2011 Apr 29, 2011

Copy link to clipboard

Copied

Hi Michael.

I am having this issue also.

I work at a corporation that houses all of our assets on our "Creative" server. (so, local paths are out of the question as this workflow needs to be available to any workstation).

I have found that images will only import IF the .csv file resides in the same folder as the images. Of course, we have the images spread across many folders, so this quickly breaks down. The InDesign file, itself, does not seem to matter where it resides.

It seems that the only solution will be to create a separate folder holding all of the images. This will necessitate having a duplicate set of images on our server which, in a corporate setting, is a horrible solution. There should only be one version of each image.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2011 Apr 29, 2011

Copy link to clipboard

Copied

This is totally off the wall, but what happens if you put a folder with aliases to the real images in the same folder with the .csv?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2011 Apr 29, 2011

Copy link to clipboard

Copied

That is actually worth a shot. Very good. Thanks Peter. I will let you know what happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines