Extra nonbreaking space on index cross references

Advisor ,
Jun 03, 2022 Jun 03, 2022

Copy link to clipboard

Copied

I do a lot of long documents, but they usually come with someone else's index. This one is an index generated from index codes that came from a Word file. In general, it's pretty good. There's a problem with getting italics into the index; I've read about that and I will come up with some kind of GREP solution. What I haven't been able to find anything about is the extra, nonbreaking space that seems to be baked in to cross references. Wherever the index code calls for a "See some subject", the generated index seems to contain a nonbreaking space followed by a normal space and then the subject. I've checked the index entries; there are no NB spaces in them (not sure if it's possible to include them, but either way, they're not there). In the "Generate Index" dialog, there doesn't seem to be a setting for "Throw in an extra no-break space just to confuse people." I tried using a custom cross reference (I used the word "Sey" instead of "See", but it just ignores me and uses See with the extra space when I generate a new index.

 

Yes, I can just search and delete the NB space, but why is it there in the first place?

TOPICS
Type

Views

37

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 03, 2022 Jun 03, 2022

Copy link to clipboard

Copied

New information: Simply selecting the first text frame of the index and Generating a new index doesn't actually replace the index (despite the "The index has been replaced successfully" dialog that requires an OK). In order to get a new index, you have to delete the text of the old one (leaving the frame keeps the index settings). So I can change the cross reference format (from See to See also or to something custom like "Sey", which I know is not a word), but no matter what the cross reference is, there's still this extra nonbreaking space that I'm sure I did not ask for.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 11, 2022 Jun 11, 2022

Copy link to clipboard

Copied

LATEST

Really? No one else is experiencing this problem? I see detailed instructions for index cross references at https://helpx.adobe.com/in/indesign/using/creating-index.html, but nowhere in those instructions does it mention that the See and See also cross reference types include a no-break space. There must be a way to edit these cross reference types.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines