• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

How do I turn off snapping to some sort of invisible grid in InDesign?

Community Beginner ,
Aug 27, 2012 Aug 27, 2012

Copy link to clipboard

Copied

In the last few upgrades of Indesign something has stumped me. When I move or scale objects there is snapping to some sort of invisible grid. This happens when I move or scale something with my mouse but not when I move something with the the up and down arrow keys (I set the keyboard increments to a very small setting and that works). I've tried troubleshooting this problem by playing with the settings for guides and grids under the "view" menu, changing preferences for units and increments and guides and pasteboards, anything I can think of. Nothing turns this snapping off and it is impossible to do percision alignment when scaling because I can't scale with the up and down arrow keys, only the mouse and other input devices. I have been using InDesign for a long while so I am a relatively advaced user but I haven't been able to figure this one out.

TOPICS
How to

Views

100.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Aug 27, 2012 Aug 27, 2012

Sorry, I totally missed that part of your answer.

Yes, if you have selected pixel as your unit of measurement, objects will snap to the pixel grid. It is entirely possible to have objects be placed outside of this grid, but when moving them around they will snap to the grid.

How did you go about changing the units of measurement for the document? If you aren't you should try (with rulers on) right clicking on the box in the top left hand corner where the rulers meet and selecting a different unit

...

Votes

Translate

Translate
New Here ,
May 08, 2019 May 08, 2019

Copy link to clipboard

Copied

OMG THANK YOU!!!!! Turning the doc from pixels to picas worked for me! This was so frustrating! >.<

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2023 Jun 02, 2023

Copy link to clipboard

Copied

Hi ALec - your answer really helped me too! Thank you! Was struggling to get rid of the snapping and it was so frustrating - Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2015 Nov 23, 2015

Copy link to clipboard

Copied

Also one thing I just realized is that you have to change both the horizontal and vertical axis increments. I learned this trick where you right click on ruler and can change increments in illustrator, indesign, and photoshop without going to preferences. But yeah, changing from pixels to inches solved it for me also. thanks


matt

Screen Shot 2015-11-23 at 1.59.31 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2018 Mar 25, 2018

Copy link to clipboard

Copied

I read through this thread and tried everything with no success... so I took a deep dive into the InDesign menu and eventually found a solution to this issue:

Edit-> Preferences -> Units & Increments

Then play around with the settings under Keyboard.  Setting everything to 1 or 0p1 worked for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2022 Oct 30, 2022

Copy link to clipboard

Copied

It was driving me crazy too. I couldn't get the pen tool to work the same way it does in Illustrator and Photoshop. Go to View>Grids and Guides and turn off any snap to in there. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2023 Mar 20, 2023

Copy link to clipboard

Copied

I had the same problem, solved by changing the increment

Screenshot 2023-03-20 at 15.50.56.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

Can someone remove this thread is ffrom 2012 WTH!!!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

Every post here is dated and it takes little effort to look at a thread, recent posts and versions mentioned to realize it may not be relevant to a current-day question. But there's not much reason to purge threads just because they're old.

 

I am much more irritated by the terabytes of info out there, mostly in individual blogs and sites where there's no excuse for it, that is undated. It's maddening to read whole how-to and instructional articles that turn out to have less to do with current systems, software and sites than one on how to do spell-checking in WordPerfect Release 4.

 

(This outdated garbage mode is endemic in e-book, e-publishing, EPUB and Kindle, wasting huge amounts of time and effort by new and novice users who don't know better until hours have been wasted trying to get a decade-old method to work.)

 

Sorry you wasted a whole minute on this. 🙂


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 14, 2023 Sep 14, 2023

Copy link to clipboard

Copied

This outdated garbage saved my day 🙂

These little quirks of InDesign/Adobe really do my head in.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

I am thankful for this 12 year-old thread. It just helped me solve my current day problem! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2024 Jun 14, 2024

Copy link to clipboard

Copied

LATEST

This is what worked for me.
Go to Preferences> Units and increments> 
Under Ruler Units, change Horizontal: and Vertical: from pixels to something else, like inches for instance.
Hope this helps.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines