Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How to align TOC entry name after numerical section number

Explorer ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Is there a way to right-align a first set of numbers (like a chapter number) in a TOC while having the chapter (area) title left align, then have the page #'s right align? As you can see in the screenshot, the location numbers are left aligned. they should be right-aligned. There are over 100 entries, so this needs to be automatic to all of the #'s look right-aligned tabular.

In the book's text, there's a paragraph style with an autogenerated numbered list then the location name, so I was hoping that'd help. I tried setting the TOC entry style to tabular under OpenType but the setting doesn't do anything when there's no leading zero to fix tabular #'s.

Attached is the look I need from another book I have. I'm trying to replicate the TOC look. We don't want periods after the area number (so align on period doesn't work in this case).

The area numbers are autogenerated from the technique in this post in the paragraph style for the area title:

https://creativepro.com/setting-up-numbered-lists-that-jump-frames-in-cs3/

 

I found this posting:

https://community.adobe.com/t5/indesign/how-to-align-toc-text-after-section-number/td-p/9955385

But the tabular figures option in OpenType didn't do anything, as there's no leading 0. This is especially true since there are 100+ areas. Adding the leading 0 to make tabular look correct makes the TOC and area #'s in the book look really weird.

Thanks!!

TOPICS
How to

Views

207

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Mar 20, 2021 Mar 20, 2021
See at the bottom of the TOC Options It says - turn off Numbered Paragraphs.  Do this - and then add the numbering to your TOC Paragraph Style    

Likes

Translate

Translate
Adobe Community Professional , Mar 20, 2021 Mar 20, 2021
(Sorry for the German UI)  

Likes

Translate

Translate
Explorer ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

The look I need:

 

IMG_3668.JPG

 

The look I have:

 

Screen Shot 2021-03-19 at 6.24.39 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Learn how to right align numbered lists so the numbers align on the period (or decimal point).Did I help you? Please DONATE via PayPal: http://tinyurl.com/th...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

I've got auto numbering active in the main part of the text using numbered lists that jump frames/threads. However, those numbers naturally come into the TOC.

When I add numbered lists to the TOC, then I end up with 2 numbers (as expected).

Screen Shot 2021-03-20 at 5.40.07 AM.png

(TOC pulls in the auto-generated #'s in the text, as expected, and adding a right-aligned numbered list to the TOC entry style creates the double entries, as expected)

 

How do I remove the auto-generated numbers from the area title that the TOC brings in so I can use the numbered list generated by the TOC entry style?

Screen Shot 2021-03-20 at 5.43.56 AM.png

(area #'s are autogenerated)

 

That's the crux - either remove the number from the text the TOC brings in and add in a right-aligned numbered list in the TOC style, or figure out how to right-align the auto-generated #s that come in from the page text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

See at the bottom of the TOC Options

It says - turn off Numbered Paragraphs. 

Do this - and then add the numbering to your TOC Paragraph Style

Capture.PNG

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

(Sorry for the German UI)

IHV_Nummerierte-Liste-ausschliessen.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Sweet, I think that'll work. Let me try it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

One sidenote.

I hope you have threaded text frames. If not and the text frames are not in the correct order you will run into problems like this:

IHV_Nummerierte-Liste-ausschliessen_beachte.png

in that case:

  • recreate your document -> Correct the placement of the elements.

or

  • create your toc, and instead of a renumbering in the TOC use a "Grep find and replace" to get your right-aligned numbering. (But that has to happen after every update of the TOC.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

LATEST

Hi @elellilrah 

was your question solved?

 

Or do you need further assistance?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines