How to keep the very long footnote on the same paragraph or page in InDesign?

Participant ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

I am having a problem with a very long footnote in abook with lots of footnotes. In this case the very long footnote number is attached to the chapter title, and nothing I do will keep some of the first paragraph of text on this page. I have checked all the obvious things and nothing works.Please see 2 attached png files. I finally did a workaround which involved making the footnote number that is at the end of the chapter title not a real footnote marker, and then putting a tiny footnote marker and coloring it K 0% near the end of the fourth line. The result of this is shown in the png attached called FootnoteIssue_p3.png. In this instance I put the footnote after the word "vel" near the end of line 4, tinted it to 0% and then kerned the space between it and the next word. But this seems to be a really complicated way to do things . . . . I'm wondering if this is a known issue?

 

<Title renamed by moderator>

TOPICS
Bug , Performance , Type

Views

275

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 13, 2022 Jul 13, 2022

I know, but copyfitting is the solution. Talk with the editor about the situation—adding or removing lines in the footnote will take care of the issue.

 

The other option is for you to play with the typography. Changing that footnote's typesize from 9 pt to 8.5 pts takes care of it as does changing the tracking to -10. And both allow you to keep the body copy on the baseline grid.

 

~Barb

 

copyfit.gif

Likes

Translate

Translate
Adobe Community Professional ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

  1. Allow to divide the footnote.
  2. In the paragraph style of the first text paragraph go to the keep options, activate keep with previous and keep some lines at the beginning.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

I've done all these things!  Nothing works!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 03, 2022 Jul 03, 2022

Copy link to clipboard

Copied

Thought you might like to see my screenshot: This shows the first paragraph of text (currently on the second page) selected, and its "keep options" showingabove. The footnotes are also set to allow splitting, with line at the satrt and 2 at the end. I'm thinking it might be a big.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Hi @Gopa C,

 

Thank you for sharing more info. Could you please share the InDesign file with me over a private message so that I can check and investigate at my end? Please share the version of InDesign and the operating system you're working on.

 

Does that happen with this specific file or all the files?

 

I will try my best to investigate.

 

Note: Please upload the file to a shared location such as CC or Dropbox as mentioned on this page:  Share your files in 6 simple steps. - Adobe Support Community - 12967491 

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Thanks for this. Here is the link: https://shared-assets.adobe.com/link/067736e4-b710-4a60-753d-829644be3c86

This issue happened in the file I was working on. I cut and pasted the text into a new file to try and see if it was a bug in the file, but the same thing happenend. In the file I have attached, I went one step further and created a brand new file and filled it with dummy text. Same problem! I am  on a Mac:Monterey 12.4 using Indesign CC17.0.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Thanks for sharing the file and trying to fix the issue, @Gopa C. You seem to be on the older version of InDesign, which might be causing issues for you. Would you mind updating InDesign to the current version (17.3) and see if that helps?

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Ok, I updated and the problem remains. Interstingly, I made a new document and it works correctly, but I still can't make my old file work, which is annoying bcasue it is on p 541 of a 700-page book and I don't want to have to reset the whole thing! Here is the file that works: https://shared-assets.adobe.com/link/1d9288b9-865c-41be-6f4e-02ff8dfcc404

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

That's good that's it not happening on the new document. Is it possible for you to copy the content of this file into a new file and let us know if that helps? Just want you to try so that I can continue to investigate on the file at my end.

 

I will try my best to help you.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Here's alink to my brand new file where this problem doesn't happen: https://shared-assets.adobe.com/link/1d9288b9-865c-41be-6f4e-02ff8dfcc404

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Hi @Gopa C:

 

In this case the very long footnote number is attached to the chapter title, and nothing I do will keep some of the first paragraph of text on this page.

This just seems to be a matter of Murphy's law, not a bug. The footnote fits perfectly on the page along with the title and the byline, so that's what is does. But with the baseline grid on, the paragraph following the byline doesn't fit, so InDesign moved it to the next page. 

 

If you add additional lines to this footnote it will break to the next page. And if you take the text off the baseline grid then the two lines from the previous page will come back up. It's just an unfortunate mathematical combination that isn't occuring in the other chapters. 

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

That's interesting! I added ten lines to the footnote, so then it moved some of the lines to the next page. Then, when I said "keep 14 lines at the end of the paragraph together", it did do what I needed and I got 5 lines of my first paragraph on the correct page. Unfortunately I can't add ten lines to the footnote in the actual document. I think the editor might have a fit. 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

I know, but copyfitting is the solution. Talk with the editor about the situation—adding or removing lines in the footnote will take care of the issue.

 

The other option is for you to play with the typography. Changing that footnote's typesize from 9 pt to 8.5 pts takes care of it as does changing the tracking to -10. And both allow you to keep the body copy on the baseline grid.

 

~Barb

 

copyfit.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

LATEST

Barb, Thanks for this. I had an interesting conversation with the editor and production manager (this is a BIG publisher.) Their comment (I thought this would amuse you): "We know you can make it work!" (i.e., no, we won't edit anything)  It was not possible to reduce the size of the footnotes as that would entail resetting 590 already completed pages, and -10 tracking is too much on my world. So what I did was to make the footnote number marker attached to the chapter title not an actual footnote marker. It'sjust a number not attached to anything. Then I inserted the footnote marker in line 4 of the first paragraph of text. I then tinted it to 0% and kerned up the type next to it so there wasn't a bit gap. Voilà! Then we made a note for the eventual epub processor to make sure to put the footnote attached to the right word. But for the print edition, as long as it looks fine, we are all happy! (I still consider it a bug!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines