Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


InDesign CS4 Package/Collect for Output - Missing links problem

New Here ,
Jan 12, 2009 Jan 12, 2009

Copy link to clipboard

Copied

I posted this on the PC forum by mistake so I apologise for doubling up on the message for those who have found the same message twice. As far as I know this is a Mac only problem!

Having recently freelanced in 3 design studios since the CS4 release, the Collect for Output problem within InDesign seems to be widespread. I've seen this happen on a range of machines from a G5's to laptops. All have been running the latest version of Leopard.

For some unknown reason any document created in older versions of Indesign that is opened in IndDesign CS4 does not collect all the linked files when it's packaged. All preflight checks are fine, the new live preflight feature shows green light, I even tried re linking all files to a new source folder containing all links and it still only randomly collects one third of the needed linked files with no obvious pattern emerging between the files omitted, i.e clipping paths, colour profiles, file types.

The worst thing is that it happens randomly on documents created fresh in InDesign CS4 as well so I'm having trouble trying to pinpoint where the problem stems from.

This is driving people crazy, and I can see that it's going to be a major pain for numerous design agencies. I hope Adobe sorts this out quick or it's back to CS3 for most of us who charge for our time. I guess I can always send Adobe the bill for the time spent manually collecting all files for a job!!

Please no obvious suggestions on preflight settings as it's happening to people with twenty plus experience in the business.

Thanks for reading the post.

Views

43.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2009 Feb 11, 2009

Copy link to clipboard

Copied

Ditto for me. Preflight tells me all my images are linked and embedded within the file I've created but numerous attempts at packaging any files refuses to take the linked images with it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2009 Feb 12, 2009

Copy link to clipboard

Copied

Well guys, this is no surprise, I knew there were more of you out there having the same problem!

Having never complained to Adobe before I decided to leave things until this forum filled up with similar comments about the linked files issue. I believe we have enough evidence here so it's time to report the bug. Does anyone know the best procedure for this? Has anyone sent a complaint to Adobe in the past?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2009 Feb 12, 2009

Copy link to clipboard

Copied

Just reported via the online bug report form. I'd like to thank all of you who have done this already. Now let's hope there's a quick response!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2009 Feb 12, 2009

Copy link to clipboard

Copied

p.s If anyone wants the link to the bug report submission form, look at Robert Levine's message above. It's been a while since I checked this forum, so thanks Bob for posting that link.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2009 Feb 16, 2009

Copy link to clipboard

Copied

I posted the bug as well. My math textbooks have hundreds upon hundreds of links to all sorts of fractions, expressions, graphs, equations, and diagrams. Manually having to relink every occurrence of every one is not an acceptable workaround.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 17, 2009 Feb 17, 2009

Copy link to clipboard

Copied

Is anyone using illegal characters in your link names? We have seen a problem with slashes in link file names becoming converted to colons (:), which can be a problem on certain servers. Packaging will stop once this illegal character is encountered. Is there anyone out there using dates in there link names, like filename_2\17.jpg? And if so, is this happening with links that are being packaged from a server? Please experiment by renaming any links that use a colon in their name for starters, and any illegal characters in general (ie., \/:*?<>|) ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 17, 2009 Feb 17, 2009

Copy link to clipboard

Copied

G'day Matt,

If I can first ask, are you from Adobe?

It's possible that some of my file names , photos from photographers and also comp images from photo libraries have slashes etc. in them, but why wasn't this a previous issue in CS3 and prior to that.

My linked images don't come from a server as everything is off the one machine.

I'll have a look and try your recommendation if there is.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

I have just upgraded from CS2 to CS4 and I am also having this problem. Random links are packaged - and sometimes none at all, not even a links folder, which is when I first noticed this problem. Having just created over 100 pages of a magazine and packaged them all as I usually did in CS2 then deleted the original files so my hard disk is not jammed up with duplicate files, I am now realising my archive is likely to be incomplete - a SERIOUS problem!!! I will add my voice to the Adobe complaint..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

Not sure if this will help CS4 users, but I've always used a script to move files rather than Collect for Output mostly because it's faster. This script will copy (not move) all linked files into a chosen folder and update the links to the copied files:

http://www.zenodesign.com/scripts/CopyAllImages.zip

I would expect it to work with CS4, but I'm not sure about Leopard. It does not gather fonts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

Yup, from Adobe. We currently have a fix, but it is for the slash turning into a colon issue (which we think the problem is limited to). Please report back if there are any packaging issues with link lists that do not use slashes or colons in thier link names. Again, Packaging will halt if it encounters any link name with a slash. So, please speak up if anyone is having this problem with a link that does not include a slash (or colon) in one of thier link names. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

FWIW, the script I posted will copy and move files with a slash. I don't think OSX allows a file name to include a colonat least not from the finder or application save dialogs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

I'll likely get flamed for this but using slashes and other characters
that are not completely cross platform is bad practice anyway.

Bob

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 18, 2009 Feb 18, 2009

Copy link to clipboard

Copied

I'll bite. Why should I care about cross platform with my IDCS4 files, they are never used outside of a Mac environment and never will. It's not a point of concern and doesn't address the issue, which is, in previous version of ID it worked, come IDSC4 and it does and it doesn't.

Matt, thanks for your last reply. Of the files that didn't package from the native file, 1 has a _ in the name another has a /. I haven't looked at other files to see if they all collect properly, I do use / in file names at times eg. to shorten landscape to l/scape or similar, but never full colons.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2009 Feb 19, 2009

Copy link to clipboard

Copied

I just ran across this problem myself. After looking through this thread and my documents I see that some of my file names have either a _ / or ~ in the name. I didn't notice if those are the only ones that that didn't package or not since my document has 74 pages and 564 links in it.

If there's a fix please let's see it available ASAP.

Thanks,
David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2009 Feb 24, 2009

Copy link to clipboard

Copied

I am having the same problem; I have a catalog created in CS2 that I am updating for 2009 in CS4 and only one out of about 100 images was packaged. I checked the image file names and the vast majority of them were strictly alphanumerical, with no slashes, underscores, etc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 24, 2009 Feb 24, 2009

Copy link to clipboard

Copied

There's a new InDesign update to 6.01 now available through the Adobe Updater. You should see whether this fixes the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2009 Feb 27, 2009

Copy link to clipboard

Copied

Just encountered this problem in CS4 myself recently (last night) and am as bamboozled and befuddled as anyone else.

First of all it was on a Macbook Pro running Leopard connected to a Mac G5 server.
2. The missing links do appear to be random. Sometimes they were links located on the server and sometimes from the desktop. Naming conventions didn't "seem" to be the problem. They did all "seem" to be bitmap (1 bit files from Photoshop) .tif files though... Did anyone else find any similarities?
3. The new Adobe update to 6.0.1 did not fix the problem.
4. The script mentioned above (CopyAllImages)crashed.
5. The feature in the Links Pallete flyout menu "CopyLink(s) To..." seemed to find more links but still omitted a bunch.

Very strange...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2009 Feb 27, 2009

Copy link to clipboard

Copied

Oh, one more thing....
We also tried all these processes before and after rebuilding the file using the Export to IDML.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2009 Mar 08, 2009

Copy link to clipboard

Copied

Same problem here. Large catalog... the package feature only collected 299 links out of 2,500 or so.

I tried to select all the images in the Links Panel, and use the Copy Links To, but that too only copied over 299 images. I quickly glanced at the first and last few images of both sets of 299, and they were the same, although I can't say for sure if there were some differences deeper in the list.

---

If the problem were with a slash or colon halting the process, wouldn't the short list of links drop off at a certain letter (if sorted by filename)? meaning:

AAA.psd
AAA.jpg
AA.tif
AAA.psd
BBB.tif
BBB.psd
BBB.tif
CCC:CC.tif
(end of list)

On my list of links, it starts with numerals and goes up to "Yale Logo.eps".
Plus, I only use _ or - in my file names...

So for me, I don't think the problem is this illegal character issue.

---

I've been looking at the Links in Bridge, using the Filter Panel to see if I could spot any overwhelming similarities in my 299 images.... and I can't....

---

I tried only selecting 794 links, and using the Copy Links To feature, and it packaged more than before, with 388, but still way short.

---

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2009 Mar 09, 2009

Copy link to clipboard

Copied

One thing to note which may explain away a few of the "missing" links:
The links panel counts and lists each and every instance of the link when the disclosure triangle is twisted "open". It also lists the non-instance of the link - the title of the disclosure triangle cluster. So if you have 3 instances of the link placed and you have the triangle "open", it will count 4 links when it should really only be counting 1. This could potentially make you think quite few of your links were not packaged. The only way to get an accurate "listing" of links is to be absolutely sure ALL disclosure triangles are twisted shut.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2009 Mar 09, 2009

Copy link to clipboard

Copied

In our links, which are mathematical formulae, we frequently use "÷" "", as well as other characters like parentheses and brackets in our file names. Are these legal or illegal? Is there a list of what is and is not illegal for resolve this problem? As I have said, it is not uncommon for us to have over 500 links associated with a document; many of which are numbers and symbols. We also use colons in file names (for example, a ratio, like "1:2.eps"). Does the patch simply convert slashes to colons? If so, then will a file name like "1/2.eps" be converted to "1:2.eps" which could cause other problems by stepping on existing files? Can't the problem be fixed to be compatible with CS2/CS3? Frankly, I hesitate to trust a patch which changes the names of our links.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2009 Mar 09, 2009

Copy link to clipboard

Copied

How are you getting a colon into a file name? In OSX a file or folder name with a colon is illegal, the finder and save dialogs prevent you from entering one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2009 Mar 11, 2009

Copy link to clipboard

Copied

hi
I have got the same problem :-(. images and illustrations are missing in the collection. does anyone know a solution?
I am using CS4 with Mac OSX on 2x2 GHz Dual-Core intel Xeon.
please help me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2009 Mar 12, 2009

Copy link to clipboard

Copied

Same problem at our design studio in VA. ARGH! We design museum exhibits and I must say we really looked professional shipping off a packaged file with a link folder with randomly missing links. NO bad characters in the doc title.

So IS there a fix for this?!?

This kind of bug is MAJOR for us, I hope Adobe fixes this asap. It does it with FONTS too, by the way...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 12, 2009 Mar 12, 2009

Copy link to clipboard

Copied

For those that are having this problem, Adobe is actively looking at this issue. Can't get into the details, but removing slashes from your links file names should be the temporary fix. Please report back if you have other examples, but we think this problem is limited to the slash. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines