• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

InDesign features are all grayed out including QUIT. Have to Force Quit every time.

Community Beginner ,
Apr 17, 2023 Apr 17, 2023

Copy link to clipboard

Copied

Please help! I have the lastest InDesign version. Almost on every file that I open, all InDesign features are grayed-out including Quit. So I always need to Force Quit. When I reopen the same file, sometimes it works. I thought maybe becaue of Type 1 fonts. But some of the files don't have Type 1 fonts. I've tried re-installing ID, reinstalling the plug-ins, etc. I have 141 GB available. Please advise. Thanks!!!

TOPICS
Performance

Views

415

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 17, 2023 Apr 17, 2023

Copy link to clipboard

Copied

Try resetting your InDesign preferences and cache files.

To reset preferences:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works great but if it doesn’t you may have to manually delete them.

To do so: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

To trash cache files:

For Macintosh Users: The User Library folder in which InDesign’s cache files are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the “Caches” folder. Within the Caches folder find and delete the entire folder “Adobe InDesign”. I find that deleting the InDesign cache folder completely leads to a lasting change.

For Windows Users: On Windows 7 and above the caches files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#]\<Language>\Cache. For Windows Users: Follow the path to C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#]\en_US\Cache

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 17, 2023 Apr 17, 2023

Copy link to clipboard

Copied

Thank you so much, Bill, for your quick reply. I tried your suggestions. I had to save the Version 18 Preferences for now since I'm working on urgent files. So far, I only had the same problem with one file. I also got this error message which I started getting since this new ID version. I wonder if this is causing the issue. Anyway, I'll keep track if I continue having this problem and will try to delete the preferences again and maybe start from scratch during my downtime. Attached are the error messages that I get, please advise if I should disable the event handler if I get that message again, or how I can disable it if I don't get that message again and I need to disable it. Thanks again and I really appreciate your help. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2023 Apr 18, 2023

Copy link to clipboard

Copied

Good morning Bill,

I can't seem to work on any ID files anymore. When I open the file, all the InDesign features are grayed out. Please help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2023 Apr 18, 2023

Copy link to clipboard

Copied

Hi Bill,

I just tried opening a file again. This time it works for now. I'll monitor it today.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 25, 2023 Apr 25, 2023

Copy link to clipboard

Copied

LATEST

I deleted the preferences as suggested above and started from scratch, just kept my Scripts folder. So far, some InDesign files still open with all features grayed-out or won't open with that error message that a modal dialog or alert is still active. I would often Quit ID while I can, before opening a file to avoid the issue. Before I upgraded to this latest version, the last version of ID used to crash a lot. I sent that error report everytime it crashed. When I upgraded, ID hardly crashed anymore. But now, no feature works that I have to Force Quit instead. Any other suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines