InDesign files on external drive open as 'read-only'

Community Beginner ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Who can help me out on this? All of a sudden this morning all my InDesign files (on my external hard drive) open as 'read-only'. Can't work in them, can't save them. When I copy them to my local drive they are ok, but I loose all links to visuals, logo's etc. I cannot create a package from the document on the exteranl drive. Restoring all links of all my documents manually will take me weeks. Is there an other way to solve this?

Working on an iMac 27 late 2015, Monterey. External drive: G-technology. InDesign latest 17.2 version.

TOPICS
How to , Server developers

Views

170

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Wurde auf deiner externe Platte irgendwas geändert? Irgend ein Schutz aktiviert? Die Infos der Platte mal untersuchen, nicht dass sie gesperrt ist? Du könntest auch mal mittels Festplattendienstprogramm diese Platte auswählen und die "Erste Hilfe" im Menü oben auswählen, um eventuelle Fehler zu reparieren.

Ich würde ansonsten mich eher an einem Mac-Forum wenden...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Thanks. Checked the external drive (again), no problems found. 

My InDesign files (on the external drive) open as read-only'. But the same problem seems to appear in Illustrator: https://helpx.adobe.com/illustrator/kb/illustrator-support-networks-removable-media.html#sa_src=web-...

In Illustrator there is a solution in preference settings. That option seems to be missing in InDesign.

So I don't think it's a hardware problem, but something that has to be fixed in Adobe programming.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Ich öffne auch gelegentlich InDesign Dateien von einem Server (nicht direkt verknüpft, sondern als Nas)... Bei mir öffnen sich alle Dateien ganz normal ohne Schreibschutz. Deshalb ging ich von einem Hardware-Problem aus.

Ist dieses Problem von heute auf morgen passiert? Vielleicht mal testweise die vorletzte Indesign-Version installieren? Oder auf der aktuellen updaten (17.2.1!)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Und so wie ich es verstehe, hat diese Einstellung in Illustrator gar nichts mit den Zugriffsrechten meiner Dateien auf externe Medien zu tun...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

Thanks for your information. Problem solved with help from Adobe by phone. In System Preferences I re-activated access of Adobe apps/software to my extrenal drive. Don't know what caused the change in preferences, most important is I can get back to work.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

I have had this exact problem also - thank you for posting I have been stuck for days

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hello! Could you provide the steps you used in system preferences to re-activate access of Adobe Apps software with your EHD? I am having the same issue and am stuck. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

I'll give it a try as I was guided through the solution by phone and dont have a written transcript.

> Top left on your screen, click the Apple icon

> Select 'System Preferences'

> Select 'Safety and Privacy'

> Select 'Privacy' button on top

> Select 'Accessability' in the left list

> Unlock the lock at the bottom

> Select '+' bottom right list

> Add InDesign (search for your local harddrive, open 'Apps', open 'Adobe InDesign 2022', select 'Adobe InDesign'

> Check if the box InDesign in the list now is active and lock the lock at the bottom.

Now do the same (or check if InDesign is already active) in the left list in the folder 'Full disk accessibility' and the folder 'Documents and folders' (or maybe it's called 'Files and folders').

Success!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hi all - I was able to speak with Adobe Support for the step by step of this:

 

  1. First go to System Preferences -> Security & Privacy -> Accessibility -> Unlock in lower left -> Add desired Adobe Softwares -> Make sure they are checked
  2. Next, scroll in left column to "Full Disk Access" -> Add desired Adobe Softwares -> Make sure they are checked
  3. Lock in the lower left
  4. If open, softwares will need to be quit and restarted for changes to take affect. 

 

Best of luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

LATEST

Run into the same problem today! Thank you for sharing the solution. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines