• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Insane font problem

Explorer ,
Apr 21, 2024 Apr 21, 2024

Copy link to clipboard

Copied

Working on a large InDesign document (about 200 pages). Default font was Open Sans Light (Google font). 

 

Suddenly every style including the Basic Paragraph has changed to Zapf Dingbats. Not the definition, that's still correct for each style. The problem is the application of any style. The style sheet shows Open Sans or other fonts depending on which style was selected, but no matter which style is applied, it immediately switches the text in that paragraph to Zapf Dingbats. If I select a paragraph and click a new style, even though that style has it's own font definition, I get Zapf Dingbats. 

 

This is insane and it's driving me insane. How can I fix this?

TOPICS
Bug

Views

177

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Apr 22, 2024 Apr 22, 2024

For which the simple check is to put the text cursor on any affected text, and check the Character Styles list to see if ID thinks one is applied. I'd lean towards this: it would not be hard at all to select all text and hit a Character Style, resulting in instant chaos from seemingly nothing.

Votes

Translate

Translate
Community Expert , Apr 22, 2024 Apr 22, 2024

And there's another easy answer for that. 🙂

 

ID has the subtle feature of allowing you to set almost anything as a default by simply selecting it when no object is selected — that is, if you have a document open and no object in the document selected, clicking Red as the color will make red the default color for everything created. Same for things like stroke width, and all styles. It sounds as if at some point, while nothing was selected, you clicked the Bullets style.

 

So with absolutely no

...

Votes

Translate

Translate
Community Expert ,
Apr 21, 2024 Apr 21, 2024

Copy link to clipboard

Copied

It sounds like either a corrupt document or a very low level font switch.

 

Does this happen with any other document? Any new document? If so, you might have corrupted preferences. Do search for how to reset ID prefs for your platform and version.

 

Otherwise, go to Basic Paragraph and set the font correctly (to match your basic 'body' style, I would assume). Then work through all the fonts by finding the most basic/parent font ("Based on") for each hierarchy, and correcting it, up through the styles if necessary.

 

BTW, Basic Paragraph should never be used in documents, either by itself or as a parent/starting style. Create your own base "Body" style that's based-on nothing.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 21, 2024 Apr 21, 2024

Copy link to clipboard

Copied

https://creativepro.com/beware-basic-styles/

Just a sidenote to James' excellent advice.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 21, 2024 Apr 21, 2024

Copy link to clipboard

Copied

Hard to know - could be a Character Style - any of this going on?
Have you got any screenshots of your styles (paragraph and character)?

A sample document for us to investigate?

 

What happens if you go to Find Replace Fonts 

can you tick the option to redefine style when changing fonts - so you can select Zapf Dingbats in the list and replace it with Open Sans and select the option to update the style - would force the change in the style too.

 

Very hard to troubleshoot what's going on.

 

----

On a side note - the font could be corrupt. Try uninstall the font and reinstall it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

As James Gifford has suggested it could be a corrupted file. One process that can remove some corruption from a file is to export the file as an IDML (File>Export>InDesign Markup (IDML)). After doing so try opening that file in your current version of InDesign and see if the font problem has been fixed. I would actually suggest using an earlier version of the file (before the font change) for this test if you have one. Using the current version of the file might fix the file but the fonts may not reset themselves automatically since the action of changing them may have already become part of the saved file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

It looks that you have a character style set with Zapf Dingbats that is applied by default on all your text.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

For which the simple check is to put the text cursor on any affected text, and check the Character Styles list to see if ID thinks one is applied. I'd lean towards this: it would not be hard at all to select all text and hit a Character Style, resulting in instant chaos from seemingly nothing.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

I really appreciate all the support that I got for this issue. I hadn't thought of the character style and that was indeed the problem. My issue now is that it seems that the "Bullet" style (which uses Zapf Dingbats) is selected by default for all text blocks I create. How can I switch that to "None"?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

And there's another easy answer for that. 🙂

 

ID has the subtle feature of allowing you to set almost anything as a default by simply selecting it when no object is selected — that is, if you have a document open and no object in the document selected, clicking Red as the color will make red the default color for everything created. Same for things like stroke width, and all styles. It sounds as if at some point, while nothing was selected, you clicked the Bullets style.

 

So with absolutely nothing selected in the document... set the font you want as the default for all newly created [font] objects, and very likely, change the Character Style from a selection of 'Bullets' to '[None].' Very useful trick... and annoyng gremlin if you don't know it exists.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

Hi @Adwiz , Also, make sure you add the dingbat you want to use as the bullet (click the Add... button), then if you want to add extra styling e.g., color or size choose a Character Style. If all you want is a Zapf Dingbat as the bullet, you might not need to choose a Character Style from the Bullets and Numbering panel—just Add the dingbat.

 

All of the paragraph’s text should have None set as its Character Style. In this example I’m defining the Zapf font family via Add..., and only the red color via my Bullet Character Style:

 

Screen Shot 48.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 22, 2024 Apr 22, 2024

Copy link to clipboard

Copied

LATEST

Thanks for all the detail. I had set up the nested styles properly, indeed exactly as you showed in your screenshots. But somehow it had set the Bullet style to apply everywhere. I did the trick of making sure nothing was selected and then selecting Basic Text from the Paragraph Styles menu and None from the Character Styles menu and it seems to have fixed the problem. Not sure how it got set that way as the file was working fine for weeks but it's now resolved. Sigh of relief. Thanks again for chiming in with such great responses.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines