Missing font window every time I use a fontbase font, Indesign 2019

New Here ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

I am using fontbase to manage my fonts from multiple sources. It's much easier to use than Adobe's font manager, and also includes Google fonts and fonts I download from other sites nicely. It has a feature which automatically updates fonts in Adobe programs, when I activate a font in Fontbase.

 

However, literally every single time that I change a font in 'character styles' from a Fontbase activated font, I get the popup saying that the Font is missing, and I need to install it. I then have to close it to do anything. Even pops up and takes priority if I switch windows.

I can't begin to describe how intrusive and slowing this is. Approximately doubles the time it takes to try out different fonts in a document, not to mention the irritation and fatigue. And the fact that the font is, in fact, not missing! Feels like Adobe's way of forcing you to use their Adobe fonts only.

 

Admittedly, it is popping up to show me that bold and italic versions of the font are missing. However, it's still incredibly time consuming to close every time, and not information I necessarily need.

I scoured the forums here for an answer. I tried a script to disable it. I completely disabled adobe fonts within creative cloud. I even removed the font dialogue window extension from the Adobe Indesign folder. No luck.

 

For reference I am using Indesign v. 14 (2019) on Mac OS X 10.12.6. And no, updating to a newer OS is unfortunately not an option right now. I'm not interested in justification as to why Adobe does this, and I am near certain a suggestion to Adobe will be either ignored or not done anytime soon.

I hope anyone has a solution to this. I'd love you forever. Thanks.

TOPICS
Bug , Import and export , Sync and storage , Type

Views

25

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

LATEST

I don't know what the answer is here - as I am not a fontbase user - however, reading their information on their website

https://fontba.se/learn

 

It seems like the fonts do deactivate once you close Fontbase - and one of their own solutions is to try relaunching the fonts or the application.

 

I don't think this is an Adobe thing - it sounds more like a Fontbase thing - but I could be completely wrong.

 

---

Some fixes you might want to try - from my collection of standard fixes

 

---

Try resetting your preferences:
The easiest way to reset everything is to delete the InDesign preferences: as soon as InDesign starts to boot hold down Shift, Alt, Ctrl (and Apple/Cmd if working on a Macintosh). A dialog will appear asking to delete the InDesign Preferences, select 'Yes' on this dialog.
Further info and instructions here if needed:
https://helpx.adobe.com/in/indesign/kb/indesign-preferences-support-file-locations.html

 

---

Reinstalling rarely fixes everything - you can do a complete reinstall using the
Creative Cloud Cleaner Tool https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

 

---

 

If a document is not behaving well then try 

File>Export 

Choose IDML

Open the IDML in InDesign
Save the file as a new InDesign file with a new name
See if the issue persists.

 

---

If you think that it's an Adobe Bug you can report bugs or make a feature request
https://www.adobe.com/products/wishform.html

 

 

------------------------------------------------------------------

I'd sincerely try to get in touch with Fontbase support.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines