• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Object alt text

Community Beginner ,
Feb 06, 2019 Feb 06, 2019

Copy link to clipboard

Copied

I'm working in CC 2019 and I'm having trouble getting alt text applied to an object to carry over to a PDF. The object is a graphic created in Indesign; I've used Object Export Options to apply alt text to the graphic, but when I export the document, the alt text is not carrying over, and the graphic is not being tagged as a figure. (Create Tagged PDF is checked in my export options, and other items such as text and images placed in InDesign are being tagged appropriately.) Am I missing a step somewhere? I can't quite figure out what I'm doing wrong.

Views

2.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 08, 2019 Feb 08, 2019

And when you export the PDF from InDesign, you're selecting PDF Interactive, and checking the options:

  • Create Tagged PDF (lower right corner of the dialogue)
  • Use Structure for Tab Order

Unfortunately, I think the bug is in InDesign or its PDF Export utility.

The good news is that you're doing things right!

The easiest thing to do at this time is to:

  • Add Alt-text to all your graphics in InDesign (hopefully most will make it through to the PDF)
  • Export the PDF
  • Add any missing Alt-Text in Acrobat Pro.
  • If the
...

Likes

Translate

Translate
Community Expert ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

To help diagnose what's going wrong, let's review the steps to take:

  1. Create the graphic object in InDesign.
  2. Right-click/Opt-click on the object and select Object Export Options. (Or choose Object menu / Object Export Options)
  3. From the first tab (Alt-Text), select Custom from the Alt-Text Source. Type your Alt-text in the field box.
  4. Exit the dialogue.
  5. Save the INDD file.
  6. Export the PDF: File / Export / PDF Interactive and check the options for Create Tagged PDF and Use Structure for Tab Order.
  7. View the PDF in Acrobat Pro.

Let us know if this method works.

-- Bevi

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Followed those steps exactly, and the graphic still isn't showing a figure tag or alt text in the PDF.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Let's check another item:

When you select the graphic, are you using the Selection Tool (black arrow) and selecting the frame around the graphic (the blue frame)? This is what should "hold" the Alt-Text.

Sometimes people select the actual graphic itself with the Direct Selection Tool (white arrow), which often doesn't tag correctly in the PDF.

One more items: Which version of InDesign are you using?

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Yep, I double checked to make sure I'm using the Selection Tool and selecting the frame. The alt-text and tag still isn't showing up in the PDF.

I'm using CC 2019.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

OK, please check one more item:

When you select the object's frame and right-click/opt-click for Object Export Options, is there anything in the MIDDLE tab "Tagged PDF"?

If so, delete any text in the Actual Text Source (it should be empty) and revert that tab's settings to Apply Tag: From Structure.

Note that Alt-Text is not the same as Actual Text.

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

In the Tagged PDF tab, both Apply Tag and Actual Text Source are set to From Structure, and the text box says "[Selection has content with no associated structure.]"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

That's correct.

I think there might be a bug in either your file or in InDesign.

There was a known bug for a couple of versions that prevented some (but not all) graphics in an InDesign layout file from having the Alt-text automatically carried over into the PDF. (It actually was there, but incorrectly burried in a nested tag structure in such a way that the Acrobat checker and screen readers couldn't find it.)

But we hadn't see that bug since CC:2018.1 a year ago.

One last test to see where the bug lies, in your file or in InDesign:

  1. Start a brand new document, create a shape, and add dummy Alt-text to it.
  2. Export to PDF and see if that is OK.

If it is OK, take the same document and copy/paste your graphic from the original file into to. Add the Alt-text, export to PDF, and check it.

Let me know your results.

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

On your version of InDesign, look deeper.

Version 14.0.1 is the latest version (which is CC:2019 with a little updater).

Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Started a new document with a new graphic, and Alt-text still didn't work.

I'm on version 14.0. (It looks like Version 14.0.1 isn't available for my organization's enterprise account; my manager thinks it's possible our IT department hasn't released it to us yet.)

I'll keep an eye out and update when I can.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

And when you export the PDF from InDesign, you're selecting PDF Interactive, and checking the options:

  • Create Tagged PDF (lower right corner of the dialogue)
  • Use Structure for Tab Order

Unfortunately, I think the bug is in InDesign or its PDF Export utility.

The good news is that you're doing things right!

The easiest thing to do at this time is to:

  • Add Alt-text to all your graphics in InDesign (hopefully most will make it through to the PDF)
  • Export the PDF
  • Add any missing Alt-Text in Acrobat Pro.
  • If the graphic did at least get a <Figure> tag, then you can easily select the <Figure> tag from the tag tree, right-click/opt-click / Properties and add the Alt-text there.  If there's more than one that's missing the Alt-text, then it might be quicker to run the Set Alt Text utility from the Accessibility Tool Panel in Acrobat.  It will cycle you through all of the graphics in the PDF where you can use the back/forth arrows to hop from figure to figure.
  • If you don't see the <Figure> tag at all, then use the Reading Order Panel from the Oder panel (left side of Acrobat, looks like a blue Z icon, then Options and Show Reading Order Panel). Use the crosshairs cursor to marquee-select the missing graphic, and then click the button for Figure. it will add it to the tag tree.
    • Drag the new <Figure> tag into the correct position in the tag tree (this controls the reading order).
    • Right-click/Opt-click on the <Figure> tag, Properties, and write the Alt-text.
Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

You're welcome! Glad to help.

Question: (yes, another one!) Did you happen to use the Articles panel for this project?

If so, was the graphic added to the Articles panel?

Two possible outcomes:

  1. Any object (text or graphic) left out of the Articles panel won't be tagged, so it won't have Alt-text.
  2. A bug that was fixed in 13.1 was supposed to correct that. See Alternate text added to graphic missing in exported PDF when using Articles panel. – Adobe InDesign ... from a year ago.
Bevi Chagnon | PubCom | Designer & Technologist for Accessible Documents
| Books & Classes | Accessible InDesign | Accessible PDFs | Accessible MS Office |

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2019 Feb 08, 2019

Copy link to clipboard

Copied

Yes, I was using the Articles panel, and the graphic was added to the Articles panel.

(In the test document with the dummy graphic and alt-text, I did not use the Articles panel.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

Hi

I am far from being a specialist in PDF accessibility.

However, I recall reading threads about placed PDF, or AI not being correctly tagged.

I suppose this is the same thing here...

I am not aware of any other solution than tagging the object in Acrobat itself.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

LATEST

Hi,

I had the same issue and found that the ALT text applied to images other than JPEG, PNG doesnot appear in PDF. So convert all your shapes, images, graphics to JPEG/PNG, add ALT text and export to pdf. This should solver the issue.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines