Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Placeholder error message with InDesign Data Merge

New Here ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

 

We use data merge frequently, using the same Excel files and InDesign templates over and over. Over the past week or so, our merges have stopped working, and we get this attached error message. We have removed any placeholders in both InDesign and Excel that are not being used. We have tried creating various .csv files from Excel. What could we be doing wrong, our workflow has not changed. Thank you!

 

Screen Shot 2020-01-27 at 10.45.39 AM.png

TOPICS
Bug

Views

3.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Participant , Jan 28, 2020 Jan 28, 2020
Phew...I just looked up the reported bug i mentioned. The solution was to CREATE A NEW Indesign document - not to save the old one with another name (sorry for wrong info). You still may copy over layout and stuff.Then setup the merge fields again. The unconfirmed guess was that the indesign document gathers data scrap as time goes by and creating it new should solve it. Another solution:If you are on mac we recommend give MyDataMerge a try (https://mydatamerge.com). Its new, macOS only, its eas...

Likes

Translate

Translate
Participant , Jan 28, 2020 Jan 28, 2020
Glad you solved it that way. Otherwise i would have been run out of ideas. Would you accept it as correct answer so others could profit of it as well?

Likes

Translate

Translate
Participant ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

Please check the following scenarios:

 

Did you (mistakingly or not) change a data column title? Then the data merge panel will tell you which placeholder is not connected properly.

 

Did you add a new data column in excel with a space? Check the csv file, first line if there is an additional comma at the end. If so clean up that column in excel and export csv again.

 

Edit: There have been bugs with older InDesign versions and data merge. Try to update if there's an update available.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

We have checked the column headers to make sure they are correct. The panel has not provided any info on which specific placeholder is a problem.

 

We have even gone back to previous Excel/InDesign file combinations that did work. They no longer work.

 

We tried using both InDesign 14.0.3 and 15.0.1. I will try loading anyupdates.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

Please try to remove all data except line 1 (header) and 2 (first record). Export csv again. Does the error appear again?

 

Additionally. There was a reported bug that could be solved by removing the data source and link it once again (I know that's work but give it a try) and then save a new indesign file(other name).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

I created a new Excel .csv file. It had one column header and one field of data. InDesign gave me the same error message. This was using InDesign 15.0.01. I tried your other suggestion, with the same error message result. I should mention we are working on Macs, using system 10.14.6.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

Phew...

I just looked up the reported bug i mentioned. The solution was to CREATE A NEW Indesign document - not to save the old one with another name (sorry for wrong info). You still may copy over layout and stuff.

Then setup the merge fields again. The unconfirmed guess was that the indesign document gathers data scrap as time goes by and creating it new should solve it.

 

Another solution:

If you are on mac we recommend give MyDataMerge a try (https://mydatamerge.com). Its new, macOS only, its easy and it extends merge functionality a lot. We only use that for data merge. Saved so much time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

Creating a new InDesign file and copying over the contents of the old seems to work. Not an ideal solution given the number of files we have, but thank you for the idea!

 

I looked at MyDataMerge. Another good option that I hope will prevent this from happening again. I appreciate your help in resolving this, and I pray Adobe is reading this as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

Glad you solved it that way. Otherwise i would have been run out of ideas. 🙂

Would you accept it as correct answer so others could profit of it as well?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

Data merge panel will (sort of) identify which data placeholders didn't work - the ones used have a page number - if the data item has no page number and you can see that it is in your document then that is a faulty placeholder - relink it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2021 Aug 22, 2021

Copy link to clipboard

Copied

What worked for me was to go to the menu "Window" and then "Interactive" - in the dropdown there is a choice for "Hyperlinks" - select this and a panel will pop up that shows all the hyperlinks in the doc. I had some ghost hyperlinks that were copying over with the formatting when I created a new doc. I deleted all the hyperlinks and tried the data merge again and it worked. Good luck to all!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

LATEST

I faced same error. So I try with very new Indesign file then problem solved. Dont use eye dropper tool even. All need to start from the bigining.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines