• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problem running SDK sample plugin

Explorer ,
Apr 20, 2023 Apr 20, 2023

Copy link to clipboard

Copied

Hello All,

 

I am very new to making plugin scriptable, to start with I tried building pluign give in sample code of SDK folder, I built plugin BasicME and tried to execute it using scripts given in sample sources.

 

but I am getting following error: (attached image)

Error Number : 44

Error String: Object does not support the property or method 'basicme'

 

I built this plugin from samples give in CC 2022 SDK folder and trying to run it in InDesign CC 2022. am I missing something? 

 

Any help is higly appreciated, Thanks in advance!!

TOPICS
Scripting , SDK

Views

517

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Apr 21, 2023 Apr 21, 2023

One thing that I noticied is that this plugin is InDesign server only. Check the PluginVersion defintion in the fr file. It has the following

{ kInDesignServerProduct}

However, it should be

{ kInDesignProduct, kInDesignServerProduct}

for it to load on both the desktop version as well as the Server version of InDesign

-Manan

Votes

Translate

Translate
Community Expert , Apr 21, 2023 Apr 21, 2023

Another change that you would have to make to load this on desktop version of InDesign is

Change

 

kCS5ScriptVersion, kCoreScriptManagerBoss, kInDesignServerProductFS, k_Wild,

 

To

 

kCS5ScriptVersion, kCoreScriptManagerBoss, kWildFS, k_Wild,

 

This needs to be done inside the fr file within the VersionedScriptElementInfo resource definition.

-Manan

 

Votes

Translate

Translate
Community Expert ,
Apr 21, 2023 Apr 21, 2023

Copy link to clipboard

Copied

One thing that I noticied is that this plugin is InDesign server only. Check the PluginVersion defintion in the fr file. It has the following

{ kInDesignServerProduct}

However, it should be

{ kInDesignProduct, kInDesignServerProduct}

for it to load on both the desktop version as well as the Server version of InDesign

-Manan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 21, 2023 Apr 21, 2023

Copy link to clipboard

Copied

Another change that you would have to make to load this on desktop version of InDesign is

Change

 

kCS5ScriptVersion, kCoreScriptManagerBoss, kInDesignServerProductFS, k_Wild,

 

To

 

kCS5ScriptVersion, kCoreScriptManagerBoss, kWildFS, k_Wild,

 

This needs to be done inside the fr file within the VersionedScriptElementInfo resource definition.

-Manan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 09, 2023 May 09, 2023

Copy link to clipboard

Copied

Thanks Manan,

 

This worked perfectly for InDesign Desktop but now I am trying same with InDesign Server and its giving me following error

I am running server using following command:

C:\Program Files\Adobe\Adobe InDesign Server 2022>indesignserver -port 12345

 

Trying to execute script like :

Adobe InDesign Server 2022>sampleclient -host localhost:12345  C:\Users\Administrator\Desktop\invertdoc.jsx

 

ERROR:

Error number: 55

Object does not support the property or method 'basicme'

 

Why its giving this error when its working perfectly in InDesign Desktop

 

Thanks!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 09, 2023 May 09, 2023

Copy link to clipboard

Copied

LATEST

I found the issue, actually there was mismatch between server version and SDK version

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines