Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Single and double quotes are appearing straight, not curly, despite settings.

Explorer ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Hello, I am editing a prose InDesign document. All existing instances of single and double quotes are typographers quotes (curly quotes). However, when I type and add new single and double quotes, they appear straight. In Preferences, I have type set to Typographer's quotes, and I have Dictionary quotes set to curly quotes. I know that I can use keyboard shortcuts to type curly quotes (Shift and Option with bracket key), and that works, but what a pain. There are a few instances where I need straight quotes, like in expressing geographic coordinates minutes and seconds, but 99.9% of the time, I need curly quotes. I have the latest versions of Mac and Indesign. Any help would be much appreciated on how to fix this problem.

TOPICS
Bug, Type

Views

78

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Sep 05, 2021 Sep 05, 2021
Hi @tturiano: My guess is that the command is unchecked for that one file. Do curly quotes work correctly in the other files? If it's just the one file, open the file, then open Prefs and make sure it is enabled. If all files, and if the command is enabled with all files closed, consider rebuilding cache/preferences.  https://www.rockymountaintraining.com/adobe-indesign-rebuilding-preferences-cache/ ~Barb 

Likes

Translate

Translate
Adobe Community Professional ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Under the InDesign menu  Edit > Find/Change menu, from the Query drop-down, select Straight single (or double) typographers quotes, or change them in Glyphs.

If you're Placing a Word file via the Microsoft Word Import Options dialogue box, you can select "Use Typographer's Quotes" as an option.

 

Screenshot 2021-09-04 at 15.42.49.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Thanks for the tip Derek. Your suggestion, using Find/Change, is a way to go back afterward and fix them all, correct? That is what I have been doing, but I would rather have them appear correctly as I type. I am not importing from Word. What about your Glyphs panel suggestion? Is there a way in that panel to edit which glyph appears when I type the apostrophe and quotes key? I will play around with that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Are your text with applied paragraph style and with applied your language?

Remember, never say you can't do something in InDesign, it's always just a question of finding the right workaround to get the job done. © David Blatner

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

quote

Is there a way in that panel to edit which glyph appears when I type the apostrophe and quotes key?


By @tturiano

 

Enable Use Typographers Quotes in Prefs > Type to get them while typing.

 

quoted.png

 

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 04, 2021 Sep 04, 2021

Copy link to clipboard

Copied

Thanks Barb. I already tried that. Even with that setting, the quotes and apostrophes still type straight, rather than curly. My question that you quoted refers to the Glyph panel, no the Preferences>Type panel. I was wondering if there is a way to edit the CID/GID number that is assigned to the keyboard keys for quotes and apostrophes to select the curly glyph, rather than the straight glyph.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 05, 2021 Sep 05, 2021

Copy link to clipboard

Copied

Hi @tturiano:

 

My guess is that the command is unchecked for that one file. Do curly quotes work correctly in the other files?

 

If it's just the one file, open the file, then open Prefs and make sure it is enabled. If all files, and if the command is enabled with all files closed, consider rebuilding cache/preferences. 

https://www.rockymountaintraining.com/adobe-indesign-rebuilding-preferences-cache/

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

LATEST

Barb, you were right. Prior to posting, I had kept checking the Preferences>Type>Use Typographers Quotes box, but I wasn't doing it at the right time relative to typing and testing it...and I was doing it on some files and not on others...and getting confusing feedback...but right after you sent this message to me, I tried it again, and it started working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

"However, when I type and add new single and double quotes, they appear straight"

 

Hi tturiano,

how is your text formatted with property language?

Is it perhaps set to [No Language]? Then you always type straight quotes by default.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines